asa 55xx vpn problem

Unanswered Question
Jul 2nd, 2010
User Badges:

Hi,

have an ASA 5505 with version 8.3 ..... create a remote vpn tunnel but i can`t connect from the client. Don`t know why. Here is the config:


ASA Version 8.3(1)
!
hostname ASA
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.16.23.5 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa831-k8.bin
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
domain-name
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network network-obj-172.16.23.0
subnet 172.16.23.0 255.255.255.0
object network network-obj-10.100.100.0
subnet 10.100.100.0 255.255.255.192
object network network-obj-172.16.23.22
host 172.16.23.22
object network network-obj-188.188.242.118
host 188.188.242.118
object network network-obj-194.124.0.0
subnet 194.124.0.0 255.255.255.0
description PROXY
object network NETWORK_OBJ_10.100.100.0_26
subnet 10.100.100.0 255.255.255.192
access-list vpnsafe_splitTunnelAcl standard permit 172.16.23.0 255.255.255.0
access-list global_access remark MAIL_HTTPS
access-list global_access extended permit tcp any object network-obj-172.16.23.22 eq https
access-list global_access remark MAILSMTPOUT
access-list global_access extended permit tcp object network-obj-172.16.23.22 any eq smtp
access-list global_access remark BLOCK
access-list global_access extended deny tcp 172.16.23.0 255.255.255.0 any eq smtp
access-list global_access remark IPTRAFFIC
access-list global_access extended permit ip 172.16.23.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPOOL 10.100.100.10-10.100.100.50 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static network-obj-172.16.23.0 network-obj-172.16.23.0 destination static network-obj-10.100.100.0 network-obj-10.100.100.0 description Allow VPNPOOL to the inside Network
nat (inside,outside) source static network-obj-172.16.23.22 network-obj-188.188.242.118 description Mailserver
nat (inside,outside) source static network-obj-194.124.0.0 network-obj-194.124.0.0 description PROXY
nat (inside,outside) source static any any destination static NETWORK_OBJ_10.100.100.0_26 NETWORK_OBJ_10.100.100.0_26
!
object network obj_any
nat (inside,outside) dynamic interface
access-group global_access global
route inside 194.124.0.0 255.255.255.0 172.16.23.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server rsa protocol radius
aaa-server rsa (inside) host 172.16.23.20
key *****
radius-common-pw *****
http server enable
http 172.16.23.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp inside
sysopt noproxyarp outside
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
telnet 172.16.23.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside
dhcpd auto_config outside
!




threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy vpnsafe internal
group-policy vpnsafe attributes
dns-server value 172.16.23.21
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnsafe_splitTunnelAcl
default-domain value
tunnel-group vpnsafe type remote-access
tunnel-group vpnsafe general-attributes
address-pool VPNPOOL
default-group-policy vpnsafe
tunnel-group vpnsafe ipsec-attributes
pre-shared-key *****
!
!
prompt hostname context
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email [email protected]
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:ef97a0e36258db4e0015a80d2542f80b
: end



And here the client LOG:


29     15:52:18.140  07/02/10  Sev=Info/4    CM/0x63100002
Begin connection process




30     15:52:18.172  07/02/10  Sev=Info/4    CM/0x63100004
Establish secure connection




31     15:52:18.172  07/02/10  Sev=Info/4    CM/0x63100024
Attempt connection with server "198.166.23.2"




32     15:52:18.182  07/02/10  Sev=Info/6    IKE/0x6300003B
Attempting to establish a connection with 198.166.23.2.




33     15:52:18.195  07/02/10  Sev=Info/4    IKE/0x63000001
Starting IKE Phase 1 Negotiation




34     15:52:18.200  07/02/10  Sev=Info/4    IKE/0x63000013
SENDING >>> ISAKMP OAK AG (SA, KE, NON, ID, VID(Xauth), VID(dpd), VID(Frag), VID(Nat-T), VID(Unity)) to 198.166.23.2




35     15:52:18.622  07/02/10  Sev=Info/4    IPSEC/0x63700008
IPSec driver successfully started




36     15:52:18.622  07/02/10  Sev=Info/4    IPSEC/0x63700014
Deleted all keys




37     15:52:23.692  07/02/10  Sev=Info/4    IKE/0x63000021
Retransmitting last packet!




38     15:52:23.692  07/02/10  Sev=Info/4    IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 198.166.23.2




39     15:52:28.762  07/02/10  Sev=Info/4    IKE/0x63000021
Retransmitting last packet!




40     15:52:28.762  07/02/10  Sev=Info/4    IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 198.166.23.2




41     15:52:33.865  07/02/10  Sev=Info/4    IKE/0x63000021
Retransmitting last packet!




42     15:52:33.865  07/02/10  Sev=Info/4    IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 198.166.23.2




43     15:52:38.940  07/02/10  Sev=Info/4    IKE/0x63000017
Marking IKE SA for deletion  (I_Cookie=1E4B877E28F57D6C R_Cookie=0000000000000000) reason = DEL_REASON_PEER_NOT_RESPONDING




44     15:52:39.450  07/02/10  Sev=Info/4    IKE/0x6300004B
Discarding IKE SA negotiation (I_Cookie=1E4B877E28F57D6C R_Cookie=0000000000000000) reason = DEL_REASON_PEER_NOT_RESPONDING




45     15:52:39.450  07/02/10  Sev=Info/4    CM/0x63100014
Unable to establish Phase 1 SA with server "198.166.23.2" because of "DEL_REASON_PEER_NOT_RESPONDING"




46     15:52:39.450  07/02/10  Sev=Info/5    CM/0x63100025
Initializing CVPNDrv




47     15:52:39.490  07/02/10  Sev=Info/6    CM/0x63100046
Set tunnel established flag in registry to 0.




48     15:52:39.490  07/02/10  Sev=Info/4    IKE/0x63000001
IKE received signal to terminate VPN connection




49     15:52:39.965  07/02/10  Sev=Info/4    IPSEC/0x63700014
Deleted all keys




50     15:52:39.965  07/02/10  Sev=Info/4    IPSEC/0x63700014
Deleted all keys




51     15:52:39.965  07/02/10  Sev=Info/4    IPSEC/0x63700014
Deleted all keys




52     15:52:39.965  07/02/10  Sev=Info/4    IPSEC/0x6370000A
IPSec driver successfully stopped

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Federico Coto F... Sat, 07/03/2010 - 16:42
User Badges:
  • Green, 3000 points or more

Hi,


In previous versions, the clients won't connect if using phase 1 DES and SHA

So, try changing your policy from:


crypto isakmp policy 10
authentication pre-share
encryption des
hash sha
group 2

To:


crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2

Federico.

Actions

This Discussion