Cisco 871W PPPOE Configuration

Unanswered Question
Jul 2nd, 2010

Hey guys,

I have a cisco 871W connected to a dsl modem that is in bridge mode. Currently I am having problems getting my Router to connect to my Att DSL modem. When I do a show ip int brief the fastethernet4 connection is not getting a public IP address. I have a basic understanding of cisco routers but I can't seem to figure out what is wrong with this configuration. I also feel like I have allot of "Pork" in my configuration so if you see something I don't need please let me know, for example I am not sure if I need dialer groups or vpdn.

Thanks,

David

service password-encryption
hostname Cisco871W
enable secret
enable password
aaa new-model
aaa authentication login default local
aaa authorization exec default local
aaa session-id common
ip http server
ip http secure-server
line con 0
password
line vty 0 4
password
ip domain name att.net
no ip domain lookup
username privilege 15 password
ip dhcp excluded-address 172.16.1.1 172.16.1.99
ip dhcp excluded-address 172.16.2.1 172.16.2.99
service dhcp
ip dhcp pool Internal-net
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
import all
domain-name att.net
lease 4
ip dhcp pool VLAN20
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
import all
domain-name att.net
lease 4
vpdn enable
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username [email protected] password password
ppp ipcp dns request
ppp ipcp address accept
access-list 1 permit 172.16.1.0 0.0.0.255
access-list 1 permit 172.16.2.0 0.0.0.255
dialer-list 1 protocol ip list 1
ip nat inside source list 1 interface Dialer1 overload
ip access-list extended Guest-ACL
deny ip any 172.16.1.0 0.0.0.255
permit ip any any
interface FastEthernet4
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
ip route 0.0.0.0 0.0.0.0 Dialer1
interface FastEthernet0
spanning-tree portfast
interface FastEthernet1
spanning-tree portfast
interface FastEthernet2
spanning-tree portfast
interface FastEthernet3
spanning-tree portfast
bridge irb
interface Dot11Radio0
encryption vlan 1 mode ciphers tkip
encryption vlan 20 mode ciphers tkip
ssid GuestWLAN
vlan 20
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii password
ssid InternalWLAN
vlan 1
authentication open
authentication key-management wpa
wpa-psk ascii password
channel 1
no cdp enable
no dot11 extension aironet
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no snmp trap link-status
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
interface Dot11Radio0.20
description Guest wireless LAN - routed WLAN
encapsulation dot1Q 20
ip address 172.16.2.1 255.255.255.0
ip access-group Guest-ACL in
ip nat inside
interface Vlan1
description Internal Network
ip nat inside
ip virtual-reassembly
bridge-group 1
bridge-group 1 spanning-disabled
interface BVI1
description Bridge to Internal Network
ip address 172.16.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
bridge 1 route ip
int f0
no shut
int f1
no shut
int f2
no shut
int f3
no shut
int f4
no shut
int dot0
no shut
ip inspect name MYFW tcp
ip inspect name MYFW udp
ip access-list extended Internet-inbound-ACL
permit udp any eq bootps any eq bootpc
permit icmp any any echo
permit icmp any any echo-reply
permit icmp any any traceroute
permit gre any any
permit esp any any
int dialer1
ip inspect MYFW out
ip access-group Internet-inbound-ACL in

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 07/04/2010 - 05:08

Hello Dsheli,

>> for example I am not sure if I need dialer groups or vpdn.

vpdn were needed in older IOS images. You are missing the point of application of PPPoE

your fas4 need a command to make it the "physical interface" to be used by PPPoE

int fas4

! old command

! pppoe enable 
! needed one:
pppoe-client dial-pool-number 1

see

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoenat.html#wp1234804

follow the link above to go on

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml#tshoot

it gives you the debug commands to be used

Hope to help

Giuseppe

Actions

This Discussion