AnyConnect on XP SP3 VPN client driver has encountered an error

Unanswered Question
Jul 2nd, 2010

Hello, and thank you for reading my post - apologies if this question has been answered, I couldn't find it.

I am running AnyConnect client version 2.5.0217 on a Dell Vostro 1500 running XP Professional SP3. When I try to connect to my customer's VPN, the client accepts my username and password, checks for profile updates, provides a security alert to have me verify the server's certificate (because their cert name does not match the server name), allows me to accept the certificate, tries to establish a vpn session and then ends with two messages.

The first is error message is "The VPN client driver has encountered an error." with an event log entry of:

Function: ConnectMgr::launchCachedDownloader

File: .\ConnectMgr.cpp

Line: 5040

Invoked Function: ConnectMgr :: launchCachedDownloader

Return Code: 3 (0x00000003)

Description: Cached Downloader terminated abnormally

and the second is "AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again." with an event log entry of:

Function: ConnectMgr::processIfcData

File: .\ConnectMgr.cpp

Line: 1956

Invoked Function: ConnectMgr::processIfcData

Return Code: -33554423 (0xFE000009)

Description: GLOBAL_ERROR_UNEXPECTED

Does anyone have a helpful suggestion of what I can do to correct this problem?

Additional Information: I also get what I think is a related error when trying to connect to the same host with the same client software on a Dell SC-440 running Windows Server 2003 SP2. When the VPN client launches, it throws an unhandled exception at 0x7c84cdf2 in vpnui.exe: 0xC0000005: Access violation writing location 0x00000014. If I catch the error with a Visual Studio debugger session and continue logging in, I am able to establish the VPN tunnel, close the VS debugger and work on the remote network without problem. If I close the debugger before completing the VPN tunnel connection, the AnyConnect client closes. To add to the mystery, if I run a virtual machine on my laptop and launch AnyConnect from the guest OS, I am able to connect without incident. The guest VM (Server 2003) is bound to the same NIC that fails when used directly. It seems that if the AnyConnect client is running on a machine(virtual or metal) that has more than one NIC, it fails. It only seems to work on machines with one network adapter.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (1 ratings)
hwaghela Mon, 04/04/2011 - 03:31

"AnyConnect was not able to establish a connection to the specified secure gateway" ....

Try disable internet connection sharing. I had similar issues on Win 7 clients, running Anyconnect 2.5.1025, to ASA and using NAC agents. I'd get authentication working past Securid, however fail shortly afterwards.

Actions

Login or Register to take actions

This Discussion

Posted July 2, 2010 at 8:19 AM
Stats:
Replies:3 Avg. Rating:
Views:36994 Votes:0
Shares:0
Categories: AnyConnect
+

Related Content

Discussions Leaderboard