Problem with TCL script for outbound calls on CME

Unanswered Question
Jul 4th, 2010

Hi all,

I have a CME 7.0 and registered  a small analog gateway (like and ATA with 2 FXS ports). Is registered via SIP on the CME. Registration woks fine. I can make and receive call on the analog phones attached to the FXS ports.

I have also configured the acctfixedpin.tcl script and applied it on the dial-peers for outbound calls restrictions with a password.

The problem I'm facing is that even though the script is in place, when I make a call, the call is hitting the dial-peer with the script but the script is not executing. Hence, the "enter password audio" is not played, and the call goes through as if there was no application attached to the dial-peer.

I have used this application in many cases before and never had this issue. This is the first time I use it with this type of phone (analog gateway with 2 FXS ports).

Is there any restrictions on using this tcl script for SIP, third-party SIP or FXS port regitered on CME ?

I wolud appreciate any help.

Wilfred Diclo

Network Manager

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
wdiclo Mon, 07/05/2010 - 06:51

I have performed a debug on the dial-peer to get that information.

Also, as you menthioned on you email, I have set up a loopback voip DP.

This configuration works fine if I register the device (analog gateway with 2 FXS) on a call manager as third-party sip (advance), it works fine. The script execute perfectly, that makes me beleive that the script is fine, but for some reason it doesn't work when the device is register on the CME.



This Discussion