Recording and Monitoring issue in UCCX

Answered Question
Jul 6th, 2010

Hi,


I am unable to configure Monitoring/Recording as CDA gives an error "CDAUI1000 Error while trying to load the data.Ensure that the system path includes the location of the WebAdminLib.dll".I checked the dcoumentation and it says give the path in "environment variable" but I don't know how to do that.


Also besides this I am using 7942 IP phones which are connected to the same port as desktop but both of them are in different VLANs.Please let what additional configuration I will have to do to achieve desktop monitoring.


Regards


Amit Prasad

Attachment: 
Correct Answer by joesnyde about 6 years 7 months ago

Be sure to folow the steps below, and verify that the environment variable is moved to the begining of the string. These directions are from the CAD Error Code guide which are attached to the post.


Ensure that the system path includes the location of the WebAdminLib.dll. Type: Fatal Add’l Info: Error indicating that the location of the WebAdminLib.dll is not added to the System path. Action: On the Unified CCX server, add the location of the WebAdminLib.dll (C:\Program Files\Cisco\ Desktop\bin) to the Path environment variable.


1. In Control panel, launch the System utility.

2. On the Advanced tab, click Environment Variables.


3. From the list of system variables, select Path and click Edit.


4. In the Variable value field, locate the string C:\Program Files\Cisco\Desktop\bin; and, using cut/paste, move it to the beginning of the variable value string. This results in the DLL being accessed from the correct location.


5. Click OK and close the System utility.


6. Stop the Cisco Unified Node Manager.


7. On the Unified CCX server, delete the teamadmin folder from these locations: C:\Program Files\wfavvid\ tomcat_appadmin\webapps C:\Program Files\wfavvid\ tomcat_appadmin\work\catalina\localhost


8. Restart the Unified Node Manager, and wait two minutes.


9. Access Cisco Desktop Administrator and verify that you can navigate to the Services Configuration > Enterprise Data > Fields page.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
Soman Nair Tue, 07/06/2010 - 05:19

Hi,


Browse to the following location and add the path of WebAdminLib.dll.


Desktop> Right click on My Computer> Properties > Advanced tab > Environment variables

This should resolve a part of your problem.




Regards,

Soman Nair.


(Pls rate if this helps your query.)

amitprshad Tue, 07/06/2010 - 05:48

Hi Soman,


Thanks for your response I checked the environment variable the way you told but the "Path" environment variable is already updated with the correct path.I tried to put the value once again but I am still getting the same error on web CDA.


Any other idea on how to troubleshoot this.

Correct Answer
joesnyde Tue, 07/06/2010 - 06:37

Be sure to folow the steps below, and verify that the environment variable is moved to the begining of the string. These directions are from the CAD Error Code guide which are attached to the post.


Ensure that the system path includes the location of the WebAdminLib.dll. Type: Fatal Add’l Info: Error indicating that the location of the WebAdminLib.dll is not added to the System path. Action: On the Unified CCX server, add the location of the WebAdminLib.dll (C:\Program Files\Cisco\ Desktop\bin) to the Path environment variable.


1. In Control panel, launch the System utility.

2. On the Advanced tab, click Environment Variables.


3. From the list of system variables, select Path and click Edit.


4. In the Variable value field, locate the string C:\Program Files\Cisco\Desktop\bin; and, using cut/paste, move it to the beginning of the variable value string. This results in the DLL being accessed from the correct location.


5. Click OK and close the System utility.


6. Stop the Cisco Unified Node Manager.


7. On the Unified CCX server, delete the teamadmin folder from these locations: C:\Program Files\wfavvid\ tomcat_appadmin\webapps C:\Program Files\wfavvid\ tomcat_appadmin\work\catalina\localhost


8. Restart the Unified Node Manager, and wait two minutes.


9. Access Cisco Desktop Administrator and verify that you can navigate to the Services Configuration > Enterprise Data > Fields page.

Attachment: 
amitprshad Wed, 07/07/2010 - 00:00

Hi joesnyde ,


Thanks It worked.My one problem is resolved



I will now try to use desktop monitoring for my IP phones and update the post if I need the help again.


Regards


Amit

amitprshad Wed, 07/07/2010 - 03:55

Hi,


I am able to configure the Web CDA now but the Agent Recording/Monitoring is not working.


The scenario is this the agent is logged in using CAD and IP communicator installed on the same desktop and Supervisor is logged in on(both CAD and CSD) on his PC and is trying to monitor/record the agent's calls.


For Monitoring

Whenever I try to monitor then I get an error on CSD that packets not received from CAD

For Recording

When I click to record the call then the .wav file >1kb gets created and I am able to view the same in the “Supervisor Record Viewer” but there is no audio coming from the file.

I have already tested the NIC card of agent’s desktop using NICQ.exe utility and it has passed the test.Please help me with the same.

Regards

Amit

Attachment: 
Walter Solano Wed, 07/07/2010 - 05:12

Hello Amit,


I am wondering if you already checked this document, but its very good in terms of troubleshooting Desktop monitor, in case that you go through the document and you still having the issue please gather a sniffer trace in the CAD and CSD at the same time.


http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a008075025a.shtml



HTH

Please rate this post if was helpful


Walter Solano

CCVP, Cisco UCCX Specialist

Cisco IP Communications Express Specialist

amitprshad Wed, 07/07/2010 - 08:47

Hi Walter,


Thanks for the document.I will follow the steps in the document.Please let me know one thing that for Desktop Monitoring also I will have to connect the second NIC(for voip monitoring) of UCCX server or it is required only for SPAN monitoring.


Regards


Amit

Aaron Harrison Thu, 07/08/2010 - 03:01

Hi


Yes - the second NIC is generally used just for the packet sniffing style of recording.


For a desktop monitoring system I would just use a single NIC, and disable the secondary NIC completely (fault tolerance isn't supported on UCCX).


Regards


Aaron


Please rate helpful posts...

amitprshad Thu, 07/08/2010 - 06:06

Hi Aaron,


I followed the checklist document and have configured both the Agent and Suervisor desktop.Now I am able to see the NICQ_Output giving "all tests passed" (both the files are attached) but the recording or monitoring is still not happening.I am still getting the same error(error screenshot atached).


I did following things


1)Phones are daisy chained (that is the pc port is conected to PC and Switch port is connected to network port in the cubicle) for both Agent and Supervisor's IP phone


2)Span to PC enabled in both Agent and Spervisor's IP Phones

3)Web CDA configured for both Agent and Spervisor's IP Phones for desktop monitoring

4)Ran post install.exe on both Agent and Supervisor desktops and checked if the network adapter selected is correct



Please help me what should I check now.


Regards


Amit

Attachment: 
joesnyde Thu, 07/08/2010 - 06:24

Hi


First we need to find out if you are going to use SPAN or Desktop based recording. I believe you stated that the phones are on different vlans than the PCs. More than likely you will need to use SPAN. However, at the device (CUCM configuration) be sure that Span to PC port is enabled and that Advertise G722 is disabled, CAD does not support G722. If this is still failing you will need to get a packet capture from the PC to the server and to the supervisor desktop to determine where the packets are failing to be sent.


Joe

amitprshad Thu, 07/08/2010 - 06:40

Hi Joe,


I have planned to use Desktop based monitoring but Yes both my IP phones and Agent Desktops are in a different VLAN also I am using G.711 codec only for my IP phones.Now do I have to switch over to SPAN base monitoring in this case.


Regards


Amit

joesnyde Thu, 07/08/2010 - 06:45

Amit


At the device disable G722 just in case the CUCM system wide parameter has this enabled. You may have to start looking SPAN (server) based monitoring and recording.


Joe

amitprshad Thu, 07/08/2010 - 06:48

Hi Joe,


Please let me know how do i disable the G.722.I mean where do I have to disable that.


Regards


Amit

joesnyde Thu, 07/08/2010 - 06:54

Amit


To disable G722 at the device, open CCMAdmin page > Device > Phone > find the agent's phone > Scroll down until you find "advertise G722 codec" and select "disable". Save and apply config.



Joe

amitprshad Thu, 07/08/2010 - 09:13

Hi Joe,


Thanks!! It worked.


The Monitoring started working.


I am testing the "Recording" part and will let you the update if it works or not.


Regards


Amit

amitprshad Fri, 07/09/2010 - 00:53

Hi Joe,


The recording is also wroking now.Thanks a lot once again



Regards


Amit

Actions

This Discussion