SIP behaviour, callback failed

Unanswered Question
Jul 6th, 2010
User Badges:

Hi ALL,

My problem is:

I have a two site with 1760 routers  (2FXO port connected to PBX, 2 Cisco IP Phone connected via skinny, 2 IP Phone D-link connected via SIP), other site have same equpment. Calls from PBX phones from one site, to other site SIP phone FAILS (I can hear ring-ring,it's indicating on display, but when I offhook I heard a busy signal, when I get it onhook calls come again and again, but every time I just listening busy signal),but in other direction (from sip to pbx - works), situation same in both directions.All other calls i.e. from site 1 with Cisco skinny IP Phone to SIP Phone on site 2 works fine!

configs:

r1#

!


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  registrar server

!


voice register global

mode cme

source-address 192.168.1.5 port 5060

max-dn 144

max-pool 24

!

voice register dn  1

number 01000


voice register pool  1

id mac 0026.5A49.8F11

number 1 dn 1

dtmf-relay sip-notify

username 01000 password 01000

!


interface Ethernet0/0

description LINK TO SITE 2

ip address 192.168.2.1 255.255.255.252

full-duplex

!

interface FastEthernet0/0

ip address 192.168.1.5 255.255.255.128

speed auto

full-duplex

no cdp enable

!


dial-peer voice 900 voip

destination-pattern 02...

session target ipv4:192.168.2.2

!

dial-peer voice 901 pots

port 0/1

destination-pattern 011..

!


telephony-service

max-ephones 10

max-dn 20

ip source-address 192.168.1.5 port 2000

keepalive 45

max-conferences 8 gain -6

transfer-system full-consult

!

!

ephone-dn  1

number 01005

!


ephone  1

mac-address 0012.0127.85D7

button  1:1




r2#


!


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  registrar server

!


voice register global

mode cme

source-address 192.168.3.5 port 5060

max-dn 144

max-pool 24

!

voice register dn  1

number 02000


voice register pool  1

id mac 0036.5A49.8F12

number 1 dn 1

dtmf-relay sip-notify

username 02000 password 02000

!


interface Ethernet0/0

description LINK TO SITE 1

ip address 192.168.2.2 255.255.255.252

full-duplex

!

interface FastEthernet0/0

ip address 192.168.3.5 255.255.255.128

speed auto

full-duplex

no cdp enable



!


dial-peer voice 900 voip

destination-pattern 01...

session target ipv4:192.168.2.1

!

dial-peer voice 901 pots

port 0/1

destination-pattern 021..

!


telephony-service

max-ephones 10

max-dn 20

ip source-address 192.168.3.5 port 2000

keepalive 45

max-conferences 8 gain -6

transfer-system full-consult

!

!

ephone-dn  1

number 02005

!


ephone  1

mac-address 0022.0127.85D7

button  1:1








Please help me to find config bug

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
auppal Sat, 07/10/2010 - 10:06
User Badges:
  • Cisco Employee,

please collect

deb ccsip messages

and deb voip ccapi def for a failed call

Krasnoperov Sun, 07/11/2010 - 23:17
User Badges:

Hi, thanks for reply, here is debug output, but I have to change my config, but I change some address, so


r1# = do13#

source-address 192.168.1.5 port 5060 = source-address 192.168.113.5 port 5060

number 01000 = number 13009

ip address 192.168.2.1 255.255.255.252 = ip address 192.168.224.108 255.255.255.248

ip address 192.168.1.5 255.255.255.128 = ip address 192.168.113.5 255.255.255.128




Also I attache wireshark report

Attachment: 
auppal Mon, 07/12/2010 - 07:12
User Badges:
  • Cisco Employee,

So i see 192.168.1.113 disconnecting the call. Can you collect the same debugs from that router please include all the debugs in one file


deb vpm sig

deb voip ccapi def

deb ccsip messages


Thnx

Krasnoperov Wed, 07/14/2010 - 02:59
User Badges:

Thank for your replays, I think I find out what was wrong in my config, on a working routers FXO ports were joined to trunkgroop,

I meen

for instance


!

trunk group FXO

!

voice-port 2/0

trunk-group FXO

!


voice-port 2/1

trunk-group FXO

!


dial-peer voice 290 pots

destination-pattern 41...

trungroup FXO

!


And for some reason, calls to SIP phones fails. When I do my config without trunkgroup, calls begin to come


!


voice-port 2/0

!

voice-port 2/1

!


dial-peer voice 290 pots

destination-pattern 41...

port 2/0

!


dial-peer voice 290 pots

destination-pattern 41...

port 2/1


Why so?

Thanks


Actions

This Discussion