MGCP registration

Unanswered Question
Jul 6th, 2010

Hi Experts,


Its hard to believe but i  am unable to register a cisco 2801 VGW as MGCP, i have deployed numerous MGCP Gws in past but this one has been troubling me for past one week. I tried all the options in the world but cant figure it out.


i have a 2801 gw with 1 ISDN T1 PRI, as soon as i add the gw in CUCM ( 7.0.2) the gw says unregistered while i flap the mgcp in the router ( mgcp/no mgcp) i can see that gw regiters momentarily for maybe 15-20 secs and finally comes back with status as unregisterd. On the GW i can see the isdn d channel is up and is backhauled to CCM ( shows in output of sh isdn status). Also show ccm shows that GW is registered to CUCM.




interstingly when i captured mgcp events debugs from gw and looked at them , the traces tells me that its name issue but i have tried to register the gw with domain name and without domain name and same result.I removed my name server/ domain name commands from gw and assigned a local hostname and used same hostname in the CCM admin page but in both instances the debugs  are same ie name issue.


any other ideas...im running latest ios ie 15.0 M and cucm version is 7.0.2.


here are debugs from GW and out put of sh ccm and sh isdn status cmds


thanks again

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish rawat Tue, 07/06/2010 - 09:19

testgw#sh ccm
MGCP Domain Name: testgw
Priority        Status                   Host
============================================================
Primary         Registered               10.236.103.6
First Backup    None
Second Backup   None

Current active Call Manager:    10.236.103.6
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            16:34:04 UTC Jul 6 2010 (elapsed time: 00:00:03)
Last MGCP traffic time:         16:34:04 UTC Jul 6 2010 (elapsed time: 00:00:03)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled
TFTP retry count to shut Ports: 2

Backhaul Link info:
    Link Protocol:      TCP
    Remote Port Number: 2428
    Remote IP Address:  10.236.103.6
    Current Link State: OPEN
    Statistics:
        Packets recvd:   2
        Recv failures:   0
        Packets xmitted: 3
        Xmit failures:   0
    PRI Ports being backhauled:
        Slot 0, VIC 1, port 0
Configuration Auto-Download Information
=======================================
No configurations downloaded
Current state: Waiting for commands
Configuration Download statistics:
        Download Attempted             : 8
          Download Successful          : 7
          Download Failed              : 1
          TFTP Download Failed         : 0
        Configuration Attempted        : 5
          Configuration Successful     : 0
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 5
Last config download command:
FAX mode: disable
Configuration Error History:
controller T1 0/0/0
linecode b8zs
end


controller T1 0/0/0
linecode b8zs
end


controller T1 0/0/0
linecode b8zs
end


controller T1 0/0/0
linecode b8zs
end


controller T1 0/0/0
linecode b8zs
end


TFTP File download failed

testgw#sh isdn st
Global ISDN Switchtype = primary-ni

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/1/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 3
    Total Allocated ISDN CCBs = 0

Actions

This Discussion