Why did my Port-Channel not come up.

Unanswered Question
Jul 6th, 2010
User Badges:

Can someone look at this configuration and help me troubleshoot why my port-channel did not come up?

I have a 6513 with a SUP 720 10G and a 4510 with SUP 6E. I installed new 10Gig uplinks and tried to configure a port-channel but could not get it to come up. Both the 10G uplinks showed UP and UP but my port channel never came up. Here is the config I was going to use.

6513

interface Port-channel2

switchport

switchport mode trunk

no shutdown

interface TenGigabitEthernet7/4

description UPLINK to 4500

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

udld port aggressive

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50

wrr-queue random-detect max-threshold 1 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80

rcv-queue threshold 1 50 50 60 60

rcv-queue threshold 2 60 80 100 100

mls qos trust cos

channel-group 2 mode active

!

interface TenGigabitEthernet8/4

description UPLINK to 4500

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

udld port aggressive

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50

wrr-queue random-detect max-threshold 1 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80

rcv-queue threshold 1 50 50 60 60

rcv-queue threshold 2 60 80 100 100

mls qos trust cos

channel-group 2 mode active

4510

interface Port-channel2

switchport

switchport mode trunk

no shutdown

interface TenGigabitEthernet5/1

switchport mode trunk

udld port aggressive

service-policy input VoIP-Input-COS-Policy

service-policy output VoIP-Output-Policy-10G

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

channel-group 2 mode active

no shutdown

!

!

interface TenGigabitEthernet6/1

switchport mode access

udld port aggressive

service-policy input VoIP-Input-COS-Policy

service-policy output VoIP-Output-Policy-10G

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

channel-group 2 mode active

no shutdown

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 07/06/2010 - 12:48
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Bill,

I would suggest to start with a simpler configuration:

remove UDLD

remove qos settings

start with physical interface in shut


use interface range to enable both interfaces at the same time and look at the log messages for any related event


Hope to help

Giuseppe

manish arora Tue, 07/06/2010 - 13:01
User Badges:
  • Silver, 250 points or more

Hey Bill ,

on the 4500 series switch , i can see the second port being configured as switch port mode access ... also if you have ports working as a trunk link why would you have them as spanning tree port fast configuration on it.

also , configure all you settings on the interface port channel and just have the physical interface as the part of that channel group.

Thanks

Manish

Bill19795_2 Tue, 07/06/2010 - 13:29
User Badges:

How about this:


6500

Default interface TenGigabitEthernet7/4

interface TenGigabitEthernet7/4

description UPLINK to 4500

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

Default interface TenGigabitEthernet8/4

interface TenGigabitEthernet8/4

description UPLINK to 4500

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface Port-channel2

switchport

switchport mode trunk

switchport trunk encapsulation dot1q

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50

wrr-queue random-detect max-threshold 1 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80

rcv-queue threshold 1 50 50 60 60

rcv-queue threshold 2 60 80 100 100

mls qos trust cos

no shutdown

4500


Default interface TenGigabitEthernet5/1

interface TenGigabitEthernet5/1

description ** CGCORP-6513-SW-3 5-24-2010 **

switchport mode trunk

channel-group 2 mode active

!

!

Default TenGigabitEthernet6/1

interface TenGigabitEthernet6/1

switchport mode trunk

channel-group 2 mode active

interface Port-channel2

description 10Gig to CGCORP-6513-SW-3

switchport

switchport mode trunk

service-policy input VoIP-Input-COS-Policy

service-policy output VoIP-Output-Policy-10G

no shutdown

manish arora Tue, 07/06/2010 - 14:16
User Badges:
  • Silver, 250 points or more

hey bill,

1> are you using ws-x6148(with or without v )-ge-tx switching module -- this one doesnot support more than 1 gbps in aggregated speed ?

2> mention lacp as protocol on both sides ?

3> try enabling "no mls qos channel-consistency"  on both ends of the port channel ?

4> double check speed and duplex on both ends , should be same for lacp to work.

5> the spanning tree port priority should be same for all ports in the port channel.

6>The trunking protocol should be same on both sides of the port channel.

7> Please show the output of the following :-

  a> sh etherchannel port-channel 2

  b>sh etherchannel 2 detail

  c> sh etherchannel summary


also, check the ports are forwarding in the spanning tree configuration wise.

Thanks

Manish

chireadorin Tue, 07/06/2010 - 14:33
User Badges:

I see dot1q trunk on Po2 - Te7/4 & Te8/4 - 6500
You should put dot1q on 4500 too , just to make sure. Maybe 4500 doesn't support dot1q. You can check it on the internet for that line card.
Try to use no int Po2 , then use int range and set parameters for group interfaces and issue also

switchport trunk encap dot1q
switchport trunk allowed vlan [vlans]
switchport mode trunk
switchport nonegociate
shutdown
no shutdown

channel-protocol lacp
channel-group 2 mode active

--
for troubleshooting:
show int trunk and paste only those intf
show etherchannel port

check if there is link on all interfaces.

show errdisable

show span sum



Make sure udld is disabled before testing, or put it to normal mode.


If still not working, try to skip the qos conf until you see link.

Actions

This Discussion