Multicast: switch doesn't accept proper RP-discovery message

Unanswered Question
Jul 7th, 2010

Hi all,

We have a very strange problem on a C6500 running 12.2(33)SXH4

We are using Auto-RP for Rendez-vous point distribution and this is working fine, only on one switch the

RP-discovery packet is ignored. See message below from "debug ip pim auto-rp"

Auto-RP(0): Received RP-discovery, from 10.96.24.4, ignored

Auto-RP(0): Received RP-discovery, from 10.96.0.1, ignored

I have no idea why this packets is 'ignored'. The system itself is a mapping agent (for other ranges), but that should not

prevent it from accepting other RP-discovery packets.

I have checked RPF failures. The routing table is correct so their should not be a problem here.

Below is the MC configuration (without ip pim on interfaces):

no ip pim dm-fallback

ip pim autorp listener

ip pim send-rp-announce Loopback100 scope 15 group-list SITE-RP

ip pim send-rp-discovery Loopback0 scope 15

ip pim rp-announce-filter rp-list RPS

ip pim accept-register list ALLOWED-MC-SOURCES

What i have noticed is the following:

from the moment that i remove "ip pim send-rp-discovery Loopback0 scope 15" (mapping agent), the switch accepts

the received update. When i put it in -> doesn't accept the update again. Very strange.

regards,

Geert

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Frank Li Mon, 01/18/2016 - 14:39

Hi Geert,

Not sure if you are still follow this question. I searched this: http://ieoc.com/forums/t/17606.aspx

Mapping Agent will ignore another MA advertisement; however both MAs will send out their advertisements, and all devices will hear both announcements.

Not sure if this statement is true, but I observed that the Mapping Agent is ignored RP discovery messages from other MAs as well.

Thanks.

Actions

This Discussion