Calling Party Transfomrations, where am i going wrong?

Unanswered Question
Jul 7th, 2010
User Badges:
  • Bronze, 100 points or more

Hi,


I have a gatekeeper with an GK ICT setup, I will be having a number of patterns going towards this trunk and unfortunately a number of route lists also. I want to prefix the intersite access code to the calling number using a Calling Party Transformation CSS.



I have created the following but the DNA does not display anything happening to the calling number.

Partition: TP_GK-CALLS

CSS: TCSS_GK-Calls


Calling Party Transformation Pattern:

Pattern: XXXX (to match the internal calling number)

Partition: TP_GK-CALLS

Calling Party Trans Mask:161XXXX (to prefix 161 to the internal 4 digit extension)



ICT GK Trunk:

Calling Party Transform CSS = TCSS_GK-Calls

Use Device Pool Calling Party Transformation CSS: Unchecked



Route-List: RL_AU-to-UK

RG Member RG_GK

Called Party Transformations - Prefix Digits #1


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Griffin Wed, 07/07/2010 - 16:50
User Badges:
  • Silver, 250 points or more

Transformation patterns, if used, override anything you did to the called party number on a route pattern.

If you want to prefix the '#1' to the called or calling party presented to the gatekeeper, do it in the transformation pattern. 

heathrw Wed, 07/07/2010 - 16:55
User Badges:
  • Bronze, 100 points or more

Thanks for the feedback, im having problems with the Calling Party using Calling Party Transformations using a Transformation CSS on the Trunk, the called party prefix is not causing any issues from what the DNA shows.

Steven Griffin Wed, 07/07/2010 - 17:04
User Badges:
  • Silver, 250 points or more

The DNA is not the greatest when it comes to showing what is actually presented to the gateway when you make a call using transformation patterns.  I find it is better to look at actual debugs on the voice gateway to findout what was presented.


What do your H.323 gatekeeper debugs show?


Why aren't you using the prefix field?  Have you just tried putting 161 in the prefix field instead of the using the mask field?

Actions

This Discussion