Not getting DHCP on corporate network but on guest-web

Unanswered Question
Jul 8th, 2010

We have two types of SSIDs:

1. The official one putting clients on our corporate network. This uses our regular DHCP-servers.

2. The guest-web where you end up on the DMZ. The Ancor-controller stands in as DHCP-server.

The Anchor-controller is on the same subnet as the regular controller while the regular DHCP-servers are several router hops away.

When connecting to the official SSID I pass the authentication but do not get a DHCP-address. When connecting to the guest-web there is no problem getting a DHCP-address.

The interface-ip is pingable from other subnets so I don't think the ip-connectivity is the problem.

We have had similar problems earlier and solved them by using backup from a working controller and just changing what is controller specific.

We're running on a WLC 4402 and during setup there was no question of whether this was to be a Layer2 or Layer3 network. In earlier releases that question has always shown up. Can this be the problem? If so, how do I correct it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jeffrey Keown Thu, 07/08/2010 - 13:18

WLC's have 'dhcp proxy' enabled by default.  This mechanism is similar to the 'ip helper' address configurations that you're probably familiar with on Cisco routers.

But the controller isn't a router...why dhcp proxy?

Due to the architecture of the WLC's dhcp proxy needs to be enabled for the controller's internal dhcp server to function.

So when you configure 'dhcp server' on your controller's interfaces, that's actually the proxy config to forward dhcp requests for the associated wlan's clients.

I'd start by making sure that the corresponding controller interface is pointing to the correct dhcp server.  Confirm that you can ping the dhcp server from the controller as well.

If this doesn't work, ssh into the controller and run a debug client while a failed dhcp attempt is being made:

This should give you a better indication as to what's wrong.



Nevyn Bergstrom Thu, 07/08/2010 - 22:56

This is a bit embarrassing... I had checked and double-checked everything which had something to do with the DHCP on the controller. What I had missed was that had gotten one digit wrong in the default gateway...

We had this problem (and then we had the correct default gateway) in an earlier release and when it happened again I jumped to conclusions.


Jeffrey Keown Fri, 07/09/2010 - 05:41

heh heh, no worries   happens to the best of 'em.

glad to hear that you got things working


This Discussion

Related Content



Trending Topics - Security & Network