Two DHCPs, one is slow to send the offer

Unanswered Question
Jul 9th, 2010

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

Hello, I have a small issue about DHCP, I need two servers of DHCP.

1 - Provide by Switch Cisco  range 172.17.52.0

2 - Provide by Windows Server range 10.10.10.0

Everything works ok, but when I have a Computer using vlan 101 (at interface GigabitEthernet2/0/1) the DHCP is to slow, at debug mode I can read no dhcp pool for vlan 101,

then I see forward to 10.10.10.253, but this process is to slow, my computer need about 30 seconds (at wireshark I watch about 10 lines of 0.0.0.0 255.255.255.255 resquest form the computer).

The configuration of the switch:

ip dhcp excluded-address 172.17.52.254

!

service dhcp

!

ip dhcp pool Wifi-Guest

   network 172.17.52.0 255.255.255.0

   default-router 172.17.52.254

   dns-server 8.8.8.8 4.2.2.2

!

interface Vlan100

description ### Wireless - SSID ###

ip address 172.17.52.254 255.255.255.0

!

interface Vlan101

description ### Wireless - SSID ###

ip address 10.10.10.254 255.255.255.0

ip helper-address 10.10.10.253

!

interface GigabitEthernet2/0/1

switchport mode access

switchport access vlan 101

spanning-tree portfast

spanning-tree bpduguard enable

My point is, how to disable DHCP server to vlan 101, I have try this:

ip dhcp excluded-address 10.10.10.1 10.10.10.254

but didn’t work... the speed is slow.

Also try to

interface Vlan101

no ip dhcp-server... but this command dont work obligate to "no ip dhcp server use subscriber-id"

Anyone have ideas to block or disable dhcp to vlan 101 on the switch dhcp server?.

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion