T1 PRI Configuration Help!

Unanswered Question
Jul 10th, 2010
User Badges:

Hi, I am trying to configure 2x E1/T1 cards in a back-to-back format like this 2801-->T1Crossover-->2811

However, both cards stay in the Layer 1: Deactivated state. I have followed config guides and cant see what I  am missing. My T1 cross over cable is 1-->4, 2-->5, 4-->1, 5-->2.


I have CD and AL lights on both routers, when I unplug the cable, they go to only CD, but the AL appears shortly after. If I reload the 2811, the T1 on the user side (2801) comes up.


2801 - c2801-adventerprisek9-mz.124-25b.bin

2811 - c2800nm-adventerprisek9-mz.124-20.T.bin


2811 Config (Network)

card type t1 0 0
network-clock-participate wic 0

isdn switch-type primary-ni
!
controller T1 0/0/0
framing esf
clock source internal
linecode b8zs
cablelength short 110
pri-group timeslots 1-24
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bchan-number-order ascending
no cdp enable
!
voice-port 0/0/0:23
!

!

!

Cisco2811#sh controll t1
T1 0/0/0 is down.
  Applique type is Channelized T1
  Cablelength is short 110
  Transmitter is sending remote alarm.
  Receiver has loss of frame.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info Firmware: 20071011, FPGA: 13, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (5 seconds elapsed):
     40955 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 5 Unavail Secs
  Total Data (last 6 15 minute intervals):
     43348407 Line Code Violations, 638 Path Code Violations,
     3 Slip Secs, 0 Fr Loss Secs, 6 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 6 Severely Err Secs, 5394 Unavail Secs
!

Cisco2811#sh isdn stat
Global ISDN Switchtype = primary-ni
ISDN Serial0/0/0:23 interface
        ******* Network side configuration *******
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        NLCB:Calls are Held because of T309= 90.000 seconds
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0
Cisco2811#sh controll t1
T1 0/0/0 is down.
  Applique type is Channelized T1
  Cablelength is short 110
  Transmitter is sending remote alarm.
  Receiver has loss of frame.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info Firmware: 20071011, FPGA: 13, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (154 seconds elapsed):
     1261414 Line Code Violations, 0 Path Code Violations
     2 Slip Secs, 1 Fr Loss Secs, 3 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 3 Severely Err Secs, 151 Unavail Secs



2801 Config (User)

card type t1 0 3

network-clock-participate wic 3
isdn switch-type primary-ni

!

controller T1 0/3/0
framing esf
linecode b8zs
cablelength short 110
pri-group timeslots 1-24
!

interface Serial0/3/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
voice-port 0/3/0:23
!

!
Cisco2801#sh isdn stat
Global ISDN Switchtype = primary-ni
ISDN Serial0/3/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 26
    Total Allocated ISDN CCBs = 0
Cisco2801#
!

Cisco2801#sh controll t1
T1 0/3/0 is down.
  Applique type is Channelized T1
  Cablelength is short 110
  Transmitter is sending remote alarm.
  Receiver is getting AIS.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info Firmware: 20090408, FPGA: 13, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (136 seconds elapsed):
     567692 Line Code Violations, 34 Path Code Violations
     9 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins
     6 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 121 Unavail Secs
Cisco2801#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sun, 07/11/2010 - 00:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Likely faulty cable. Moreover, you have not set isdn prototocol network.

mattiep00 Sun, 07/11/2010 - 00:41
User Badges:

Thanks for the quick reply - I've actualy tried 2 different cables, so hopefully its not that.


User my 'network' router I have:

interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!


So that should be there as well. Any other ideas?


Thanks,

Matt

Paolo Bevilacqua Sun, 07/11/2010 - 02:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Buggy IOS? Faulty HW?

Also try in E1 mode.

Tracy Larson Mon, 07/12/2010 - 08:12
User Badges:
  • Silver, 250 points or more

are you sure you need a cross over cable? To test your card, you could create a loop back cable and check for errors.

nevermind, missed the part of connecting two routers together.

Chad Stachowicz Wed, 01/04/2012 - 21:37
User Badges:
  • Silver, 250 points or more

Did you ever figure this out?  I am having the same issue, highly annoying.

Chad

Paolo Bevilacqua Thu, 01/05/2012 - 04:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What issue ? These are typicaly cabling or configuration issues.

Philip Denton Mon, 01/16/2012 - 17:27
User Badges:

Same here.  We have a local carrier who comes into the building via SIP then offers PRI handoff via some model of Cisco Voice Gateway.  We've connected the customer VG via T1 crossover cable but cannot get Layer 2 to come up - it just bounces between TEI_ASSIGNED and AWAITING_ESTABLISHMENT.  All I see in the Q921 debugs is outgoing messages:


*Jan 17 01:16:36.771: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

*Jan 17 01:16:36.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:37.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:38.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:39.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:40.771: ISDN Se0/1/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2

*Jan 17 01:16:45.771: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

*Jan 17 01:16:45.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:46.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:47.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:48.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:49.771: ISDN Se0/1/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2

*Jan 17 01:16:54.771: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

*Jan 17 01:16:54.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:55.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:56.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:57.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:16:58.771: ISDN Se0/1/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2

*Jan 17 01:17:03.771: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

*Jan 17 01:17:03.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

*Jan 17 01:17:04.771: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Aaron Harrison Mon, 01/16/2012 - 23:36
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

All tx, no rx... if you are happy with your config then speak to the service provider.


If not sure, post up your config, show isdn status and show controller t1/e1 output.


Regards


Aaron Harrison

Principal Engineer at Logicalis UK


Please rate helpful posts...

Actions

This Discussion