SRW248G4 Firmware v1.2.3.0

Unanswered Question
Jul 12th, 2010

Hi,

We finally got around to sending our broken SRW248G4 back to Cisco, which they promptly replaced (well done ),

However, when i got it back, i decided to deploy the latest firmware - v1.2.3.0 from the Cisco downloads site, the upgrade went well but on starting up i am now no longer able to access the web UI config interface - i get the problems i previously had before applying the IE workaround bug. No amount of fiddling with IE settings and versions managed to make it work.

OK i thought, that firmware is broken, i'll downgrade. Downgraded with the console interface and TFTP - v1.2.2b - downgrade went well, however the web UI still doesn't work.

On our other identical switch v1.2.2b works fine so i can't understand what's wrong.

Anyone any ideas? I tried two firmwares and factory resets to no avail.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hornstein Mon, 07/12/2010 - 08:30

Hi dave-lew,

I just checked the release notes, and it mentions the following, I just hope it's this simple, let me know if it fixes your problem;

Web GUI

GUI does not work if there is only one user "Admin". The Menu CLI works.

If you change the username to Admin1 or anything else, it works.

If you have another user name or names in addition to Admin, this also works.

See http://www.cisco.com/en/US/docs/switches/lan/csbms/srw224g4_srw248g4/release/notes/SRW224G4-248G4_V1.1_Firmware_V1.2.3.0.pdf

I hope this works for you otherwise make a call to the Small Business Support Center again.

I can only apologize for this trouble you are having.

regards Dave

dave-lew99 Mon, 07/12/2010 - 09:02

Hi Dave,

I'd already tried that for both 1.2.2b and 1.2.3, what i can't understand is that it's not working with 1.2.2b either, yet it was when it arrived and our other identical switch is working fine.

As i said in my original thread (see https://supportforums.cisco.com/thread/2023362/) i'd be quite happy only using the CLI but it doesn't offer access to all the features.

dave-lew99 Mon, 08/02/2010 - 03:56

Quick Update:

After being sat on my desk for a couple of weeks i decided to give it another go, re-flashed to 1.2.2b and it's now working.

Sounds like there's an uninitialised variable bug going on somewhere, it'd be interesting to review the code and see what it looks like.

Actions

This Discussion