VLan Mismatched on a 3560 switch

Unanswered Question
Jul 12th, 2010

Hi all,

I have a Cisco 3560 switch and it is connected through Manageable Linksys SRW2048 switch.

Since couple of day, I found it wasn't working well.

Here's the error message that I'm getting regularly when connected to the Console :

00:44:00: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/6 (3), with S2IWEB_LanEx FastEthernet0/1 (1).
00:44:00: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/6 (3), with S2IWEB_LanEx FastEthernet0/2 (1).
00:44:00: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/2 (1), with S2IWEB_LanEx FastEthernet0/6 (3).
00:44:00: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (1), with S2IWEB_LanEx FastEthernet0/6 (3).

For your information,

- Interface FastEthernet 0/6 is connected to Port 1 in the SRW2048 which is configured in trunk mode.

- Interface FastEthernet 0/2 is connected to Port 2 in the SRW2048 which is configured in Access Mode and is excluded from VLAN 536.

- Interface FastEthernet 0/1 is connected to Port 48 in the SRW2048 which is also configured in Access Mode and is excluded from VLAN 536.

Here's a part of the configuration of the Cisco Switch :

!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
description To 75Queen-LAN
switchport mode access
speed 100
duplex full
!
interface FastEthernet0/2
description VoiceVLAN
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 536
switchport mode trunk
!
interface FastEthernet0/3
description PTP/75Queen/80Queen
switchport access vlan 541
switchport mode access
!
interface FastEthernet0/4
description PTP/75Queen/iWebHochelaga
switchport access vlan 391
switchport mode access
!
interface FastEthernet0/5
description PTP/75Queen/iWebIDS
switchport access vlan 821
switchport mode access
speed 10
duplex full
!
interface FastEthernet0/6
description To 75Queen-NewLan
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/7
description To MTO Internet
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/8
description To MTO Trunk
switchport trunk encapsulation dot1q
switchport mode trunk
speed 10
duplex full
!
interface GigabitEthernet0/1
!
interface Vlan1
ip address 192.168.13.253 255.255.255.0
!
interface Vlan2
ip address 172.32.1.2 255.255.255.0
!
interface Vlan3
ip address 172.16.200.1 255.255.0.0
!
interface Vlan391
ip address 10.51.0.2 255.255.0.0
!
interface Vlan536
ip address 10.0.1.100 255.255.255.0
!
interface Vlan541
ip address 172.20.200.1 255.255.0.0
ip helper-address 192.168.13.5
!
interface Vlan821
ip address 10.50.0.2 255.255.0.0
!

So now, I need to know how to fix this because this situation give me hard times and I need to sleep

Any Q?

Best regards,

Stephane

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Nagaraja Thanthry Mon, 07/12/2010 - 13:11

Hello,

The reason you are getting the error message is because I think on one end,

you have assigned the port to VLAN 3 and on the other end the port is on a

different VLAN. You have two options one, make sure that both ends are

assigned to same VLAN. Other is to turn-off CDP on the ports that are

connected to other devices.

Hope this helps.

Regards,

NT

Ciscotinkadm Mon, 07/12/2010 - 18:34

But if I disable CDP, it won't fix the problem right?

If I don't fix it, my network will stay unstable and it could happen that my VLan came down and crash right? Because it happens some times...

Nagaraja Thanthry Mon, 07/12/2010 - 19:11

Hello,

In that case, the best solution would be to change the VLAN settings on one side of the connection so that they are consistent.

Regards,

NT

Ciscotinkadm Mon, 07/12/2010 - 19:37

Would it be possible to make a trunk on Interface FA0/1 and allow both VLan 1 and VLan 3?

Why? Long story... the short story will be : VLan 1 is the current IP Range of our Network and VLan 3 would be our new IP range. Many servers are on both range. Also, we have to Internet Link from 2 different providers. Some servers have 172.16.200.1 as default gateway but need to be on VLan 1 IP range...

I'm not sure if I'm clear enough.

Thanks

Leo Laohoo Mon, 07/12/2010 - 20:26

Would it be possible to make a trunk on Interface FA0/1 and allow both VLan 1 and VLan 3?

Sure.  Just change the settings:

switchport mode trunk

switchport trunk encap dot (not all switches will take this)

switchport trunk allow vlan 1,3

Ciscotinkadm Tue, 07/13/2010 - 04:47

On the other end, should I configure all my ports on the srw2048 to accepted VLan 1 and Vlan 3? Should VLan 3 be Tagged or Untagged?

Thanks

Ciscotinkadm Tue, 07/13/2010 - 05:55

leolaohoo a écrit:

Would it be possible to make a trunk on Interface FA0/1 and allow both VLan 1 and VLan 3?

Sure.  Just change the settings:

switchport mode trunk

switchport trunk encap dot (not all switches will take this)

switchport trunk allow vlan 1,3

I did the changes. I also unplugged the Interface 0/6.

The problem now is that 172.16.200.1 is unreachable. This cause some servers to be unreachable from the web...

Nagaraja Thanthry Tue, 07/13/2010 - 07:42

Hello,

I guess then the issue could be that you have 172.16.200.x subnet on VLAN3 on the core switch and on VLAN 1 on the access switches. The best option would be to keep the core on VLAN 3 (interface is on VLAN 3) and then change all ports on the access-switch to VLAN 3 along with its management VLAN. This would give you an easy fix without much hastle. But if you would rather not do that, then you can just ignore the messages or turn-off the CDP and not worry about it as the messages are informational only and will not affect your performance.

Hope this helps.

Regards,


NT

Leo Laohoo Mon, 07/12/2010 - 14:58

Native VLAN mismatch error means that your local switch, a 3560, port Fa 0/6 has native VLAN set to "3" while the remote end, S2IWEB_LanEx, port Fa0/1 is set to default native VLAN of "1".  The configuration of S2IWEB_LanEx, port Fa 0/1 will not have the lines of "switchport trunk native VLAN 1" because this is the default settings.

To solve this issue, you have to set either ends to the correct native VLANs of your choice using the command above.

Please don't forget to rate useful posts.  Thanks.

andrew.husking Tue, 07/13/2010 - 15:36

I agree with leolaohoo, i've had this issue before and all i needed to do to resolve this issue was change "switchport trunk native VLAN 1" to be the same as what the VLAN on the other side of the trunk was.

Cheers

Actions

This Discussion