MOH on SRST on 2900 Router

Unanswered Question
Jul 13th, 2010

Hi all,

I have a 2911 router running 15.1(1)T.  This also serves as a SRST gateway in the event of CUCM failure.  The challenge that I run into is that when I power the router on and the site falls into SRST I don't have any MOH.  If a reconnect the site and then break the WAN connection again (without doing any configs) MOH works perfectly.  From this point forward my MOH works.  If I power the router down though and test again - no MOH.  I wonder if anyone has run into an issue like this before.  Maybe a bug...


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
ichehouri Wed, 09/22/2010 - 06:09


i have the same setup with same 2921 gateways in remote sites and i want to configure MOH locally. can you please send me the config file or what need to be configured on both the gateway and cucm



Felipe Garrido Wed, 09/22/2010 - 06:18

Can you provide the following from the SRST gateway.

show run

show flash:


ichehouri Wed, 09/22/2010 - 07:01

Hi Felipe,

find attached the show run on my gateway (i do not have the show flash now but it is having the .wav file) note that i want to have MOH on the local gateways if the phones are registered with CUCM and in case of SRST.



ichehouri Fri, 09/24/2010 - 04:54


MOH is working for PSTN users in case of SRST from flash but not working between ip phones. Is this a known issue or it can be solved?

another question: can i have MOH from flash in case the phones are registered to CUCM? note that my ISP does not allow multicast if required

any ideas,


mightyking Fri, 11/26/2010 - 07:56


Did you manage to fix the internal MOH issue? I have the same problem.



ichehouri Fri, 11/26/2010 - 10:39


Yes my issue is solved now and i have MOH on local gateway in case or SRST and in case of phones registered to CUCM. the following is what i did on the gateway:

tftp-server flash:moh1.wav

ccm-manager music-on-hold


secondary-dialtone 0

max-conferences 8 gain -6

transfer-system full-consult

ip source-address port 2000

max-ephones 100

max-dn 150 dual-line

transfer-pattern .T

keepalive 10

voicemail 601012504

call-forward pattern .T

call-forward busy 601012504

call-forward noan 601012504 timeout 20

mwi relay

moh moh1.wav

multicast moh port 16384 route

cor incoming Internal-CSS default

cor incoming Local-CSS 1 601012002

cor incoming National-CSS 2 601012001

cor incoming Mobile-CSS 3 601012000

on the CUCM side you need to configure the MOH server with multicast and make sure the region between the MOH server and the phones is G711. you can do that by creating a Region for MOH and make relationship to other regions with G711



mightyking Sat, 11/27/2010 - 17:01

Thanks Ibrahim, I appreciate your help. My problem is with the Wireless phone only and it's just for the internal calls. The MOH for the PSTN calls works fine.


Felipe Garrido Mon, 11/29/2010 - 09:41

If it's only for the wireless IP phones, I would advise checking to see if multicast is enabled. If not, then do so and check to see if MoH is heard.


mightyking Wed, 12/01/2010 - 21:32

Are you talking about enabling the multicast in WLCs? Yes the multicast is enabled but MOH for the wireless phones is not working.




This Discussion

Related Content