disable Ping sweep discovery not possible

Answered Question
Jul 13th, 2010

Hi,

Earlier i used the ping sweep option for discovery purpose. I had problem with this feature so i disabled it.

Now I'm using the large CDP seed file for discovery.

Although i have disabled the ping sweep there are unreacheable  devices have been found by ping sweep modul.

Why is the ping sweep working?? How can i disable it  permanently??

Regards,

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 6 months ago

Try deleting the scheduled discovery, then recreate it.  See if Ping Sweeps come back.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
KAROLY KOHEGYI Wed, 07/14/2010 - 01:23

Hi Joe,

Thank for the links. Its are very useful.

I checked the /conf/csdiscovery/system-config.xml file which contains the following regarding to ping sweep :

- Selected="false" ClassName="com.cisco.nm.discovery.modules.pingsweep.PingSweepDiscoveryModule">
 
 
 
 
   .
   .
   .
 

I've compared  this the CDP module settings.  I think  the ping sweep is disable beause of Selected="false".

It is interesting that  LMS keeps the range setting in spite of it was deleted from discovery settings.

Now i try to delete the range settgins from the xml file mannually,

Finally i attached the screenshot about my discovery settings and  PING  seepd discovered devices

Regards,

Joe Clarke Wed, 07/14/2010 - 08:51

As I said in the document, scheduled Discoveries will store their configs under NMSROOT/objects/csdiscovery.  Check those CSDiscovery-config.xml files to see if Ping Sweep is still enabled.  You can also edit scheduled discovery settings through the GUI under Common Services > Device and Credentials > Device Discovery > Discovery Schedule.

KAROLY KOHEGYI Thu, 07/15/2010 - 02:23

Hi,

I checked the NMSROOT/objects/csdiscovery/xxx/CSDiscovery-config.xml files. The ping sweep selected state is false so i do not unterstand why run the ping sweep modul in discovery process.

it is very interesting if i run manually the discovery it runs well and stop and does not run the ping sweep!!!!!

The scheduled discovery process always start the ping sweep and the process is never ending. ( i have to stop it manually )

Finally i attached the NMSROOT/objects/csdiscovery/xxx/CSDiscovery-config.xml.

Regards,

NMSROOT/objects/csdiscovery/xxx/CSDiscovery-config.xml

Correct Answer
Joe Clarke Thu, 07/15/2010 - 19:16

Try deleting the scheduled discovery, then recreate it.  See if Ping Sweeps come back.

KAROLY KOHEGYI Fri, 07/16/2010 - 03:06

Hi Joe,

Thank you very much your assist.

The latest "Microsoft like" solution solved the problem.

I think it was a liitle bug!

Thanks

Regards,

Actions

This Discussion