MGCP Gateway fallback with CUCM 7

Unanswered Question
Jul 13th, 2010

I have a router 2811  ios version 12.4(22) and a Cucm7.

I want to setup the 2811 gateway with a fxo active port to act as a  fallback function for the Cucm.

I have setup the following commands:

-from the cucm /srst, add new- router`s ip and name, port 2000,

-in the device pool i have setup at srst the router`s name,

-in the gateway i have setup the router as new gateway, configured as mgcp, i have entered at the domain name tab: "router`s name".domain.com

- i have selected the subunit 0 in my case with the 2fxo, controlled as mgcp (AALN/S0/SU0/0@"router name''.domain.com)

On the router i configured :

R(config)#ccm-manager fallback

R(config)#application
R(config-app)#global
R(config-app-global)#service alternate Default
Router(config)# call-manager-fallback
Router(config-cm-fallback)# keepalive 60
Router(config)# call-manager-fallback
Router(config-cm-fallback)# ip source-address 10.x.x.x port 2002 strict-match  (10.x.x.x - router`s address)
Router(config-cm-fallback)# max-dn 24 dual-line preference 1
Router(config-cm-fallback)# max-ephones 24
Router(config-cm-fallback)# limit-dn 7911 2
If i type
cme#show ccm-manager fallback-mgcp
% Call Manager Application is not enabled

What am i missing here ...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Calin Cristea Fri, 07/16/2010 - 06:17

I have made the router to register with the CUCM, this is a part of the router`s config.

ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.X.X>X
ccm-manager config
!
mgcp
mgcp call-agent 10.X.X.X service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp rtp payload-type g726r16 static
!
mgcp profile default

The only problem that i have now is that ephone-dn assigned.

router#$CA35.C7D4 TCP socket:[2] activeLine:0 REGISTERED in SCCP ver 19/9
ephone-1[0] Mac:001F.CA35.C7D4 TCP socket:[2] activeLine:0 REGISTERED in SCCP ve       ^r 19/9

On show-ephone command, the available line doesn`t appear

ephone-1[0] Mac:0xxxxxxxxxx TCP socket:[2] activeLine:0 whisperLine:0  REGISTERED in SCCP ver 19/97 max_streams=5
mediaActive:0  whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0  reset_sent:0 paging 0 debug:1 caps:11
IP:1XXXXXX* 36015 7961   keepalive 38 max_line 34


I don`t have dhcp created, i have static ip.

Does anyone know why the phone failed to get a ephone-dn?

Calin Cristea Thu, 07/22/2010 - 03:54

Guys i`ve figer it out what it was. It was the damned 7911 phone. I think it was a firmware issue.

I`ve tested on my ip comunicator phone and it worked perfectly

Actions

This Discussion