IP Multicast Problem

Unanswered Question
Jul 14th, 2010
User Badges:

Dear All,


I am having problem with IP multicast in my environment. i have cisco 6500 core switch and cisco catalyst 3750 access switches. I am using all the switches as layer 2. I have different VLANS and on the firewall i am having the subinterfaces for the VLANs. The firewall VLAN interface is the gateway for each VLAN and the firewall doing all the routing.

on all the switches I enabled globally the mls Qos (no policy applied) and ip igmp snooping is enabled by default.

on the firewall (ASA 5540) I enabled the IP multicast and IGMP / Multicast forwarding is enabled on all the interfaces/subinterfaces.

also on the firewall it does not allow me to create a service policy with the option to enable the QoS priority (LLQ). It says first i need to configure the priority queue limit on the interfaces.

but when i go to Configuration > Properties > Priority Queue i do not see the VLANs subinterfaces. (because can not be applied to VLAN interfaces)

in all the 3750 switches if i run the command :

switch#sh ip igmp snooping querier

Vlan IP Address IGMP Version Port

-------------------------------------------------------------

2 10.2.0.1 v2 Po1

3 10.3.0.1 v2 Po1

4 10.4.0.1 v2 Po1

5 10.5.0.1 v2 Po1

6 10.6.0.1 v2 Po1

7 10.7.0.1 v2 Po1

these ip addresses are the vlan interfaces of the firewall.

I have the media server in Vlan 2 and i am able the see the multicast traffic from Vlan2 without any packet loss or delay.

But from the other VLANs i am able the see the traffic but only from one VLAN at a time with some packet loss and some delay.

so if i have multicast connections from VLAN3 then i am not able to get connections from the other VLANs  (4,5,6,7) at the same time.

any recommendation or advice?

Thank you for your kind support.

Regards,

mico

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion