Calling party hear ringing tone after answering the call

Unanswered Question
Jul 14th, 2010

I have SIP trunk from SIP provider, I configured the VG to run CUBE I can place calls to PSTN. but if some body called from PSTN to IP phone and the user answers the call the calling party still hear the ringing tone while the IP phone shows connected and counters count the seconds of the call.

there is another strange issue. after 10 seconds from answering the calls another call reach to the IP phone from the same calling number in other words you will see on the phone like this:

1 from 1237654  connected 13 s

2 from 1237654   (ringing)

after answering the second calls the call will disconnect ( but for the calling party still the call not answered at the end he receive call no answer)

I contacted the SIP provider and they inform me that they can not see any other invite message forwarded to my line.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ADAM CRISP Wed, 07/14/2010 - 14:29

Hi,

What scenario have you got? H323 -> SIP, or SIP to SIP?

Which PBX have you got?

I would check your codec support on the phone and trunks to make sure you've got compatability. H323 phones for example might be using faststart where the call is setup prior to media being negotiated. i.e. The SP sends an Invite to the Cube, H323 call setup to the phone and your phone could ring, but then when you pick up, have a codec incompatability. Just a guess, what's your setup? Can you provide some information on your setup

thanks

JustForVoice_2 Wed, 07/14/2010 - 15:21

Hi ADAM,

thank you for your reply,

I have H323 GW added to CUCM in CUCM I enabled faststart for in-band and out band. and I checked require MTP.

regarding the codec I am using G.711 A law. So, I forced this in the dial-peers for incoming and outgoing.

in the CUBE I allowed all connections.

Do you think it is codec issue??

I can place outside calls the problem just in incoming calls.

regards,

ADAM CRISP Thu, 07/15/2010 - 01:10

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

Hi

It’s difficult to know what’s wrong without seeing the config or debug output, so here’s an example of a CUBE working from H323 to SIP.

In this example I have explicitly split the calls into four dial-peers. i.e.

Incoming calls from SP, outgoing call to CUCM

Incoming calls from CUCM, outgoing call to SP

In this example we’re going from a private network to a public network. We’re terminating and originating calls on the CUBE, so there’s no need for NAT.


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

!Generic config!


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

voice service voip

address-hiding

allow-connections h323 to sip

allow-connections sip to h323

voice class codec 1

codec preference 1 g711alaw

!

interface GigabitEthernet0/0

ip address 10.1.1.98 255.255.255.0

load-interval 30

duplex auto

speed auto

h323-gateway voip bind srcaddr 10.1.1.98

!

interface GigabitEthernet0/1

ip address 255.255.255.224

ip access-group 123 in ! ***** please see footnote

load-interval 30

duplex auto

speed auto

!


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

Incoming call from SP to CUCM


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

The SP is pre-fixing calls with AAA so we can easily identify where they’re coming from and be 100% sure which dial-peer is in use.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

!

dial-peer voice 999 voip

description incoming SIP FROM SERVICE PROVIDER!

voice-class codec 1

voice-class sip asymmetric payload full

voice-class sip early-offer forced

session protocol sipv2

session target sip-server

session transport udp

incoming called-number AAA.+

dtmf-relay rtp-nte ! dtmf type used by SP

!

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

We now route the call to CUCM. We're taking the time to route any received DID to an extension 5001 for testing

We do this with a translation rule and an outgoing dial-peer

!

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

voice translation-profile 1001

  translate called 1001

!

voice translation-rule 1001

  rule 1 /.+/ /5001/

!

!

dial-peer voice 1001 voip

description H323 connection to CUCM

translation-profile outgoing 1001

preference 2

destination-pattern AAA123456789 !the DID sent by the SP.

b2bua

voice-class codec 1

session target ipv4:10.1.1.97 !CUCM

session transport tcp

dtmf-relay h245-alphanumeric !Our DTMF type

!



/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

Outgoing call to SP


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

Again, To aid routing we’ve configured CUCM to pre-fix calls with a string. In this example we’re using the prefix ‘836204'

!

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

dial-peer voice 998 voip

description Incoming H323 from CUCM

b2bua

voice-class codec 1

incoming called-number ^836204.+

dtmf-relay h245-alphanumeric

!

! and now we route to SP

!

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

voice translation-profile CUCM_to_SP

translate called 10

!

voice translation-rule 10

rule 1 /^836204\(.*\)/ /\1/

!

   !

dial-peer voice 5 voip

description Outgoing SIP TO SERVICE PROVIDER!

translation-profile outgoing CUCM_to_SP

destination-pattern ^836204.+

b2bua

voice-class codec 1

voice-class sip asymmetric payload full

voice-class sip outbound-proxy dns:SP's SBC

voice-class sip early-offer forced

session protocol sipv2

session target sip-server

session transport udp

dtmf-relay rtp-nte

!

sip-ua

sip-server dns.xxx

authentication xxx pass xxx realm xxx

access-list 123 permit ip to

access-list 123 permit udp to *****


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

*****Access list footnote *****

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

If you’re having media issues you could try allowing media traffic from to . Even though media is terminated on the CUBE's public IP and originated again on the private, I've seen examples where media is partially broken unless this is allowed.

eg access-list 123 permit udp ,

Try this as a last resort and if it works for you, please raise this with TAC because I'm sure it's not meant to be like this, but I’ve always been in a production environment with a customer when it’s cropped up.

Good luck.

Adam

JustForVoice_2 Thu, 07/15/2010 - 03:00

Tank you too much for you help.

I saw the configuration that you sent I do not know if it is exactly what I did,

I made the conifguration vey simple for testing and later on I will add more configuration, belwo is my configuration:

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323    
  no h225 timeout keepalive
sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1

interface GigabitEthernet0/0
description connected to SIP service provider

ip address


I did not create any translation rule for the time being, I just add the full 7-digit number to the IP phone as extension

dial-peer voice 100 voip

descrprtion for incoming calls from SIP Provider
destination-pattern 344....
session target ipv4:172.20.104.6

codec g711alaw
!

for ougoing calls this is one of the dial-peer:

dial-peer voice 110 voip
destination-pattern 07........
session protocol sipv2
session target ipv4:IP-address for the SIP provider
incoming called-number .
dtmf-relay rtp-nte
codec g711alaw
no vad

sip-ua
retry invite 5
retry notify 5
retry register 5
sip-server ipv4::IP-address for the SIP provider
host-registrar

if you need I can collect some debugs ,

agin thank you for your help

ADAM CRISP Thu, 07/15/2010 - 03:18

Hi,

Is  interface GigabitEthernet0/0 reachable by the SP?

it not get rid of the SIP bind commands.

BRB

JustForVoice_2 Thu, 07/15/2010 - 03:44

I did not ask thm to ping it but for sure it is pingable because I can place and receive the calls, If I plcaed the calls then there is no issue so the reachability is there between me and SP

JustForVoice_2 Thu, 07/15/2010 - 16:16

I tried to troubleshoot the problem with the provider and they said that after sending the invite message there is no reply from my side they can see ringing but the call not answered, at the end they receive error message which is 503.

I checked the 503 error message and it is mean Service un-available?

Any body know what is the meaning of service unavailable?

where I should look? and what  may cause the problem??

ADAM CRISP Fri, 07/16/2010 - 00:51

The 503's not telling you much, other than the other end isn't available.

With your scenario, there's a SIP dialogue that starts between the SP and the CUBE.

As soon as the initial SIP Invite hits the Cube, there's a similar but separate H323 dialogue that starts between the CUBE and CUCM, which hopefullys results in some RTP sockets being opened and a call completing

1. Make sure your IP connectivity is OK.

2. debug ccsip messages and confirm you have a working dialogue

3. similarly look at the h323 debug and look to see if anything stands out.

You could post some debug outputs...

Adam

Actions

This Discussion