Sip passing through nat but rtp is not - no audio

Unanswered Question
Jul 14th, 2010
User Badges:

I'm looking at traffic leaving my router with a sniffer. I see SIP traffic but I do not see RTP traffic.  The phones ring on both sides but I do not get any audio.


interface f0/0.100

ip address 192.168.10.1 255.255.255.0

ip nat outside



ip nat pool VoIP 192.168.10.1  192.168.10.1 prefix-length 24

ip nat inside source route-map VoIP pool VoIP overload
ip nat inside source static tcp 10.1.1.2 49201 192.168.10.54 49201 extendable


access-list 1 permit ip host 10.1.1.2 any


!
route-map VoIP permit 10
match ip address 1
match interface  f0/0.100
set interface  f0/0.100

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
patricianet Thu, 07/15/2010 - 06:24
User Badges:

Do I need to enable anything voip related for this to work?


Like voice service voip ?

Nagaraja Thanthry Thu, 07/15/2010 - 06:46
User Badges:
  • Cisco Employee,

Hello,


You can enable "ip nat service sip" or "ip nat service h323" and "ip nat

service h225" commands. As per the documentation, they are enabled by

default. In the latest IOS there is a new feature added to Cisco IOS that

ensures that even RTP packets get translated to one of the allowed ports as

specified by the RFC. The command to enable the feature is "ip nat service

allow-sip-even-rtp-ports"


http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640...

d_white_paper0900aecd80597bc7.html


Hope this helps.


Regards,


NT

patricianet Mon, 07/19/2010 - 17:31
User Badges:

Ok I configured the portmap command and I still do not get any audio.


This works with a linksys router but not with a cisco 2600 router

saif musa Tue, 03/31/2015 - 23:20
User Badges:
  • Bronze, 100 points or more

Thanks Nagaraja Thanthry, that correct, I had the same issue and solved by using the instructions above ( ip nat service allow-sip-even-rtp-ports).

 

Regards

Actions

This Discussion