Translation rule help DID block to Internal DN

Unanswered Question
Jul 15th, 2010

I apologize in advance  if this is a duplicate post

Here is the existing rule where any calls to this range translates to 76000

rule 15 /^21255514..$/ /076000/

I need to change this rule to where the first 6 digits are stipped  leaving the last 2 and then I add 0 and 7 at the beginning

Im thinking

rule 15 /^21255514..$/ /0714../

The DID range is 2125551400 - 2125551414

The ultimate goal is

2125551400 translate to 071400

2125551401 translate to 071401

This is a 2851 router

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
thomuff Thu, 07/15/2010 - 08:18

I forgot to mention I already have other rules in place that are specific translations

For example

2125551415 translate directly to 076001

William Bell Thu, 07/15/2010 - 09:17

Maybe try this:

Voice translation-rule 2222

rule 1 /^21255514\(..\)/ /0714\1/

Sample test of rule:

iecube01#test voice translation-rule 2222 2125551400

Matched with rule 1

Original number: 2125551400     Translated number: 071400

Original number type: none      Translated number type: none

Original number plan: none      Translated number plan: none

iecube01#test voice translation-rule 2222 2125551401

Matched with rule 1

Original number: 2125551401     Translated number: 071401

Original number type: none      Translated number type: none

Original number plan: none      Translated number plan: none

HTH.

Regards,

Bill

Please remember to rate helpful posts.

William Bell Thu, 07/15/2010 - 09:27

Maybe try this:

Voice translation-rule 2222

rule 1 /^21255514\(..\)/ /0714\1/

Sample test of rule:

iecube01#test voice translation-rule 2222 2125551400

Matched with rule 1

Original number: 2125551400 Translated number: 071400

Original number type: none Translated number type: none

Original number plan: none Translated number plan: none

iecube01#test voice translation-rule 2222 2125551401

Matched with rule 1

Original number: 2125551401 Translated number: 071401

Original number type: none Translated number type: none

Original number plan: none Translated number plan: none

HTH.

Regards,

Bill

Please remember to rate helpful posts.

remi-reszka Fri, 03/04/2011 - 04:59

Hi William,

It´s a great post. Could you tell me what would best practise for apllying those rules to a dial-peer? I have a DID range 7282829271-299 and I need to translate them to DNs 101-139 and I am not sure yet how to apply the translarion rules to a dial-peer.

Thanks in advance.

William Bell Fri, 03/04/2011 - 11:26

You apply translation profiles to dial-peers as follows:

dial-peer voice 101 pots

translation-profile outgoing name-of-translation-profile

!

OR

dial-peer voice 102 pots

translation-profile incoming name-of-translation-profile

In dial-peer 101 the translation profile is applied to calls using this dial-peer for the outbound leg. For 102, the translation is applied to the inbound leg. In both cases the pattern assigned to the dial-peer is matched before applying the translation rule.

HTH.


Regards,
Bill

remi-reszka Sun, 03/06/2011 - 17:10

Hi William,

Once again thanks for the good clue. I did apply the rule to the dial-peer in outgoing direction to match outgoing call leg. It looks like the changed called ID does not make a change. However on the debug voice ccapi I can see that the rule ins being matched:

Calling Number=7282851072(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=017223306845(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=Red Logica
   Account Number=, Final Destination Flag=FALSE,
   Guid=50EE77A2-478D-11E0-8DA0-E359F099615A, Outgoing Dial-peer=912
040198: Mar  7 01:01:57.764: //923/50EE77A28DA0/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=7282851072
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=017223306845
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

The caller ID displays on the called phone as the main namber from the DID range 7282829270 and never begin desplayd as 7282851072. Would that be something with the voice service provider, shall I speak to them?

Thanks in advance.

William Bell Mon, 03/07/2011 - 06:38

Are the trunks to your carrier ISDN? If so, check "debug isdn q931" and see what you are sending to the carrier for the calling party IE. If you find you are still sending  7282851072 but the called party still sees 7282851070 then your carrier's CO switch is introducing the problem.

HTH>


Regards,
Bill

Actions

This Discussion