Access points joining different WLC

Answered Question
Jul 15th, 2010
User Badges:

hi


i have a wireless controller module( NME-AIR-WLC25-K9) installed in a Cisco 2851 ISR, this setup is in my remote site, we are connected through MAN network. In our main office i have a cisco 4402 wireless controller. so whenever i install a AP in my remote site instead of joiining the remote site WLC, the access point joins my main office 4402 controller, i dont why it is happening, the AP is not even trying to join the remote site WLC.. i have not configured high availability and both these controller are in separate RF network.


the firmware version in NME-AIR-WLC25-K9 is 7.0.98.0 ...

the version in the other controller is 6.0.196.0


Please let me know what is else i need to check asap


Thanks

karthik

Correct Answer by mirizarr about 6 years 9 months ago

Hi,

  Did you even see the AP trying to join the local controller?  If the controller are in different domains, the AP will prefer the remote controller since it join that one first.  Since you are running 5.2, try configure on the AP the primary controller with the name, and local IP address of the local controller, and then reboot the AP.  See if after that the AP join. run debug capwap events enable to see if you see the AP event trying to join the controller.


Regards,

Manuel

Correct Answer by Leo Laohoo about 6 years 9 months ago

That's not the point.


Presume you have two controllers:  WLC-A and WLC-B.


You have an AP who you want to join WLC-A but instead will always join WLC-B.


The solution is to configure "High Avlailability" with WLC-A details entered as the Primary Controller.  This will force the AP to join the correct controller:  WLC-A.


Does this answer your question?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
mirizarr Thu, 07/15/2010 - 12:52
User Badges:
  • Cisco Employee,

Hi,

  You should check if you have DNS configure to resolve to cisco-lwapp-controller or cisco-capwap-controller  to the correct controller.  Also, did you configure option 43 on the DHCP server to point to the correct controller.


Regards,

Manuel

karthikeyan gop... Fri, 07/16/2010 - 16:40
User Badges:

I added the dns configure to resove cisco-lwapp-controller and cisco-capwap-controller to the correct controller, also configured option 23 on the dhcp server, did vendor specific option to the controller, but the ap is still joining the remote controller instead of the one which is pointed or local...i seriously don’t know what is the issue

Leo Laohoo Fri, 07/16/2010 - 23:51
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Any particular reason why you don't want to configure "High Availability"?

karthikeyan gop... Sat, 07/17/2010 - 20:35
User Badges:

we have enabled mac-filtering and also one controller which support 50 ap is already with 48, the another one supports 25 and we have 24 ap so high availability is of no use

Attachment: 
Correct Answer
Leo Laohoo Sun, 07/18/2010 - 20:48
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

That's not the point.


Presume you have two controllers:  WLC-A and WLC-B.


You have an AP who you want to join WLC-A but instead will always join WLC-B.


The solution is to configure "High Avlailability" with WLC-A details entered as the Primary Controller.  This will force the AP to join the correct controller:  WLC-A.


Does this answer your question?

karthikeyan gop... Mon, 07/19/2010 - 10:51
User Badges:

To I need to configure it for each and every Access point which is having problem or a stand configuration in the controller

Leo Laohoo Mon, 07/19/2010 - 16:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

In your unique case, I'd configure HA on the AP that's misbehaving.


Please don't forget to rate our posts.  Thanks.

karthikeyan gop... Mon, 07/19/2010 - 17:05
User Badges:

Hi leo


I went to WCS and there was an option for AP configuration template, so through that I created a new template to forcefully join the primary controller and pushed it to the APs which have not joined the local controller. And it worked so perfectly. Thanks to you for your suggestions.

Leo Laohoo Mon, 07/19/2010 - 20:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Glad to hear it's working.  May I ask if you can mark this thread as "Answered" please?  Thanks.



it is running the new version 5.x

Cisco also recommends anyone to stay away from 5.X and 6.X.  If you need 802.11n support, use the newer 7.0 firmware.
Leo Laohoo Tue, 07/20/2010 - 22:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Thanks.


Glad to be of some assistance.

Correct Answer
mirizarr Mon, 07/19/2010 - 06:07
User Badges:
  • Cisco Employee,

Hi,

  Did you even see the AP trying to join the local controller?  If the controller are in different domains, the AP will prefer the remote controller since it join that one first.  Since you are running 5.2, try configure on the AP the primary controller with the name, and local IP address of the local controller, and then reboot the AP.  See if after that the AP join. run debug capwap events enable to see if you see the AP event trying to join the controller.


Regards,

Manuel

karthikeyan gop... Mon, 07/19/2010 - 10:38
User Badges:

I tried the see whether the AP is joining the local controller but it is not I enable debug capwap events in local wlc , but there is no event at all,

mirizarr Mon, 07/19/2010 - 10:45
User Badges:
  • Cisco Employee,

Hi,

Is that is the case, you probably better opening a TAC case so a TAC

engineer can review the switch, and wlc, and router config.


Regards,

Manuel

karthikeyan gop... Mon, 07/19/2010 - 10:59
User Badges:

I created a template and pushed to the Access points which were joined different controller to join their appropriate local controller. I cannot create a case because we don’t have current support contract on it

karthikeyan gop... Mon, 07/19/2010 - 17:06
User Badges:

Hi


I went to WCS and there was an option for AP configuration template, so through that I created a new template to forcefully join the primary controller and pushed it to the APs which have not joined the local controller. And it worked so perfectly. Thanks to you for your suggestions.

Leo Laohoo Thu, 07/15/2010 - 15:25
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless


i have not configured high availability and both these controller are in separate RF network.

Configure high availability will allow you to instruct the AP to join the WLC of your choice.  Let us know if you are running 4.X because this process needs to be done using CLI only.

karthikeyan gop... Thu, 07/15/2010 - 16:36
User Badges:

It is not running 4.x it is running the new version 5.x

The upgrade was done so that they can support 1142n Access points

Actions

This Discussion