Is using L2TP correct?

Unanswered Question
Jul 15th, 2010

Hello,

My company will be moving to a different building in the near future and we are looking for a way to move all of our equipments.

One idea was to see if we can have the same vlan and link it together over a T1 line.

I currently have two 2960 switches and two 7206VXR routers.

The routers has a 4 port T1 card installed.

I've read about using L2TP to do something similar to what we are trying.

My question is, is it correct to use L2TP to tunnel through a T1 line?

I've tried following some configuration examples and can't seem to make it work.

Below is the configuration from both routers.

If anyone could take a look at the configuration for errors, or if anyone can point me in the right direction on how to go about setting up the same vlan in the buildings, would be greatly appreciated.

Router A

hostname L2TP-TEST-ROUTER-A
!
boot-start-marker
boot system disk2:c7200-adventerprisek9-mz.124-6.T.bin
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip cef
!
no ip domain lookup
!
pseudowire-class A
encapsulation l2tpv3
protocol none
ip local interface Loopback0
!
controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
interface Tunnel1
no ip address
tunnel source 20.20.20.254
tunnel destination 30.30.30.254
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
ip address 20.20.20.254 255.255.255.0
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface Serial1/0:0
bandwidth 1544
no ip address
no ip proxy-arp
ip load-sharing per-packet
no cdp enable
xconnect 2.2.2.2 1 encapsulation l2tpv3 manual pw-class A
  l2tp id 1 1
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
!
ip route 0.0.0.0 0.0.0.0 20.20.20.1
ip route 2.2.2.2 255.255.255.255 Serial1/0:0

================================================================

Router B

hostname L2TP-TEST-ROUTER-B
!
boot-start-marker
boot system disk2:c7200-adventerprisek9-mz.124-6.T.bin
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip cef
!
no ip domain lookup
!
pseudowire-class B
encapsulation l2tpv3
protocol none
ip local interface Loopback0
!
controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
interface Tunnel1
no ip address
tunnel source 30.30.30.254
tunnel destination 20.20.20.254
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/1
ip address 30.30.30.254 255.255.255.0
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface Serial1/0:0
bandwidth 1544
no ip address
no ip proxy-arp
ip load-sharing per-packet
no cdp enable
xconnect 1.1.1.1 1 encapsulation l2tpv3 manual pw-class B
  l2tp id 1 1
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
!
ip route 0.0.0.0 0.0.0.0 30.30.30.1
ip route 1.1.1.1 255.255.255.255 Serial1/0:0

========================================================

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
alexht258 Fri, 07/16/2010 - 08:28

Hello Giuseppe,

Thank you for your response and the link to the documentation.

Actions

This Discussion