Error when enabling dhcprelay on ASA 5505

Unanswered Question
Jul 15th, 2010

Hello all, I am trying to setup dhcprelay on an ASA 5505, but I'm having an issue enabling the feature.  I removed the default dhcp server & range off the config and issue the following commands:

dhcprelay server LAN
dhcprelay setroute LAN
dhcprelay enable LAN

DHCP: There is a DHCP Server '' configured on interface 'LAN'!
DHCP Relay cannot receive DHCP requests and forward them on the same interface.

However, as you can see, I get an error when I try to enable dhcprelay on the LAN (inside) port. I am using a Windows 2008 Server as my DHCP server (will be plugged in to port 0/2). I have an ASA 5505 with the basic licensing package. Any help is greatly appreciated!

Here's my current config:

237fw(config)# sho run
: Saved
ASA Version 8.2(1)
hostname 237fw
domain-name accentrio
enable password d8EZWY4Wcs1LrAqo encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
interface Vlan2
description [RCN]
nameif WAN
security-level 0
ip address dhcp setroute
interface Vlan111
nameif LAN
security-level 100
ip address
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
switchport access vlan 111
interface Ethernet0/2
switchport access vlan 111
interface Ethernet0/3
switchport access vlan 111
interface Ethernet0/4
switchport access vlan 111
interface Ethernet0/5
switchport access vlan 111
interface Ethernet0/6
switchport access vlan 111
interface Ethernet0/7
switchport access vlan 111
ftp mode passive
dns server-group DefaultDNS
domain-name accentrio
pager lines 24
logging asdm informational
mtu WAN 1500
mtu LAN 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (WAN) 1 interface
nat (LAN) 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config WAN
dhcprelay server LAN
dhcprelay setroute LAN


threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server
class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
service-policy global_policy global
prompt hostname context
: end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
catterad77 Thu, 07/15/2010 - 19:02

Hi Marvin,

The error is more or less correct. You wouldn't need the FW to perform DHCP relay for hosts behind the LAN interface, as they can get to the DHCP directly as its more or less in a same subnet.

You need to change the dhcprelay enable and setroute commands  to the interface you want to listen for DHCP requests from hosts.

This page explains how to do it.




This Discussion

Related Content