QoS problems over an ethernet subinterface

Answered Question

Hello Everyone. My QoS problems I have on my HQ gateway (Cisco 2811) and my remote site (Cisco 1841) don't seem to be working and I have no idea why. Calls cut in and out very badly when the circuit is concentrated. On the cisco 1841, my voice traffic seems to be marked right and going to the right policy-map, but on the HQ side it doesn't seem to be doing that. Here is some info:

  1. Both sites are using one ethernet interface and split up by vlans (500 and 501) from our provider. The speed of the circuit is 3Mb/s. Please let me know if you need any more information. Thanks!
  2. --------------- HQ Gateway Cisco 2811 --------------------
  3. interface FastEthernet0/1
  4. bandwidth 3000
  5. no ip address
  6. no ip redirects
  7. no ip proxy-arp
  8. duplex auto
  9. speed auto
  10. !     
  11. interface FastEthernet0/1.500
  12. description "To Central Ave"
  13. encapsulation dot1Q 500
  14. ip address 192.168.0.17 255.255.255.252
  15. no ip redirects
  16. no ip proxy-arp
  17. service-policy output QoS_Albany_Parent
  18. !     
  19. interface FastEthernet0/1.501
  20. description "To New Karner Road"
  21. encapsulation dot1Q 501
  22. ip address 192.168.0.5 255.255.255.252
  23. no ip redirects
  24. no ip proxy-arp
  25. service-policy output QoS_Albany_Parent
  26. !
  27. !     
  28. mls qos map cos-dscp 0 8 16 26 34 46 48 56
  29. !
  30. !     
  31. class-map match-any dscp46
  32. match ip dscp ef
  33. match ip precedence 5
  34. !     
  35. !     
  36. policy-map AutoQoS-Policy-Trust
  37.   description QoS
  38. class dscp46
  39.   priority percent 35
  40. class class-default
  41.   fair-queue
  42. policy-map QoS_Albany_Parent
  43. class class-default
  44.   shape average percent 95
  45.   service-policy AutoQoS-Policy-Trust
  46. -----------------------------------------------------
  47. ---------- Router at remote site Cisco 1841 ---------
  48. interface FastEthernet0/1
  49. description "NKR Local to Latham"
  50. bandwidth 3000
  51. ip address 192.168.0.6 255.255.255.252
  52. no ip redirects
  53. no ip unreachables
  54. no ip proxy-arp
  55. ip nbar protocol-discovery
  56. duplex auto
  57. speed auto
  58. service-policy output QoS_NKR_Parent
  59. !
  60. !
  61. !     
  62. class-map match-any Voip-Control-Trust
  63. match ip dscp cs3
  64. match ip dscp af31
  65. class-map match-all Staff
  66. match ip dscp cs1
  67. class-map match-any VoIP-Trust
  68. match ip dscp ef
  69. match ip precedence 5
  70. class-map match-any AutoQoS-VoIP-Control-Trust
  71. match ip dscp cs3
  72. match ip dscp af31
  73. !     
  74. !     
  75. policy-map QoS-VoIP-Policy
  76.   description QoS for Albany 75% voice burst
  77. class VoIP-Trust
  78.   priority percent 35 300000
  79.   set dscp ef
  80. class AutoQoS-VoIP-Control-Trust
  81.   bandwidth percent 5
  82. class Staff
  83.   bandwidth percent 20
  84. class class-default
  85.   fair-queue
  86. policy-map QoS_NKR_Parent
  87. class class-default
  88.   shape average percent 95
  89.   service-policy QoS-VoIP-Policy
  90. ------------------------------------------------
  91. ------ Gateway Cisco 2811 show policy-map ------
  92. #show policy-map int fa0/1.501
  93. FastEthernet0/1.501
  94.   Service-policy output: QoS_Albany_Parent
  95.     Class-map: class-default (match-any)
  96.       25141425 packets, 22854129846 bytes
  97.       5 minute offered rate 347000 bps, drop rate 0 bps
  98.       Match: any
  99.       Traffic Shaping
  100.            Target/Average   Byte   Sustain   Excess    Interval  Increment
  101.              Rate           Limit  bits/int  bits/int  (ms)      (bytes)
  102.                95 (%)                0 (ms)      0 (ms)
  103.           2850000/2850000   17100  68400     68400     24        8550 
  104.         Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
  105.         Active Depth                         Delayed   Delayed   Active
  106.         -      0         25138587  1375033230 5043479   3112890157 no
  107.       Service-policy : AutoQoS-Policy-Trust
  108.         Class-map: dscp46 (match-any)
  109.           0 packets, 0 bytes
  110.           5 minute offered rate 0 bps, drop rate 0 bps
  111.           Match: ip dscp ef (46)
  112.             0 packets, 0 bytes
  113.             5 minute rate 0 bps
  114.           Queueing
  115.             Strict Priority
  116.             Output Queue: Conversation 136
  117.             Bandwidth 35 (%)
  118.             Bandwidth 997 (kbps) Burst 24925 (Bytes)
  119.             (pkts matched/bytes matched) 0/0
  120.             (total drops/bytes drops) 0/0
  121.         Class-map: class-default (match-any)
  122.           25141426 packets, 22854134502 bytes
  123.           5 minute offered rate 347000 bps, drop rate 0 bps
  124.           Match: any
  125.           Queueing
  126.             Flow Based Fair Queueing
  127.             Maximum Number of Hashed Queues 128
  128.         (total queued/total drops/no-buffer drops) 0/527/0
  129. ------------------------------------------------------
  130. ------------ Remote show policy-map ------------
  131. #sho policy-map int fa0/1
  132. FastEthernet0/1
  133.   Service-policy output: QoS_NKR_Parent
  134.     Class-map: class-default (match-any)
  135.       26024405 packets, 17721424020 bytes
  136.       5 minute offered rate 178000 bps, drop rate 0 bps
  137.       Match: any
  138.       Traffic Shaping
  139.            Target/Average   Byte   Sustain   Excess    Interval  Increment
  140.              Rate           Limit  bits/int  bits/int  (ms)      (bytes)
  141.                95 (%)                0 (ms)      0 (ms)
  142.           2850000/2850000   17100  68400     68400     24        8550 
  143.         Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
  144.         Active Depth                         Delayed   Delayed   Active
  145.         -      0         26018735  536436868 11132581  2351775935 no
  146.       Service-policy : QoS-VoIP-Policy
  147.         Class-map: VoIP-Trust (match-any)
  148.           1289430 packets, 274951568 bytes
  149.           5 minute offered rate 5000 bps, drop rate 0 bps
  150.           Match: ip dscp ef (46)
  151.             1289430 packets, 274951568 bytes
  152.             5 minute rate 5000 bps
  153.           Queueing
  154.             Strict Priority
  155.             Output Queue: Conversation 136
  156.             Bandwidth 35 (%)
  157.             Bandwidth 997 (kbps) Burst 24925 (Bytes)
  158.             (pkts matched/bytes matched) 66915/14317951
  159.             (total drops/bytes drops) 0/0
  160.           QoS Set
  161.             dscp ef
  162.               Packets marked 1289430
  163.         Class-map: AutoQoS-VoIP-Control-Trust (match-any)
  164.           24318 packets, 13955238 bytes
  165.           5 minute offered rate 0 bps, drop rate 0 bps
  166.           Match: ip dscp cs3 (24)
  167.             24318 packets, 13955238 bytes
  168.             5 minute rate 0 bps
  169.           Match: ip dscp af31 (26)
  170.             0 packets, 0 bytes
  171.             5 minute rate 0 bps
  172.           Queueing
  173.             Output Queue: Conversation 137
  174.             Bandwidth 5 (%)
  175.             Bandwidth 142 (kbps)Max Threshold 64 (packets)
  176.             (pkts matched/bytes matched) 1470/842226
  177.         (depth/total drops/no-buffer drops) 0/0/0
  178.       
  179.         Class-map: class-default (match-any)
  180.           24710657 packets, 17432518728 bytes
  181.           5 minute offered rate 169000 bps, drop rate 0 bps
  182.           Match: any
  183.           Queueing
  184.             Flow Based Fair Queueing
  185.             Maximum Number of Hashed Queues 128
  186.         (total queued/total drops/no-buffer drops) 0/22/0
  187. --------------------------------------------------------

Thanks in advance! I'm still new to qos and still very much learning, but from what i read this should work right? If you need more information let me know.

I have this problem too.
0 votes
Correct Answer by Mohamed Sobair about 6 years 4 months ago

Hi,

Classification and marking should be applied on the ingress (trusted boundary). Your VOIP traffic is not classified and marked at the ingress, you need to apply the following into your QoS Config at HQ:

class-map match-any VOIP

match access-group 100

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

policy-map voip-marking

class VOIP

set ip dscp ef

interface x ( Source LAN for IP Phones)

service-policy input Voip-marking

Let us know if this solves your problem,

Mohamed

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Mohamed Sobair Sun, 07/18/2010 - 02:07

Hi,

Classification and marking should be applied on the ingress (trusted boundary). Your VOIP traffic is not classified and marked at the ingress, you need to apply the following into your QoS Config at HQ:

class-map match-any VOIP

match access-group 100

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

policy-map voip-marking

class VOIP

set ip dscp ef

interface x ( Source LAN for IP Phones)

service-policy input Voip-marking

Let us know if this solves your problem,

Mohamed

Awesome! I think that worked! My show policy map now looks like this:

  Service-policy output: QoS_Albany_Parent

    Class-map: class-default (match-any)
      39642600 packets, 24944921439 bytes
      5 minute offered rate 239000 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes) 
               95 (%)                0 (ms)      0 (ms)
          2850000/2850000   17100  68400     68400     24        8550    

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         39587793  3388006521 5025411   2241546962 no

      Service-policy : AutoQoS-Policy-Trust

        Class-map: dscp46 (match-any)
          165795 packets, 105201803 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp ef (46)
            56727 packets, 80932030 bytes
            5 minute rate 0 bps
          Match: ip precedence 5
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: access-group 100
            109068 packets, 24269773 bytes
            5 minute rate 0 bps
          Queueing
            Strict Priority
            Output Queue: Conversation 136
            Bandwidth 35 (%)
            Bandwidth 997 (kbps) Burst 24925 (Bytes)
            (pkts matched/bytes matched) 13875/8161087
            (total drops/bytes drops) 254/385572
         
        Class-map: class-default (match-any)
          39476797 packets, 24839719200 bytes
          5 minute offered rate 233000 bps, drop rate 0 bps
          Match: any
          Queueing
            Flow Based Fair Queueing
            Maximum Number of Hashed Queues 128
        (total queued/total drops/no-buffer drops) 0/42780/0

And this is the change I made:

class-map match-any dscp46
match ip dscp ef
match ip precedence 5
match access-group 100
!        
!        
policy-map AutoQoS-Policy-Trust
class dscp46
  priority percent 35
class class-default
  fair-queue
policy-map QoS_Albany_Parent
class class-default
  shape average percent 95
  service-policy AutoQoS-Policy-Trust
!        
!        
!

access-list 100 permit udp any any range 16384 32767
access-list 100 permit tcp any any eq 1720

Looks good now. I will go over to the remote site and test it out. Thanks again!

Actions

This Discussion