Layer 3 routing

Unanswered Question
Jul 16th, 2010
User Badges:

Hi,


Can show me the simple example of Layer 3 routing? For example, route host A connect to host B via the switch 3650. What kind of configuration need to  be put on the switch?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
tironevi Fri, 07/16/2010 - 20:28
User Badges:

I do not think I understand your question. Are you trying to route between two hosts

that are physically conncted on the same switch but on different subnets?

Ganesh Hariharan Sat, 07/17/2010 - 01:19
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi,


Can show me the simple example of Layer 3 routing? For example, route host A connect to host B via the switch 3650. What kind of configuration need to  be put on the switch?

Hi,


Cisco 3560 series are L3 switches in order to make communication between vlan just confiogure ip routing in global mode with creating SVI for two vlan and rest will take care by 3560 switch for communication.


But not by default ports in 3560 are in l2 mode in order to make the port in L3 you need configure no switch port under interface level.



Hope to Help !!


Ganesh.H


Remember to rate the helpful post

lamav Sun, 07/18/2010 - 09:50
User Badges:
  • Blue, 1500 points or more

Folks:


Hes asked for a sample config.


Enter these commands at privileged exec mode on a L3 capable switch that has both hosts directly connected to the switch.


switch#conf t


switch(config)#


!enter these command lines!


ip routing (may be on by default)


vlan 2

name tax_division


vlan 3

name accounting_division


interface vlan 2

description default gateway for TAX Subnet

ip address 10.10.2.2 255.255.255.0

no shut


interface vlan 3

description default gateway for ACCOUNTING Subnet

ip address 10.10.3.2 255.255.255.0

no shut


interface gigabitethernet 1/0/1

description connection to  server on TAX Subnet

switchport mode access

switchport access vlan 2

no shut


interface gigabitethernet 1/0/2

description connection to server on ACCOUNTING Subnet

switchport mode access

switchport access vlan 3

no shut



You wont need a routing protocol because the hosts are directly connected and the switch is enabled for ip routing.


HTH


Victor

ssweehinlew Mon, 07/19/2010 - 06:57
User Badges:

Thank for your response. If I want to restrict certain ports in between these 2 networks. How it can be done on the access list?

Jon Marshall Mon, 07/19/2010 - 10:53
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

ssweehinlew wrote:


Thank for your response. If I want to restrict certain ports in between these 2 networks. How it can be done on the access list?


Following on from Victor's post you would use acls ie.


access-list 101 deny tcp host 10.10.2.5 host 10.10.3.10 eq www

access-list 101 deny tcp 10.10.2.0 0.0.0.255 10.10.3.0 0.0.0.255 eq ftp

access-list 101 permit ip 10.10.2.0 0.0.0.255 10.10.3.0 0.0.0.255


int vlan 2

ip access-list 101 in


the above config would -


1)  stop host 10.10.2.5 connecting to the web server on 10.10.3.10

2) stop all ftp intitated traffic from 10.10.2.x to 10.10.3.x

3) allow everything else


Jon

Actions

This Discussion