Unity Connection Temp Fail - Conversation Manager Crashing

Unanswered Question
Jun 30th, 2010
User Badges:
  • Bronze, 100 points or more

I'm using CUCM 8.0.2 and Unity Connection 7.1.3.  Whenever I call the voicemail pilot it answers fine and asks me to enter my PIN.  When I enter my PIN nothing else happens and after a few seconds I get a Temp Fail message on my phone.  I also see that at that point I stop receiving RTP packets on my phone (although I'm still sending).  It doesn't seem to be time related as I can back out to the CUC main menu and move around and it works fine.  It's just whenever I log into a mailbox I get this.  I have tried logging into other subscribers' mailboxes, but get the same thing.


Very basic setup.  Nothing unusual or fancy.


Any thoughts?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
shh5455 Thu, 07/01/2010 - 19:33
User Badges:
  • Bronze, 100 points or more

Update: I tried this with CUCM 7.1.5 and the same thing occurs.

shh5455 Wed, 07/07/2010 - 19:21
User Badges:
  • Bronze, 100 points or more

Update: Reinstalled CUC.  Problem still occuring.

David Hailey Wed, 07/07/2010 - 19:30
User Badges:
  • Purple, 4500 points or more

Are your ports configured and registered properly with CUCM?  I would start by monitoring the ports on CUC to make sure they aren't flapping registration with CUCM.  Where is CUC relative to CUCM - same subnet, different subnet, same building, different building, etc???


Hailey

Scott Hills Thu, 07/08/2010 - 06:03
User Badges:
  • Cisco Employee,

Hello,


At times we see this when two Connection servers are fighting for registration. Not sure if you might have another Unity or Unity Connection Server on your network that might be causing issue.


The problem would most likely be if they are attempting to register with the same device prefix to the same Callmanager Cluster.


Thanks,


Scott

David Hailey Thu, 07/08/2010 - 06:33
User Badges:
  • Purple, 4500 points or more

In similar fashion, I have seen this with a new CUC cluster that was configured properly (for integration with CUCM); however, the ports on the servers would show a registered status but with a private IP address (i.e., 169.259.x.x). The ports would receive calls and integrate but nothing past that. The cause for this is unknown but the ports would occasionally flap registration status as well. In the end, rebooting the cluster cleared things up - but either way, it sounds like you have an issue with your CUCM integration. If it's not as simple as that, I'd take a look at connectivity on the network to see if that is factoring into play here.


Hailey


Please rate helpful posts!

shh5455 Fri, 07/16/2010 - 11:51
User Badges:
  • Bronze, 100 points or more

I have verified that as soon as the first digit of the PIN is pressed the CUC ports unregister from CUCM.  Not sure why.  I haven't tried to pull any logs yet.  After a few seconds they will reregister and then I can call again.  Strangely, when it tries to log me in, if I hit * then a mailbox ID, it works through that.  It's just as soon as I start to type the PIN the ports unregister.

David Hailey Fri, 07/16/2010 - 12:20
User Badges:
  • Purple, 4500 points or more

Are you using a SIP or SCCP integration for CUCM to Unity Connection?

shh5455 Fri, 07/16/2010 - 13:38
User Badges:
  • Bronze, 100 points or more

I have spent some time looking at the logs, and it appears that Conversation Manager may be crashing whenever the PIN is entered.  In RTMT it generates a core dump each time (I tried to download this, but it didn't seem readable).  The Conversation Manager also reset.  I used Port Monitor to watch the ports and RTMT would lose connection with it and ask if Conversation Manager was still up.  Then the ports would reinitialize.


Looking at the Conversation Manager logs (i enabled macro traces), everything appears to be ok, but right after I enter the PIN the file says its attempting to authenticate, then the file ends.  A new file starts up (presumably after Conversation Manager restarts) and then the ports reregister.  There is also a gap in time between the files so that makes me think the service crashed.


I'm attaching those two log files if you want to see them.  If you know better how to determine what is happening, I'm all ears.

David Hailey Fri, 07/16/2010 - 15:25
User Badges:
  • Purple, 4500 points or more

For completeness, I would like to ask if you've looked at anything from the CUCM side as well.  For instance, have you tried to register your ports to a different CUCM subscriber to see if that makes a difference in behavior?


Hailey

shh5455 Fri, 07/16/2010 - 19:22
User Badges:
  • Bronze, 100 points or more

While I haven't looked at the CUCM logs, I have registered it to CUCM 7.1.5 and 8.0.2 and get the same behavior.  I have also tried rebuilding CUC from scratch. I'm going to try upgrading to the latest 7.1.3 release.

David Hailey Fri, 07/16/2010 - 19:25
User Badges:
  • Purple, 4500 points or more

While version could be a factor, I would still test registration with a separate Subscriber. What is your CUCM and CUC architecture?


Sent from my iPhone

shh5455 Fri, 07/16/2010 - 19:27
User Badges:
  • Bronze, 100 points or more

Both are on the same ESX server, same subnet.

David Hailey Fri, 07/16/2010 - 19:31
User Badges:
  • Purple, 4500 points or more

Do you have separate CUCM VMs replicating a cluster model or one VM for each app only? Is this production or testing? I suspected this was a VMWare environment. Rebuilding that many physical servers would be a pain.


Sent from my iPhone

shh5455 Fri, 07/16/2010 - 19:33
User Badges:
  • Bronze, 100 points or more

Just one VM per app (no subscriber).  It's for testing only.  Not sure if it matters but Unity 7.0 works like a champ with both CUCMs.  (It's not currently running though and they use different device names for the ports).

David Hailey Fri, 07/16/2010 - 19:38
User Badges:
  • Purple, 4500 points or more

FWIW, I run CUCM and CUC 7.1(3b)SU2 in VMWare without issues. I also have Unity 5 and Unity 7 running without issue as well...along with other apps. It is possible you're seeing an 8x w/7x bug but I suspect you may be seeing issues due to the CUCM 8x load as well. I haven't loaded 8.0 yet but it's on my to-do list.


Sent from my iPhone

shh5455 Fri, 07/16/2010 - 19:41
User Badges:
  • Bronze, 100 points or more

I thought that too and tried it with CUCM 7.1.5 and it does the same thing.  I was hoping CUC 8 would fix whatever it is, but I can't get that installed.  The installer crashes and kicks out an error about auto negotiation on the eth0.  I've tried hard coding it, but that also fails.  Boo.

David Hailey Fri, 07/16/2010 - 19:45
User Badges:
  • Purple, 4500 points or more

VM support moving into 8x is quite different. Really, 7.1(5) is a bridge code between 7x and 8x which is something I typically avoid. It has things from 8x mashed in while also trying to tie up loose ends from 7.1(3). Give 7.1(3b)SU2 a shot on both apps. I suspect you'll have success as I have.  Only difference is I use VMWare server vs. ESX.


Sent from my iPhone

shh5455 Fri, 07/16/2010 - 19:48
User Badges:
  • Bronze, 100 points or more

I'm not a 7.1.5 fan either.  I may try CUCM 7.1.3 and see if that will work for me.  Thanks for your help on this thread.

David Hailey Fri, 07/16/2010 - 19:50
User Badges:
  • Purple, 4500 points or more

No problem...stick with ES 26 which is the 7.1(3b)SU2 code I mentioned. I recommend it to all my customers (currently) and have had great success in all environments.


Sent from my iPhone

shh5455 Sat, 07/17/2010 - 10:50
User Badges:
  • Bronze, 100 points or more

Upgraded CUC to the latest 7.1.3.  And built up a CUCM 7.1.3 server.  Same issue!  Argh!!

David Hailey Sat, 07/17/2010 - 12:28
User Badges:
  • Purple, 4500 points or more

I hate to bear the bad news but I think you have issues with ESX...not the apps. I know folks have these working on VMWare Server and ESXi.


Sent from my iPhone

shh5455 Sat, 07/17/2010 - 14:01
User Badges:
  • Bronze, 100 points or more

Yeah, me too. It's probably because I am using an AMD processor and it can't find a certain file. Had a similar problem with IP Media Streaming App in CUCM that I had to fix by gaining root access.

David Hailey Sat, 07/17/2010 - 17:09
User Badges:
  • Purple, 4500 points or more

Well, good luck.  These kinds of details are pretty important and best if divulged early on in a thread.  It certainly helps steer where to look first when trying to identify an issue.


Hailey

f.giordano Fri, 08/06/2010 - 01:14
User Badges:

Hi,


I'm running a similar issue. We have CUCM 7.1(5) and CUC 7.1(3).

CUCM is running on a MCS 7825 but CUC is on ESX (Host on AMD).

Integration was working pretty well until Guys from our internal IT decide to upgrade ESX.

And now everything is working except when I enter the PinCode from the phone.

I mean i'm able to retrieve voicemessage through CUPC for instance...

When entering PinCode on IpPhone, all the voicemail port unregister for 15 secs and then back again.

I'm running sccp integration and it worked before ESX upgrade ^^


I'm now gonna move my Virtual Machine on Intel based host, I'll let you know.


Fabian

Marcel Ammann Sat, 08/28/2010 - 13:22
User Badges:
  • Silver, 250 points or more

Hello,


i have the same issue with Unity Connection 7.1.x on VMWare Workstation 7.1.0 and an AMD processor.

It seems to be a bug / error in VMWare or AMD stack.


Kind regards,


Marcel Ammann

David Hailey Sat, 08/28/2010 - 16:15
User Badges:
  • Purple, 4500 points or more

It's AMD. Use Intel and you'll have better luck.


Sent from my iPhone

california Thu, 04/28/2011 - 10:58
User Badges:

Hello.


I am running CUCM System version: 7.1.2.20000-2

and also running UCONN Version 7.1.2.20000-140


I am having exact problem on this.


I am able to leave vmails and the MWI work fine.  When i try to check vmails i enter the PIN and press # and nothing happens after that but the TEMP FAILED message on the phone.


I am using vmware virtual machines and this was working fine last week.  The changes i did were in CUCM, i deleted the vmailports and then re-created them.  in unity nothing changed.


after this,  i have the problem.


i have also re-created virtual machine and same problem.


i believe there must be something in the database that may still be referencing old records of some sort.


when i use Remote Port Status Monitor i get to this point:



CallData, 1, CallerId=1060, CalledId=8000, RedirectingId=, Origin=16, Reason=1, CallGuid=A8593BA6D4774BFEB55061A45E784414, CallerName=, LastRedirectingId=, LastRedirectingReason=1024, PortDisplayName=PhoneSystem-1-001

Application, 1, 1060, AttemptSignIn

State, 1, 1060, State - AttemptSignIn.cde!Dummy

State, 1, 1060, Event is [NULL]

Application, 1, 1060, SubSignIn

Display, 1, 1060, Subscriber Sign-In

State, 1, 1060, State - SubSignIn.cde!AnswerPhone

State, 1, 1060, Event is [TrueEvent]

State, 1, 1060, State - SubSignIn.cde!AuthenticateUser

Application, 1, 1060, -->SubAuthenticate

State, 1, 1060, State - SubAuthenticate.cde!TryCounter

State, 1, 1060, Event is [NULL]

State, 1, 1060, State - SubAuthenticate.cde!GatherID

State, 1, 1060, Event is [FalseEvent]

State, 1, 1060, State - SubAuthenticate.cde!LoadSubscriberMinimalData

State, 1, 1060, Event is [NULL]

State, 1, 1060, State - SubAuthenticate.cde!GatherPIN

Application, 1, 1060, -->SubAuthenticatePW

State, 1, 1060, State - SubAuthenticatePW.cde!ValidatePwd

After this, as soon as i het the TEMP FAILED message on the phone, my remote port status monitor says that the connection to server was reset and it closes.
let me know if you guys find a solution.
rohitborkar Tue, 06/14/2011 - 16:42
User Badges:

Hey,

Does anyone have any solution or a workaround for the above issue with AMD similar to the IPVMS workaround.


Thanks

ahochau_2 Sat, 07/21/2012 - 15:15
User Badges:

I just ran into the same issue in my test lab as well, also with a AMD proc in my ESXi host.


I checked the box for "skip pin when calling from a known extension" and everything else seems to be OK in terms of Connections functionality.  So the issue only seems to be an issue when prompted for the PIN from the "Attempt Sign In".  Not optimal for production I know, but good enough to get me through preparing for the lab.

elopesfilho Fri, 01/10/2014 - 11:10
User Badges:

I faced this same issue in my test lab. Ahochau approach is the best workworkaround to solve it. My Server processor is an AMD one too. For sure it is related do this proc.

Actions

This Discussion