Webview with windows 7 Proff and IE 8

Answered Question

We are trying to run Cisco webview  from client Machine(windows 7 professional with IE 8) the webview is accessible but when we generate any report we got the below  error Message:

((((Error. The server encountered an unexpected condition which prevented it from fulfilling the request.

java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key en-US

                at java.util.ResourceBundle.getObject(ResourceBundle.java:325)

                at java.util.ResourceBundle.getString(ResourceBundle.java:285)

                at pagecompile._webview._ReportNewDateTime_xjsp._jspService(_ReportNewDateTime_xjsp.java:322)

                at com.newatlanta.servletexec.JspHttpJspPage.service(JspHttpJspPage.java:41)

                at com.newatlanta.servletexec.JspServlet.service(JspServlet.java:1036)

                at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

                at com.newatlanta.servletexec.SERequestDispatcher.forwardServlet(SERequestDispatcher.java:638)

                at com.newatlanta.servletexec.SERequestDispatcher.forward(SERequestDispatcher.java:236)

                at com.newatlanta.servletexec.SERequestDispatcher.internalForward(SERequestDispatcher.java:283)

                at com.newatlanta.servletexec.ApplicationInfo.processApplRequest(ApplicationInfo.java:1827)

                at com.newatlanta.servletexec.ServerHostInfo.processApplRequest(ServerHostInfo.java:937)

                at com.newatlanta.servletexec.ServletExec.ProcessRequest(ServletExec.java:1091)

                at com.newatlanta.servletexec.ServletExec.ProcessRequest(ServletExec.java:1002)))))

any help would be appreciated

I have this problem too.
0 votes

I've heard of this problem from colleagues and the solution they gave me is as follows. I have not tried this, but my source is very reliable and competent.

If it fixes the problem, PLEASE post back

------------------------

WebView locale files are incorrectly setup with language = en-us but it needs to be en-US.

You can either put a workaround in your IE Internet tools, Languages, by adding (using user-defined option) a new entry "en-us" and then push it to the top of the languages.

Or you can modify the locale file on each WebView server and add an entry en-US then cycle the Jaguar and IIS Admin services.

Problem should be cleared.

---------------------------------

Regards,

Geoff

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
david.macias Sun, 07/18/2010 - 09:52

Did you search the forums before posting?  I think I remember a similar issue posted here before with a solution provided.

david

Correct Answer

I've heard of this problem from colleagues and the solution they gave me is as follows. I have not tried this, but my source is very reliable and competent.

If it fixes the problem, PLEASE post back

------------------------

WebView locale files are incorrectly setup with language = en-us but it needs to be en-US.

You can either put a workaround in your IE Internet tools, Languages, by adding (using user-defined option) a new entry "en-us" and then push it to the top of the languages.

Or you can modify the locale file on each WebView server and add an entry en-US then cycle the Jaguar and IIS Admin services.

Problem should be cleared.

---------------------------------

Regards,

Geoff

dennishageman Mon, 07/19/2010 - 05:09

Hello,

What you must change is a regedit key.

I had the same issue. It's a security in IE8

make this key in the Regedit;HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main .(TabProcGrowth) DWORD value = 0.

Dear

The regedit key was added before for the( you have been logged out due inactivaity) but what provided by Geof was for the following Error(((

Error. The server encountered an unexpected condition which prevented it from fulfilling the request.

java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key en-US and now the problem is solved

Konstantin Vaksin Fri, 11/04/2011 - 09:43

Acording BOM for UCCE 7.5 WebView Client should run OS Windows XP or Windows 2003.

If you are running WinXp with IE8, than you should change registry key, as it is mentioned in the defect:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsy89990

If you wish to use Windows 7 for WebView Client, you can run Windows 7 in Windows XP mode. It is not supported by Cisco TAC, but still can be used as workaround, if you really need it

shivkumar gadad Tue, 08/06/2013 - 05:35

Hi,

Thanks for the update, the above workaround solution is working on the user desk, but when i tried fixing it on the server level we didnt get the expected result,

we did add en-US in Webview server and reset the Jaguar and IIS Admin server, also cycle the ICM services on it but it didnt work..

Did it work for any one?

Thanks

Shiv

Actions

This Discussion