L2 redirection between a 3750 and WAE 674 WCCP

Unanswered Question
Jul 19th, 2010
User Badges:

hi


we are using a WAE 674 on a cisco 3750 in WCCP

WCCP is configured to use L2 redirection

but we saw this on the switch


Global WCCP information:
    Router information:
        Router Identifier:                   192.168.100.1
        Protocol Version:                    2.0

    Service Identifier: 61
        Number of Service Group Clients:     1
        Number of Service Group Routers:     1
        Total Packets s/w Redirected:        1
          Process:                           0
          CEF:                               1
        Redirect access-list:                -none-
        Total Packets Denied Redirect:       0
        Total Packets Unassigned:            0
        Group access-list:                   -none-
        Total Messages Denied to Group:      0
        Total Authentication failures:       0
        Total Bypassed Packets Received:     0

    Service Identifier: 62
        Number of Service Group Clients:     1
        Number of Service Group Routers:     1
        Total Packets s/w Redirected:        11
          Process:                           0
          CEF:                               11
        Redirect access-list:                -none-
        Total Packets Denied Redirect:       0
        Total Packets Unassigned:            0
        Group access-list:                   -none-
        Total Messages Denied to Group:      0
        Total Authentication failures:       0
        Total Bypassed Packets Received:     0




switch configuration


vlan 1 and 2 : data

vlan 3 routeurs

vlan 4 : WAE



interface Vlan1
ip address 10.0.0.1 255.255.0.0
ip wccp 61 redirect in
standby 0 preempt
standby 1 ip 10.0.0.6
standby 1 priority 150
standby 1 preempt
standby 1 name hsrp_vlan_1
!
interface Vlan2
ip address 10.1.0.1 255.255.0.0
ip wccp 61 redirect in
standby 2 ip 10.1.0.6
standby 2 priority 150
standby 2 preempt
standby 2 name hsrp_vlan_2
!
interface Vlan3
description Routage-FT
ip address 192.168.1.4 255.255.255.0
ip wccp 62 redirect in
standby 3 ip 192.168.1.6
standby 3 priority 150
standby 3 preempt
standby 3 name hsrp_vlan_3
!
interface Vlan4
description VLAN WCCP
ip address 192.168.100.1 255.255.255.0



WAE configuration


!
wccp router-list 8 192.168.100.1
wccp tcp-promiscuous mask src-ip-mask 0x1741 dst-ip-mask 0x0
wccp tcp-promiscuous router-list-num 8 l2-redirect mask-assign l2-return

wccp version 2
!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Michael Korenbaum Mon, 07/19/2010 - 05:57
User Badges:
  • Bronze, 100 points or more

Hi,


This counter on the 3750 is a software counter, but all WCCP redirection should be happening in hardware.  Thus, it is expected the number of redirected packets to be zero or very low.  The proper way to tell if WCCP is redirecting traffic to your WAE is to issue the command "show wccp gre" on the WAE and look for the line "transparent non-GRE packets received."


Example:


pdi-7341-19#sh wccp gre

Transparent GRE packets received:              0

Transparent non-GRE packets received:          28887345

Transparent non-GRE non-WCCP packets received: 0

Total packets accepted:                        26012975

Invalid packets received:                      0

Packets received with invalid service:         0

Packets received on a disabled service:        0

Packets received too small:                    0

Packets dropped due to zero TTL:               0


----output omitted ------



Cheers,


Mike Korenbaum


Cisco WAAS PDI Help Desk

http://www.cisco.com/go/pdihelpdesk

wrobbin Thu, 07/22/2010 - 05:37
User Badges:

hostname#sh ip wccp (61 or 62) detail
WCCP Client information:
        WCCP Client ID:          x.x.x.x
        Protocol Version:        2.0
        State:                   Usable
        Redirection:             GRE
        Packet Return:           GRE
        Assignment:              HASH
        Initial Hash Info:       00000000000000000000000000000000
                                 00000000000000000000000000000000
        Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                                 FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
        Hash Allotment:          256 (100.00%)
        Packets s/w Redirected:  513071848
        Connect Time:            9w6d
        Bypassed Packets
          Process:               0
          CEF:                   2
          Errors:                0

hostname#

Actions

This Discussion