CUPS: Integrating CUPC with Unity Voicemail Messages

Answered Question
Jul 19th, 2010

Afternoon all,

I am attempting to setup CUPS so that voicemail messages from Unity are received to CUPC as well as the desk phone.

I have configured the voicemail server and voicemail profile and assigned the relevant user to the voicemail profile. I am not entirely sure which login credentials I need to enter for Personal Communicator under ‘Preferences/Account/Voice Messaging’. Will this be the account details of the Unity Server or the subscriber details?

Platform Version as follows:

CUCM version – 6.1(4)

CUPS Version – 7.0(6) (VMware environment for testing)

Cisco Unity 4.2 Build 4.2(1)

I am concerned that our Unity server is incompatible with this feature. On our Unity server I am attempting to configure ‘Allow Users to Access VoiceMail Using IMAP client’ for a user to access voicemail from CUPC. The option should be under Licensed Features which I cannot find. Please see attached screenshot.

Any help would be appreciated. Thanks Jamie

Attachment: 
I have this problem too.
0 votes
Correct Answer by duane.larson about 6 years 1 month ago

Hmmm.   I upgraded Presence 8.0.2 to 8.0.4 and they now get the new voicemail alert on the Personal Communicator version 8.  I guess the upgrade fixed it.  I still have the VVM no connection like you do, but I guess that is not an issue.

Thanks.

Correct Answer by Andrew Murray (... about 6 years 4 months ago

Hi Jamie

I've not set this up myself but have it in play at our company. I know in the CUPC Preferences/Account/Voice Messaging section that our users put in their Windows login as our CUCM, Unity and CUPC are synched with AD.

Probably not much help but it looks like you will need subscriber credentials as opposed to server credentials.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Andrew Murray (... Mon, 07/19/2010 - 05:52

Hi Jamie

I've not set this up myself but have it in play at our company. I know in the CUPC Preferences/Account/Voice Messaging section that our users put in their Windows login as our CUCM, Unity and CUPC are synched with AD.

Probably not much help but it looks like you will need subscriber credentials as opposed to server credentials.

htluo Mon, 07/19/2010 - 10:55

You don't have that option on Unity.  That option is on Unity Connection only.

For Unity, it's the Exchange engineer's job to enable IMAP access from Exchange server.  The "Mailstore" configuration on CUPS should point to Exchange IMAP.

Michael

http://htluo.blogspot.com

duane.larson Wed, 10/13/2010 - 19:30

Hey I have my mailstore pointed to the Exchange IMAP port and CUPC users can check their voicemail.  What about in Presence where you set up "Voicemail Server"?  I have that pointed to the unity 7.1 server IP address with HTTPS and 443.  But in the CUPC client when I do a health check I see that there is no connection for VVM.  What in Unity do you need to set up for this HTTPS 443 connection?  The Deployment guide for Presence 8.x doesn't really explain this.  Only tells you to point to Unity on port 443 and HTTPS.

Jamie Weatherhead Thu, 10/14/2010 - 06:34

Hi,

Sounds like you have correctly configured CUPS. Have you made sure the account settings under CUPC preferences have the correct username and password?

Make sure you can telnet to your Unity address and port from your pc that has CUPC installed.

I did notice that under health check my VVM showed no connection. However, when I left a voicemail on my deskphone it did eventually appear in in CUPC. Very misleading but it does work.

Regards,

Jamie

Correct Answer
duane.larson Thu, 10/14/2010 - 08:05

Hmmm.   I upgraded Presence 8.0.2 to 8.0.4 and they now get the new voicemail alert on the Personal Communicator version 8.  I guess the upgrade fixed it.  I still have the VVM no connection like you do, but I guess that is not an issue.

Thanks.

Actions

This Discussion

Related Content