adding a 3750 to a 6509 network

Answered Question
Jul 19th, 2010
User Badges:

Hi,


I've been given the task to isolating traffic from our 6509 to a 3750 but still allowing traffic to flow to our 6509 network from the 3750 switch.  I have 4 vlans I want to move to the 3750 from the 6509.  I want the 3750 switch to route traffic between the 4 vlans and only access the 6509 traffic when it needs to reach one of the other vlans.  I have the 3750 and a 3550 switch on my desk for testing so I can try some things out.


I'm not that familiar with setting up Cisco switches.  I have some networking background but I'm mainly a programmer.  Budget cuts have force me into this role so if I'm completely clueless you'll know why.  I've done quite a bit of reading and this is what I came up with but I'm not sure if this is how to accomplish what I need.


I configured the 3750 for inter-vlan routing by doing ip routing.  I set up the 3 of the 4 vlans for testing.


vlan 101 ip address 192.168.168.2   255.255.255.0  set to gigabitethernet1/0/7

vlan 102 ip address 10.94.79.2  255.255.255.0       set to gigabitethernet1/0/5

vlan 103 ip address 192.3.3.2    255.255.255.0       set to gigabitethernet1/0/6


interface gigabitethernet1/0/12 set configured to be

switchport trunk encapsulation dot1q

switchport trunk mode


I configured the 3550 for inter-vlan routing also and I added the same vlans with a different ip address


vlan 101 ip address 192.168.168.1   255.255.255.0  set to fastethernet0/4

vlan 102 ip address 10.94.79.1       255.255.255.0  set to fastethernet0/1

vlan 103 ip address 192.3.3.1         255.255.255.0  set to fastethernet10/2


interface fastethernet0/24 set configured to be

switchport trunk encapsulation dot1q

switchport trunk mode

no ip address


I connected port 12 on the 3750 to port 24 on the 3550 with a crossover cable.

I connected a PC1 to the 3750 to port 5 which is vlan 102 and can access vlan 101 and 103 on the 3750 switch.  i aso added a PC2 to the 3550 switch on vlan 101 and can access the vlans on the 3550 switch.  Now I set the default gateway of PC1 to be 10.94.79.2 and PC2 to 192.168.186.1.  I can ping and access from PC1 to PC2.  Is this the right way to configure these switches for what I want to do?  I'm not sure about having 2 ip address for the same vlan on different switches.  Is this OK or is this not how to do this?  Right now I'm setting this up assuming that the end devices are going to be PC's but I hear one of the networks I'm moving is connected to a router.  So I'm not sure how to configure that port on my 3750 switch and if the  other network has to reconfigure their router.


Both switches are configured in VTP transparent mode. We have a small but very complicated WAN set up that I didn't do but now have to maintain.

Thanks in advance for any help you guys can give me.


Mike

Correct Answer by Jon Marshall about 6 years 11 months ago

MIke


If i understand correctly you want to route the vlans off the 3750. If so you do not assign IPs from those vlans to both the 6500 and the 3750. What you would do is (i'll use 2 vlans but it's the same principle for 4 just saves me some typing !)


vlan 10  = 192.168.5.0/24

vlan 11 =  192.168.6.0/24


1) as you say turn on "ip routing" on the 3750

2) create vlan 10 and vlan 11 in the vlan database on 3750 switch. Note also that you can delete these vlans from 6500

3) then you need to create a L3 SVI for each vlan on the 3750 ie.


int vlan 10

ip address 192.168.5.1 255.255.255.0

no shut


int vlan 11

ip address 192.168.6.1 255.255.255.0


you shoud find that on the 6500 at the moment you have L3 SVIs for vlan 10 & 11. You can delete these because you are routing these vlans on the 3750.


4) then the connection from the 3750 to the 6500 can be a L3 link. Note that this assumes there are no machines in vlan 10 and vlan 11 that are connected to the 6500. You said you wanted to move it to the 3750 so i'm assuming all vlan 10 and 11 clients will be connected to the 3750. If this isn't the case perhaps you could elaborate on exactly what you are trying to do as this may need to be a L2 trunk link.


choose an unused /30 subnet ie.


192.168.7.0 255.255.255.252


on the 6500


int gi0/1  <-- this port connects to 3750

no switchport

ip address 192.168.7.1 255.255.255.252


on the 3750


int gi0/1 <-- this port connects to 6500

no switchport

ip address 192.168.7.2 255.255.255.252


6) finally routing. You can either run a dynamic routing protocol such as EIGRP between the 6500 and the 3750 or to keep it simple use statics -


on the 6500 -


ip route 192.168.5.0 255.255.255.0 192.168.7.2

ip route 192.168.6.0 255.255.255.0 192.168.7.2


on the 3750


ip route 0.0.0.0 0.0.0.0 192.168.7.1


Note that to implement this you will need some downtime. Key thing is to answer whether or not clients of vlan 10/11 will be only connected to 3750 ?


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Mon, 07/19/2010 - 11:06
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

MIke


If i understand correctly you want to route the vlans off the 3750. If so you do not assign IPs from those vlans to both the 6500 and the 3750. What you would do is (i'll use 2 vlans but it's the same principle for 4 just saves me some typing !)


vlan 10  = 192.168.5.0/24

vlan 11 =  192.168.6.0/24


1) as you say turn on "ip routing" on the 3750

2) create vlan 10 and vlan 11 in the vlan database on 3750 switch. Note also that you can delete these vlans from 6500

3) then you need to create a L3 SVI for each vlan on the 3750 ie.


int vlan 10

ip address 192.168.5.1 255.255.255.0

no shut


int vlan 11

ip address 192.168.6.1 255.255.255.0


you shoud find that on the 6500 at the moment you have L3 SVIs for vlan 10 & 11. You can delete these because you are routing these vlans on the 3750.


4) then the connection from the 3750 to the 6500 can be a L3 link. Note that this assumes there are no machines in vlan 10 and vlan 11 that are connected to the 6500. You said you wanted to move it to the 3750 so i'm assuming all vlan 10 and 11 clients will be connected to the 3750. If this isn't the case perhaps you could elaborate on exactly what you are trying to do as this may need to be a L2 trunk link.


choose an unused /30 subnet ie.


192.168.7.0 255.255.255.252


on the 6500


int gi0/1  <-- this port connects to 3750

no switchport

ip address 192.168.7.1 255.255.255.252


on the 3750


int gi0/1 <-- this port connects to 6500

no switchport

ip address 192.168.7.2 255.255.255.252


6) finally routing. You can either run a dynamic routing protocol such as EIGRP between the 6500 and the 3750 or to keep it simple use statics -


on the 6500 -


ip route 192.168.5.0 255.255.255.0 192.168.7.2

ip route 192.168.6.0 255.255.255.0 192.168.7.2


on the 3750


ip route 0.0.0.0 0.0.0.0 192.168.7.1


Note that to implement this you will need some downtime. Key thing is to answer whether or not clients of vlan 10/11 will be only connected to 3750 ?


Jon

hustler0002 Mon, 07/19/2010 - 13:03
User Badges:

Thanks Jon. This is exactly what I needed.  When you pointed out the vlan 10 and 11 are no longer on the 6500, was something that didn't click until you mentioned it.  And then I figured that I didn't need to trunk anything.  I was able to configure my test network and everything works.  Getting the configuration to the live 6500 switch makes me a little nervous. Hopefully everything works.  Thanks again.

Actions

This Discussion