CiscoWorks Web Server won't start after LMS upgrade 3.0 -> 3.2

Unanswered Question
Jul 19th, 2010

I upgraded CiscoWorks LMS from 3.0 to 3.2 today.  Everything worked prior to the upgrade.

The upgrade was successful, with no errors, and all services started except "CiscoWorks Web Server" which has the following error.

Apache.exe: Syntax error on line 1025 of C:/Program Files/CSCOpx/MDC/Apache/conf/httpd.conf: Cannot load C:/Program Files/CSCOpx/MDC/Apache/modules/ into server: The operating system cannot run %1.


Windows 2003 SP2 Enterprise R2 32-bit, 8 GB RAM, HP BL460c Server

I suspect there is a problem with the precompiled apache installation?

I was wondering if someone could zip up a known-working C:/Program Files/CSCOpx/MDC/Apache folder for me from CiscoWorks LMS 3.2?

Or if someone has a patch or update to 3.2 to correct this?  Or, where I can get LMS 3.1 instead of 3.2 if LMS 3.2 is buggy?

Or if there is some other solution?  (even if it is a clean install... although I'd rather wait to see if someone can solve this a better way)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nael Mohammad Mon, 07/19/2010 - 11:00

Do you have another application that might be loading Apache or OpenSSL on that same server?

Search for theses files and verify its located in CSCOpx\bin directory .


If not, copy it from CSCOpx\setup\support directory to CSCOpx\bin directory and then restart the server.
Get the MDCSupportZip output from C:\Program Files\CSCOpx\MDC\bin\mdcsupport.exe file and upload it here.
stevenmezzadri Mon, 07/19/2010 - 11:12
These files were in the Ciscoworks bin folder

however, I noticed there was also an older set in c:\winnt\system32, so I renamed those to .old and copied the ones from the ciscoworks bin folder into c:\winnt\system32 and now the service starts.

Appreciate the tip!


This Discussion

Related Content