About PPPoE, why the command "adjust-mss" is not specified in the Official Configuration Guides.

Answered Question
Jul 20th, 2010

Hi,

I'v configured the two routers as PPPoE-Server and PPPoE-Client using IOS 12.4T.

Now it works out without any problem.

Here is the configuration below.

********************************************************

図面1.gif

[PPPoE Server]

username client1 password 0 cisco
!
bba-group pppoe global
virtual-template 1
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 200.200.200.1 255.255.255.0
duplex auto
speed auto
pppoe enable group global
!
interface Virtual-Template1
mtu 1454
ip unnumbered FastEthernet0/1
peer default ip address pool client1-pool
ppp authentication chap
!
ip local pool client1-pool 200.200.200.2
!

[PPPoE Client]

interface FastEthernet0/0
description Interner
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description LAN
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1414   (-----> question)
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1454     (-----> question)
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname client1
ppp chap password 0 cisco
!
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
!
ip http server
no ip http secure-server
ip nat inside source static 192.168.1.1 interface Dialer1
!

********************************************************

Then I have a question for the line : ip tcp adjust-mss 1414 for PPPoE Client.

The command ip mtu at interface Dialer1 on PPPoE Client is specified in the Configuration Guide of PPPoE Client.

But I can't find the command "ip tcp adjust-mss" in the Configuration Guide about PPPoE

I think it means "ip mtu" is always necessary but "ip tcp adjust-mss" is not always necessary scince recent version of IOS, isn't it?

For example, IOS calculates a value of mss such as "MTU - 40" by default, and so on.

If adjust-mss is absolutely necessary for PPPoE, could you tell me why it isn't specified in the official configuration guide of PPPoE clearly.

Regards,

Okumura

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 6 years 4 months ago

The ip mtu command addresses the issue of having disparate virtual interface mtu settings. This may affect dynamic routing protocols such as OSPF from becoming neighbors.

The ip tcp adjust-mss addresses the issue of fragmentation from hosts traversing these links.

In short, the configuration guide will get your PPPoE setup working while you need to look for other guides in order to optimize it.

Regards,

Edison

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Edison Ortiz Tue, 07/20/2010 - 05:51

The ip mtu command addresses the issue of having disparate virtual interface mtu settings. This may affect dynamic routing protocols such as OSPF from becoming neighbors.

The ip tcp adjust-mss addresses the issue of fragmentation from hosts traversing these links.

In short, the configuration guide will get your PPPoE setup working while you need to look for other guides in order to optimize it.

Regards,

Edison

Actions

This Discussion