Catalyst 3750 Switch Device Manager in Stack issue

Unanswered Question
Jul 20th, 2010
User Badges:

Hello,


   I have a stack of 6 3750's.  One had to be replaced and now the SDM is inoperative.  The show switch doesn't indicate a mismatch.  Is there a command I can issue to discover why the SDM is not working from HTTP.


Thankyou,


Denise

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dparsons Tue, 07/20/2010 - 05:06
User Badges:

Hi NT,


Yes,  I have it there, "ip http-server".  All looks ok, but not http SDM.  A" show platform stack-manager all" indicates all is good and no mismatches as well.


The SDM template is "desktop default".


From top master to bottom:

WS-C3750G-48TS

WS-C3750-48TS

WS-C3750G-48TS

WS-C3750-48TS

WS-C3750-48TS

WS-C3750-48P


Denise

Nagaraja Thanthry Tue, 07/20/2010 - 05:15
User Badges:
  • Cisco Employee,

Hello,


When you say "no SDM", are you referring to the GUI or something else? If

you are referring to GUI, can you attach the output of "show flash" from the

stack master? Also, the output of "show interface vlan "

would be great.


Regards,


NT

dparsons Tue, 07/20/2010 - 05:47
User Badges:

Hi,


Yes, it's the GUI access that's not working.


Here are the show command results.


Thanks for such quick replies


Denise


MC_SW3081#sh int vlan 2

Vlan2 is up, line protocol is up

Hardware is EtherSVI, address is 0016.c8b6.5b41 (bia 0016.c8b6.5b41)

Internet address is 10.69.2.243/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 4000 bits/sec, 8 packets/sec

5 minute output rate 3000 bits/sec, 3 packets/sec

78168170 packets input, 1440859699 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

5852049 packets output, 605918419 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

MC_SW3081#sh flash


Directory of flash:/


2 drwx 64 Dec 31 1969 20:32:13 -04:00 c3750-ipbase-mz.122-25.SEE1

3 drwx 64 Feb 28 1993 20:02:34 -04:00 update

363 -rwx 4696 Jul 8 2010 13:11:20 -03:00 vlan.dat

5 drwx 128 Feb 28 1993 20:39:31 -04:00 c3750-ipbase-mz.122-25.SEB4

366 -rwx 27 Jul 8 2010 13:11:34 -03:00 private-config.text

6 -rwx 5508786 Feb 28 1993 20:42:48 -04:00 c3750-ipbase-mz.122-25.SEB4.bin

368 -rwx 133233 Jul 8 2010 13:11:34 -03:00 config.text


32514048 bytes total (12944896 bytes free)

MC_SW3081#sh switch

Current

Switch# Role Mac Address Priority State

dparsons Tue, 07/20/2010 - 06:44
User Badges:

Hi,


More information.  I rebooted the stack and cleaned up all the flash files to be the same. c3750-ipbase-mz.122-25.SEE1.bin No change to GUI access to SDM.   SDM template is "desktop default".  One this I did notice was all switches have the IOS in a flash directory except switch 3 is just the .bin file.  Would switch 3 be missing any SDM configurations files ?


Denise

Nagaraja Thanthry Tue, 07/20/2010 - 07:44
User Badges:
  • Cisco Employee,

Hello,


If switch 3 is the stack master, then yes, that would affect the GUI access.Can reboot switch 3 and see if that helps?


Regards,


NT

dparsons Tue, 07/20/2010 - 08:59
User Badges:

Hi NT,


Switch 1 is the master. Here is a copy of the show switch and flash results as well. Looks like switch 3 was upgraded without using the .tar file. Is there anyway to copy to IOS/HTML directory from another switch to this one ?


Denise


MC_SW3081#sh switch

Current

Switch# Role Mac Address Priority State

Nagaraja Thanthry Tue, 07/20/2010 - 09:56
User Badges:
  • Cisco Employee,

Hello,


Unfortunately, you cannot copy the folder like that. You could however, install the tar image on switch 3 alone. As far as access to the device is concerned, let us try the following:


On the switch, please issue the following command:


ip http path flash1://html


Hope that fixes the issue.


Regards,


NT

dparsons Wed, 07/21/2010 - 04:57
User Badges:

Hi NT,


That command did not work. So I loaded the latest .tar using the following command and all is working now 100%.


archive download-sw tftp://x.x.x.x/c3750-ipbase-tar.122-53.SE2.tar


Thanks for all your replies.


Denise

Actions

This Discussion