Connecting 3750 stacks help please?

Answered Question
Jul 20th, 2010
User Badges:

Hi,



I've been asking about connecting two stacks and have finally got to the stage where I'm ready to go but was hoping someone could have a quick look at this to see if I'm missing anything?


Stack1 is our existing production stack and cannot have any downtime

Stack2 currently only contains one 3750 Catalyst switch, this will increase over time


I have created an etherchannel port on both stacks ready to link them.  Stack 1 is the VTP server and stack 2 is set to VTP client.  Stack 1 has a loopback address of 10.130.0.1 although when the stacks are connected I will be changing this to use HSRP with the .1 address as the standby address.  Below is the relevant config of the switches, are the OSPF settings valid?


Anyway, if anyone sees anything blatantly wrong or if there is something else I neeed to look at please let me know.  Apologies if this is very basic but you have to start somewhere don't you .  I'm just terrrified of joining the stacks and bringing everything down.


Stack 1


interface Loopback0
ip address 10.130.0.1 255.255.255.255


router ospf 1
router-id 10.130.0.1
log-adjacency-changes
redistribute static subnets route-map static2ospf
network 10.130.0.0 0.0.255.255 area 130


interface Port-channel30
description EtherChannel to Stack2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate


interface GigabitEthernet1/0/25
description Po30 member stack 2 etherchannel
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
mls qos trust dscp
channel-group 30 mode on
!
interface GigabitEthernet1/0/26
description Po30 member stack 2 etherchannel
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
mls qos trust dscp
channel-group 30 mode on


STACK1#sh etherchannel summary


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
30     Po30(SD)         -        Gi1/0/25(D) Gi1/0/26(D)


STACK1#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 24
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 21
VTP Operating Mode              : Server
VTP Domain Name                 : stacks
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x53 0xCF 0xFB 0x10 0x0F 0xAE 0x7B 0x6C
Configuration last modified by 10.130.1.1 at 6-16-10 12:35:49
Local updater ID is 10.130.1.1 on interface Vl1 (lowest numbered VLAN interface found)


Stack 2


interface Loopback0
ip address 10.130.0.3 255.255.255.255


router ospf 1
router-id 10.130.0.3
log-adjacency-changes
redistribute static subnets route-map static2ospf
network 10.130.0.0 0.0.255.255 area 130


interface Port-channel30
description EtherChannel to Stack1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate


interface GigabitEthernet1/0/49
description Po30 member stack 1 etherchannel
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed 1000
mls qos trust dscp
channel-group 30 mode on
!
interface GigabitEthernet1/0/50
description Po30 member stack 1 etherchannel
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed 1000
mls qos trust dscp
channel-group 30 mode on


Sh Etherchannel summary


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
30     Po30(SD)         -        Gi1/0/49(D) Gi1/0/50(D)


STACK2#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Client
VTP Domain Name                 : stacks
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xE3 0x08 0x2D 0xC3 0x8D 0x99 0xE1 0x5D
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Correct Answer by Nagaraja Thanthry about 7 years 1 week ago

Hello,


When you configure spanning-tree vlan root primary on the stack 1, it

will ensure that your outage is minimal and adding the new stack will not

affect your performance. If that command is not added, there is a chance

that during the recalculation, Stack 2 assumes the root role and all your

traffic need to pass through Stack 2. When you retire Stack 1, the Stack 2

automatically assumes the role of root because it is configured as root

secondary. However, it will not completely eliminate to downtime that will

be due to spanning-tree recalculations (when adding the stack).


Hope this helps.


Regards,


NT

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Nagaraja Thanthry Tue, 07/20/2010 - 04:58
User Badges:
  • Cisco Employee,

Hello,


The configuration looks good. One thing that is missing is the spanning-tree

configurations. Since stack 1 is already up and running, I would suggest

configuring it such that it retains the root position when you connect the

new stack.


"spanning-tree vlan root"


Also, remember that you will have a short down-time till the spanning-tree

converges.


Hope this helps.


Regards,


NT

Dwillcocks_2 Tue, 07/20/2010 - 05:33
User Badges:

Thanks NT,


If I apply the spanning-tree vlan root command to stack 1, what would the outage affect, Stack1, Stack 2 or both?


The next stage of my plan is to move some switches to stack 2 and finally retire Stack 1.  Would it be worthwhile adding the spanning-tree vlan root primary to stack1 and spanning-tree vlan root secondary to Stack 2?


Once stack 1 is retired I could change Stack2 to be primary or even remove the command?


Thanks again for your help.


Dave


edit:

I have just looked at the config on stack 1 and seen the following lines


spanning-tree mode pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1-2,10-13,50 priority 24576


Will this affect anything?

Correct Answer
Nagaraja Thanthry Tue, 07/20/2010 - 05:40
User Badges:
  • Cisco Employee,

Hello,


When you configure spanning-tree vlan root primary on the stack 1, it

will ensure that your outage is minimal and adding the new stack will not

affect your performance. If that command is not added, there is a chance

that during the recalculation, Stack 2 assumes the root role and all your

traffic need to pass through Stack 2. When you retire Stack 1, the Stack 2

automatically assumes the role of root because it is configured as root

secondary. However, it will not completely eliminate to downtime that will

be due to spanning-tree recalculations (when adding the stack).


Hope this helps.


Regards,


NT

Actions

This Discussion