inter-vlan routing

Unanswered Question
Jul 21st, 2010
User Badges:

i created i new vlan 100 with ip address 172.16.10.1 255.255.255.0 for a new server range.



current vlan i have are

vlan20

192.168.20.1 255.255.255.0


vlan30

192.168.30.1 255.255.255.0


vlan40

192.168.40.1 255.255.255.0


i m using cisco 3560.

ip routing is enabled.


i can ping to 172.16.10.1 but i cannot reach my server at 172.16.10.2 from my core switch which is having the above vlan config.

my switch is connected to port 30 with the following config.


interface GigabitEthernet0/30
switchport access vlan 100


sh vlan shows all my vlan are up.


what else must i do so that i can ping 172.16.10.2 255.255.255.0,  default gateway 172.16.10.1 on my server.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

dear

you current confugration in your core switch :

vlan20

192.168.20.1 255.255.255.0


vlan30

192.168.30.1 255.255.255.0


vlan40

192.168.40.1 255.255.255.0


vlan100

192.168.10.1 255.255.255.0


if the server port access port for vlan 100 and server network configration 192.168.10.2 255.255.255.0 g 192.168.10.1

you must can reach server by ping command .


try to disable firewall in your server , and what operating seyetem for your server ?


,,,,

please do the below and copy outlet here 

# sh run

# sh vlan

yeow_km Wed, 07/21/2010 - 05:21
User Badges:

vlan 100

172.16.1.1 255.255.255.0



its a new server, no firewall setup so far.

is there any difference is vlan100 is 172.16.1.1/24 while the remaining vlan are using 192.168.20.1/24 IP range ??

yeow_km Wed, 07/21/2010 - 06:09
User Badges:

i currently do not have remote access to the switch.

that's all  i can remember.


sh run int gi0/30


interface GigabitEthernet0/30

switchport access vlan 100

Nagaraja Thanthry Wed, 07/21/2010 - 06:35
User Badges:
  • Cisco Employee,

Hello,


From your earlier description, your server has an address of 172.16.10.x with default gateway pointing to 172.16.10.1. In order to acheive connectivity to the server, you might need to add few things on both the core as well as the remote switch.


On the Remote switch:


interface vlan 100

ip address 172.16.10.1 255.255.255.0

exit


On the core switch:


ip route 172.16.10.0 255.255.255.0


If you have a routing protocol enabled in the network, you can just include the new subnet range in the routing protocol itself.


Hope this helps.


Regards,


NT

ch_sajid_hussain Wed, 07/21/2010 - 06:37
User Badges:

check encapsulation for this port.

these commands may be help you.


switchport mode access

switchport access vlan 100

switchport trunk encapsulation dot1q

yeow_km Wed, 07/21/2010 - 07:02
User Badges:

the server is directly connected to the core switch with the commands as mentioned.

there is not another switch between the server n switch.

i dont have routing protocol enabled in the network.

Nagaraja Thanthry Wed, 07/21/2010 - 07:18
User Badges:
  • Cisco Employee,

Hello,


Can we try the reverse of what you are doing now i.e. try pinging from the server to rest of the network? Typically the servers do come with the firewall enabled and they block ICMP in the firewall. This excercise will tell us if the issue is with the server or is it with your network.


Hope this helps.


Regards,


NT

manish arora Wed, 07/21/2010 - 09:36
User Badges:
  • Silver, 250 points or more

Hi,

I agree with NT , you should check from server in vlan 100 and try pinging the switch from the server. it could probably be an issue with some kind of firewall running on the server. also , try using another port instead of port 30 on the switch with a different cable 9 ( tested - straight cable ).

thanks

manish

Actions

This Discussion