Question about ip helper-address in VRF environnement

Unanswered Question
Jul 21st, 2010

Hello,

I have a question about DHCP in VRF environnement.

Attached file is my architecture.

The configuration of the switch is the following :

ip vrf SRV

ip vrf USR
!

interface Vlan1
description SERVER

ip vrf forwarding SRV
ip address 10.1.1.254 255.255.255.0
ip directed-broadcast

!

interface Vlan2

ip vrf forwarding SRV
ip address 10.2.2.254 255.255.255.0
ip helper-address 10.1.1.1
ip directed-broadcast

!

interface Vlan3

ip vrf forwarding USR
ip address 10.3.3.254 255.255.255.0
ip helper-address 10.1.1.1
ip directed-broadcast

!

interface Vlan11

ip vrf forwarding SRV
ip address 192.168.11.254 255.255.255.0
ip directed-broadcast

!

interface Vlan10

ip vrf forwarding USR
ip address 192.168.10.254 255.255.255.0
ip directed-broadcast

ip route vrf SRV 0.0.0.0 0.0.0.0 192.168.11.253

ip route vrf USR 0.0.0.0 0.0.0.0 192.168.10.253

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tableau Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

The routing inter VRF is assume with the firewall (pass all for the moment).

My problem is that the DHCP client in the VLAN2 receive an IP address with the DHCP Server.

But the DHCP client in the VLAN3 does not receive an IP address with the DHCP Server.

Could you explain to me this problem (error in my configuration, ...etc)?

Thank you.

Regards.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chetan Kumar Ress Wed, 07/21/2010 - 09:50

Hi Laurent,

In your senario you have configured two VRF &  VLAN1 & VLAN 2 are in same VRF ,reasone that you are able to get the IP from DHCP.

But VLAN 3 is in USR VRF , So USR VRF cannot communicate with SRV VRF DHVP Server.

VRF is Routing Instance which have different routing table for each VRF.

Different VRF cannot communicate until an unless you configured them to communicate.

You can check that from USR VRF you will not able to ping DHCP server. Because in USR routing table you will not see any network or route for your DHCP server( 10.1.1.1 ).

But in SRV VRF you can see the network 10.1.1.X & will able to ping DHCP server.

Regards

Chetan kumar

r.laurent Thu, 07/22/2010 - 07:11

Hi Chetan,

Thank you for your response.

I have resolved the problem : bad gateway for the IP Vlan 3.

Regards.

Actions

This Discussion