How to modify RADIUS Servers on a 4402 controller?

Unanswered Question
Jul 21st, 2010

I have several controllers, including a 4402 running software and I need to modify the Radius servers that it uses. Currently I have three servers listed;

1 -

2 -

3 -

I would like to delete server 1 which is being retired and replace it with a new server 1. I suspect, once i get servwe 1 deleted, the server 1 option would become available when I create a new server. I went into the controller and disabled server one, but every time I try and delete it, I get the "Server in use either on a specific WLAN or Mesh Radius Server Configuration" error. I can't find anywhere this server is still in service and being used, either by a WLAN or a Mesh. I've tried several different variances to modify this and have run out of ideas. What I hope to avoid is the need to reset the controller. I have a total of seven controllers that I need to make this modification to, and It will be ugly if I have to reboot these units. Hospital mission critical stuff.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Saravanan Lakshmanan Thu, 06/14/2012 - 16:03

did you try from cli.

you could disable the decomissioned rad server

are you able to delete other rad server, and or add/create new radius server then you are good for now

WLC>show switch config

May be the config is corrupt on wlc.

backup the config, delete the required radius server, restore the edited config, reboot the WLC, sorry

I had tried disabling all WLANs, deleting the WLAN which used the servers, neither helped.

Tried the same from the command line, which also did not help.

I was not able to change the shared secret for the Radius servers either, which was originally all I had wanted to do.

Fortunately most of my controllers are cookie cutter from one another and I was able to recover-config and copy the configuration of a WLC from a different hospital and change the relevant interfaces and all was well.

Parmanand Patil Tue, 04/08/2014 - 00:52

I am also facing the same problem, I did not get the solution from above post.

Can anyone help me as I am trying to configure the WLC to add into radius for MGT user authentication & its not working.

At the same time my network user's are being authenticated from radius server's configured in WLC.





This Discussion

Related Content



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode