Cisco 2950 switch - Can't connect via console cable

Unanswered Question
Jul 21st, 2010
User Badges:

Hi Guy's

I have just purchased some equipment to help me study for the CCNA exam, we my equipment arrived, I started it all up made sure it booted etc and I could connect into it, and running the software as described, which it was.

I then unplugged it, and left it for the night, come to connect into one of my switches today, 2950, and it will not work via hyperterminal using the console cable, I have tried using another cable, to no avail, nor using another computer. However I can access the rest of my hardware.

The switch seems to be working fine, the LEDS indicate its started up fine etc, and if I leave it on and connect from the ethernet port of one of my rotuers, for example an 2620xm, then the LED on the router and switch are both green. Furthermore if I use the command *show cdp neighbors detail* I can see the switch and its information, it is currently running IOS 12.1(9) if that helps.

As the switch has no IP address I am unable to use telent to connect into it, and as it is the wrong version, cannot reset it and use the Express setup.

If anyone can help, before I ring up tomorrow to get the unit replaced, that would be great



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Siddharth Chand... Wed, 07/21/2010 - 14:29
User Badges:
  • Cisco Employee,


If you connect the 2950 switch via ethernet cable to another switch and you see the 2950 in 'show cdp nei' it means the switch is up and running.

So I see 3 possible problems:

1. Bad console cable.

2. Bad console port.

3. Incorrect hyperterminal settings.

You might want to check your hyperterminal settings first. Check the link below.

If this is correct, then try a different console cable.

If it fails with more than one console cable with correct hyperterminal settings, then you have a bad console port on the switch.

Sid Chandrachud

Customer  Support Engineer

Cisco TAC

dle1232003 Wed, 07/21/2010 - 14:42
User Badges:

well i've done all that already, 3 different cisco cables, used hyperterminal and putty, and different settings for the connection, so must be a bad console port, shall have to send it back then,

ps the link for me is forbidden


dle1232003 Wed, 07/21/2010 - 15:40
User Badges:

i am logged in and the latest link you sent is forbidden

Siddharth Chand... Wed, 07/21/2010 - 15:53
User Badges:
  • Cisco Employee,

Here are the recommended settings for hyperterminal:

When you set       up the connection, use these settings:

Bits per sec    :  9600 
Data bits       :     8
Parity          :  none
Stop bits       :     1
Flow control    :  none

For the issue of not being able to access the link, clear browser history, delete the cookies and try again.

- Sid

Reza Sharifi Wed, 07/21/2010 - 17:26
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN


If you have tried all the con setting (9600, 115200 and 38400) try one more thing.  Connect to Con cable to the router then turn it off and back on with con cable connected and see if you see anything on the screen



Nagaraja Thanthry Wed, 07/21/2010 - 17:39
User Badges:
  • Cisco Employee,


Try to boot the switch into "Switch:" prompt by holding the MODE button when the switch comes up (power off, hold the mode button, power on and wait till the light on the first port goes off). Once that is done, now try to connect the console cable and see if you get anything on the HyperTerminal. Try changing the speed of the HyperTerminal line (I would prefer Putty client as changing the speed is lot easier than regular HyperTerminal application) and see if you can get the "Switch:" prompt. This is worth a try.

Hope this helps.



dle1232003 Thu, 07/22/2010 - 04:00
User Badges:

nope no look with either suggestions unfortunately

armandawongso Thu, 08/12/2010 - 21:36
User Badges:

I have the same problem here.

I cannot connect the device via console cable.

I already reboot the device, but the condition still same.

what should i do?

need some help and suggestion

dle1232003 Fri, 08/13/2010 - 04:02
User Badges:

Send it off for a replacement from where you bought it from,

theres nothing else you can do, as I found out, if trying different settings doesnt work, then the console port has failed by the sounds of it.


This Discussion