ASA 5505, 8.3 Inbound traffic rejected after reboot

Answered Question
Jul 22nd, 2010

When moving to ASA 8.3 I wanted to learn the new NAT features. However, I have encountered an annoying problem.

After a reboot, inbound traffic is blocked. I have to disable-apply-enable-apply all the ACL firewall ACL entries rules - all together - for allowing inbound initiated traffic to flow. There is no problem with traffic initiated from inside.

I have reduced the config to a minimum. With only one access list entry there is no problem. When I add another (e.g. the line tagged with (*****) the problem appears again after a reboot.

I work 99.9% from ASDM.

Object NAT and 'twice' NAT make no difference.

(FUI: Not included in the config but I encounter a similar problem with aaa authentication. That too is fixed by the above disable-apply-enable-apply procedure.)

Any ideas? TIA.

Best regards
Jan Straegaard

Company related external IP addresses modified.

ASA Version 8.3(1)6
!
hostname asa
enable password zzzzzzzzz encrypted
passwd zzzzzzzz encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan12
description DMZ network
no forward interface Vlan2
nameif dmz
security-level 50
ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 12
!
boot system disk0:/asa831-6-k8.bin
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network diskstation
host 192.168.1.180
object network pea-adsl
host XXX.179.228.98
object network top-hide
host WWW.ZZZ.232.33
object service http-srv-obj
service tcp destination eq www
access-list outside_access_in extended permit tcp object pea-adsl interface outside eq www
access-list outside_access_in extended permit tcp object top-hide interface outside eq www (*****)
pager lines 24
logging enable
logging timestamp
logging buffer-size 1000000
logging asdm-buffer-size 512
logging buffered informational
logging trap informational
logging asdm informational
logging host inside 192.168.1.170
logging permit-hostdown
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
!
object network obj_any
nat (inside,outside) dynamic interface
object network diskstation
nat (inside,outside) static interface service tcp www www
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http XXX.179.228.98 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.36 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 193.162.145.130 source outside
ntp server 193.162.159.194 source outside prefer
webvpn
username admin password zzzzzzzzzzzz encrypted
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:68292e20e242590aee7df00495c81ca1
: end

Correct Answer by Panos Kampanakis about 6 years 7 months ago

You are allowing inbound traffic

access-list outside_access_in extended permit tcp object pea-adsl 
interface outside eq www 
access-list outside_access_in extended permit tcp object top-hide interface outside eq www (*****)
object network diskstation
   nat (inside,outside) static interface service tcp www www

In 8.3 you need to allow traffic to the local/real ip address. So you would need to change the ACL to allow inbound conns

access-list outside_access_in extended permit tcp object pea-adsl object diskstation eq ww

I hope it helps.

PK

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Panos Kampanakis Thu, 07/22/2010 - 15:55

You are allowing inbound traffic

access-list outside_access_in extended permit tcp object pea-adsl 
interface outside eq www 
access-list outside_access_in extended permit tcp object top-hide interface outside eq www (*****)
object network diskstation
   nat (inside,outside) static interface service tcp www www

In 8.3 you need to allow traffic to the local/real ip address. So you would need to change the ACL to allow inbound conns

access-list outside_access_in extended permit tcp object pea-adsl object diskstation eq ww

I hope it helps.

PK

janstr3360 Fri, 07/23/2010 - 04:45

Thanks PK. It helped!

I was using real addresses in the beginning, but packets were dropped, so I believed I had misunderstood something in the release description. So I started using mapped addresses again. Mapped addresses apparently works - until rebooting - I wonder why!?!?!

I will now restore my full configuration and make the address ajustments. I wonder if my aaa authention problems are solved by this.

Thanks again!

/Jan

Panos Kampanakis Fri, 07/23/2010 - 06:07

That is great!

Since it resolved your issue please mark the question as resolved so other people can use it for reference in the future.

Rgs,

PK

Actions

This Discussion

Related Content