VXML application on the dedicated FXO port

Unanswered Question
Jul 22nd, 2010
User Badges:

I have 2811 router with 2 EM-HDA-4FXO cards. FXO ports are connected to PSTN.

Routers acts as h323 gateway. Task is to configure VXML application on one of the FXO port to serv inbound calls.


The issue is that I couldn't configure inbound dial-peer that will be matched on incoming call to the FXO port.

Due to http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

FXO port doesn't have DNIS and it could be matched as inbound only by answer-address, destination-pattern, port number.

Configuring "answer-address ." is not a solution because in this case any inbound call to any FXO port will be matched and served by VXML application.

Configuring destination-pattern also has no effect. As I can see from  "debug voip dialpeer inout" inbound call will be always matched by the pots dial-peer that had been configured with "destination-pattern .T".



Here is FXO port configuration


voice-port 1/0/17

supervisory disconnect dualtone pre-connect

cptone RU

timeouts initial 20

timeouts interdigit 20

timeouts call-disconnect 1

timeouts wait-release 2

connection plar 1234567

caller-id enable


here is dial-peer that I want to configure as inbound


dial-peer voice 300 pots

service test

destination-pattern 1234567

incoming called-number 1234567

port 1/0/17


How can I configure 2811 for executing VXML script only when call arrives to the selected FXO port?

Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Steven Holl Wed, 07/28/2010 - 08:03
User Badges:
  • Cisco Employee,

It may benefit you to turn on 'debug voip dial-peer all' and watch how the dial-peer matching is occurring.


What I would do in your scenario is not have *any* POTS dial-peers with incoming called-number nor answer-address defined.  Or if you do, don't use a '.' wildcard anywhere otherwise that will be a valid match.


Now, you need to be careful that ANI with destination-pattern doesn't match anything.  So you need to make sure that the ANI coming in the port doesn't match any 'destination-pattern' statements on any POTS peers.  Assuming that's okay, it will match based on port, which you already have configured, and you should be good.


The other option is to configure a station-id number under the port.  This will force a specific ANI when that port is hit.  You then can use answer-address under the dial-peer with that ANI, which will match based on that criteria.  This will, however, make all calls in from this port have whatever ANI you configure here.  So if that FXO is from a PSTN circuit, it would defeat the purpose of inbound CLID.



If you can post the output of 'debug voip ccapi inout' and your full configuration (all voice-ports and dial-peers), I can be more specific on suggestions which will work.  It's partially circumstantial based on how you are doing inbound dial-peer matching for other ports/circuts.

MaximBudyonny Fri, 07/30/2010 - 03:28
User Badges:

Steven, thank you for reply.


I have found a workaround for this issue, i.e. if my pots dial-peer 300 is correctly matched as outbound dial peer, just configured application for outbound


dial-peer voice 300 pots
service test out-bound
destination-pattern XXXXXX
incoming called-number XXXXXX
port 1/0/17

This configuration works pretty fine!




As to a 'debug voip ccapi inout' as I remember default application was started to handle call. I will post output a bit later.


Also I found that my configuration has a kind of phone security leak.



When I called from PSTN to number XXXXXX then FXO port 1/0/17 goes off-hook and I've heared dial tone. After that I was able to input in tone any phone number and place a call to ANY number through the 2811 box.

Actions

This Discussion