Unanswered Question
Jul 22nd, 2010
User Badges:

Currently our company is testing two Cisco's cameras.

First one, CIVS-IPC-2500, is fine. Second, CIVS-IPC-4500, is not.

First of all, only IE and FF can get trough login page, but Chrome can't -- after click to Login button, Chrome goes to login page, again and again.

I don't believe that anything is wrong with Chrome.

Secondly, if click to View Video on the web client, error arise about wrong version of .NET SDK (, however IE8 shows something else (

I do believe that issue is firmware. Current version of it is 1.0.1 ( Attempt to download it from Support just failed.

Could anyone be so kind to help with it, please?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
sergei.plaxienko Thu, 07/22/2010 - 22:53
User Badges:

The solution for mentioned issue is to install oldest IE6 what you can find, and oldest .NET SDK, but newer than version 2.0

The second step, what you must do, is to turn off all security things in IE6, even if you pretty sure that this buggy browser already has all them turned off.

Don't even hope -- you must turn them off further.

Third -- update firmware to latest 1.0.3. Where you will find it is a big mystery, since on it is not available for download.

Should I not mention that upgrade can be done only in IE6.

Fourth step is to check how IE6 is trying to show HDTV video and hung. And hung. Period.

Thus, obviously, last step came -- return CIVS-IPC-4500 to Cisco' office and never ever try this crаp again. Sic!

Edward Swenson Fri, 07/23/2010 - 10:09
User Badges:
  • Cisco Employee,

Hi Sergei

Sorry for the trouble you've been having. I do see 1.0.3 firmware on CCO and am

checking if we have something later, even if it isn't released yet. If you want to try

again let me know and I'll work on getting a lab setup to work on your problem.


Edward Swenson Fri, 07/23/2010 - 10:50
User Badges:
  • Cisco Employee,

Ok, cool, I thought you might have already taken the camera back.

I found a 4300 camera running 1.0.3, and I get an error trying

to view with FF.

.NET SDK/Runtime 2.0 or above is not available

which is expected since IE/ActiveX are required to view video.

Now I need to get Windows going so I can test with IE

Edward Swenson Fri, 07/23/2010 - 11:19
User Badges:
  • Cisco Employee,

So, I have a windows virtual machine running on my Mac and was able to pull up IE.

At first I didn't see any video, but when I had my mouse in the video pane it displayed

a little popup asking me to download, I'm not sure what

exactly that is, some sort of ActiveX control I guess. Now I'm able to see SD video.

The user guide does say IE 6.X is required, so I think that explains why later

versions didn't work for you.

Are you able to see SD video ? or nothing at all ?

sergei.plaxienko Sun, 07/25/2010 - 20:41
User Badges:

When I try to View Video the only thing popups for download is [1]DxPlay[2].cab, nothing like

What do you mean by SD? There is nothing like that.

Edward Swenson Mon, 07/26/2010 - 09:54
User Badges:
  • Cisco Employee,

I discovered that message was from a 2500 camera, which worked fine

after I realized I needed to click to install the ActiveX control.

The "does not support object or method" error seems to be a way of

saying "download an ActiveX control". The actual error about ActiveX was

quite small, and in the background.

Now I'm trying on a 4500

sergei.plaxienko Mon, 07/26/2010 - 19:17
User Badges:

I've tested CIVS-IPC-2500 too, and after short shaman's dance it works just fine. So, I would say that there is no issues with 2500 camera.

slaanoi Fri, 07/23/2010 - 12:07
User Badges:

Hello Sergei,

What appears to be happening is that your browser is blocking ActiveX initialization because of the default security settings of the Internet Zone. The browser sees the script as not safe so it disables its initialization. The solution, and this should work for IE7 and IE8 as well, is to add the camera as a trusted site in the trusted zone and enable all ActiveX settings under Tools > Internet Options > Security > Trusted Sites > Custom level. After initialization of the ActiveX controls is complete, reset the settings to the default and the script should now run ok allowing viewing live video under default medium Internet zone settings.

Note that v1.0.3 firmware for the 4000 series HD cameras is available on CCO at:

If you restart your browser and log in to view the live feed - what is the result? What are your stream settings for the active channel?



sergei.plaxienko Sun, 07/25/2010 - 20:47
User Badges:

Here is settings what I made in IE8:

Sorry for Russian, there is no way to switch IE8 to English interface. is camera's address.

Only for testing I set all settings to the lowest level:

When click View Video in web, next error arise:

Can't say how this error sounds in English, but if translate it says "Object does not support property or method".

Even more, may be it help, when press any control button on the interface above, nothing works, and next error indicates on the corner of IE8:

I think that it might be a issue not with ActiveX only, but with Java too.

sergei.plaxienko Sun, 07/25/2010 - 20:59
User Badges:

I've checked installed Java's version:

Version 6 Update 20.

I doubt that camera needs newer version.

Holly Goguen Mon, 07/26/2010 - 07:24
User Badges:
  • Cisco Employee,

Hi Sergei,

It sounds like the active X controller could not install properly.

Can you please try the following:
ensure that you are logged in as an Administrator of that machine
Un-install DxPlayInstaller from Control Panel -> Add/Remove Programs
Then connect to the camera web interface and allow Active X to install which will re-install DxPlayInstaller


sergei.plaxienko Mon, 07/26/2010 - 19:21
User Badges:

I am logged to this particular system as administrator for 100%.

What about DxPlayInstaller -- can't find it.

sergei.plaxienko Tue, 07/27/2010 - 01:19
User Badges:

Nope, I have not seen mentioned post.

bcc.technik.ip wrote:

have you tried to reinstall the DxPlayinstaller ( not only deactivate it in IE!! ) ?

How should I reinstall it? There is no such programs in Add/Remove:

sergei.plaxienko Mon, 07/26/2010 - 19:48
User Badges:

Today is the last day of testing period, and it looks like we won't bring the camera up.

sergei.plaxienko Tue, 07/27/2010 - 02:18
User Badges:

Here is a solutuon.

First of all, if you have similar issues, you must manually download DxPlayer directly from camera.

The address for download is: https://192.168.0.x/utility/

It might be http, not https, be aware. And do not forget to change 0.x with you camera's ip address.

After download, extract both files -- DxPlay.inf and DxPlayInstaller.msi -- and run .msi file.

It runs with no messages and you must check if it's installed in Add/Remove Programs:

Second step, what you must do, is to turn off all security things in IE. FF and Chrome won't work, don't even try.

I was able to bring CIVS-IPC-4500 up in IE8, here is a proof:

But camera is still not in full operation -- Motion Detection does not work.

When press "Save Settings" error message appears:

sergei.plaxienko Tue, 07/27/2010 - 02:26
User Badges:

Snapshot doesn't work either:

It says that in GDI+ arise error of common view. I have to clue, what it means.

No need to say that no snapshoots were created.

sergei.plaxienko Tue, 07/27/2010 - 02:32
User Badges:

If after all this shaman's dances your camera still doesn't want to show any picture, make sure that SRTP is on:

Without SRTP camera shows only Malevich's square and nothing else.

jfengAtepic Wed, 04/27/2011 - 07:44
User Badges:

Do you know if I can view the live video of CIVS-IPC-4500 through a third party application? Thank you !

jfiranzi Mon, 05/02/2011 - 21:47
User Badges:
  • Bronze, 100 points or more

Hi Jie,

If you are asking about 3rd party custom written applications, you would have to contact the Cisco Physical Security Business Unit and make a case for requesting the camera API for the current HD camera firmware.  With the API doc, a skilled programmer should be able to author a custom app to view video.  Use the email alias [email protected] to request the camera API.

If on the other hand you mean an off the shelf or freeware program, VLC Media Player can be used.  You may have to try an older version of VLC if you have trouble with later releases.  I believe 0.9.4 worked.  If you need them, the older versions of VLC may be found here:

High Definition (HD) IP Camera

VLC Media Player can also be used to view the video streams from Channel 1

and Channel 2 from the HD IP camera. Accessing the Video Stream on the HD IP camera requires gathering additional

information from the HD IP Camera. You must access the HD IP Camera via HTTP to gather the following

parameters: sessionID, ChannelName for Both Channels.

• Navigate to the Streaming Settings on the Camera web page and get the sessionID parameter from the “URL”

ie. HTTP to HD IP Camera

• Confirm & Record the Channel Name (s). For Example, "Channel1" or “Channel2”.

URL Location: rtsp://< HD CAMERA IP ADDRESS >/StreamingSetting

StreamingSetting ?version=1.0&action=getRTSPStream&sessionID=< SESSION-ID >&ChannelID=< 1 or 2

>&ChannelName=< Channe1 or 2>





In the example above, is the HD Camera IP Address.
‣ 1234567 is the sessionID from the URL. This will be different for each new session.
‣ Channel ID is “1” and ChannelName is “Channel1” (the primary stream from this camera.)

Follow the SAME steps for VLC that are listed in the SD IP Camera section above. The ONLY change is the “Media
Resource Locator (MRL)” address. Just use the HD IP Camera URL format shown above.

I hope that helps...


Dirk-Jan Uitten... Tue, 05/03/2011 - 13:44
User Badges:
  • Cisco Employee,

Interesting. I was able to install the DxPlay.msi. After clearing  IE8's browser cache, cookies and restarting the browser an error message  popped up when opening the View Video screen:

"Failed to setup DirectShow Filter Graph


System.Runtime,InteropServices.COMException  (0x80040273): Creating an instance of the COM component with CLSID  {51B4ABF3-748F-4E3B-A276-C828330E926A} from the IClassFactory failed due  to the following error: 80040273.

at DxPlay.VideoControl.setupGraph(Control hWin, String FileName, ViewerSetting viewerSetting)"

strange ;-)


mishaaltk Tue, 07/26/2011 - 08:34
User Badges:

Im getting the same errors on FF and IE

Dont know wt to do, ive tried everything mentioned is this post so far with no luck!

mishaaltk Wed, 08/17/2011 - 06:34
User Badges:

Im still getting the same error as above: "Failed to setup DirectShow Filter Graph"

jfiranzi Wed, 08/17/2011 - 10:30
User Badges:
  • Bronze, 100 points or more

Hi Mishaal,

It sounds as if you may be hitting a known bug in earlier versions of VSM. 

This occurs with the VS Client for 6.2.0 and 6.2.1 releases on Windows XP SP2 (and SP3)

The defect  is CSCte46953

When viewing the 4500 camera directly, error message :

Failed to setup DirectShow Filter Graph

4500 camera  (I believe only with H.264 codec)


Un-install DxPlayInstaller from Control Panel in Windows.

Then connect to the camera web interface and allow Active X to install which will re-install DxPlayInstaller

I hope that helps,

mishaaltk Wed, 08/17/2011 - 16:18
User Badges:

What you're saying here, ive tried it over a 100 times without luck.

I have VSM 6.2.1 on an ISR 2911 SRE. I am also unable to upgrade it to the latest version of 6.2.2 (for the ISR only)

But the problem is not in the software as i am accessing the IP Camera interface directly.

jfiranzi Mon, 08/01/2011 - 09:55
User Badges:
  • Bronze, 100 points or more

The VLC suggestion was in response to Jie's reply (I have never tried using VLC with SRTP, only RTSP)

For a camera with IP address for example, first log into the camera web interface via IE, authenticating as admin with a password (or another logon with at least view priviledges), and click on View Video.  In the address bar, you will see something like the following:

In order to establish the stream in VLC, you would need to use


That should permit viewing Channel 1 from the camera.  If you close the IE browser session, you will likely lose video through VLC (unless you are using multicast.)

I use the latest version of VLC.

I hope that helps,


artarmstrong Sun, 02/19/2012 - 12:42
User Badges:


I realize this is an old post, but it is very similar to the problem I'm having.

I'm trying to stream a Cisco CIVS-IPC-4500. After much trial and error I am able to view stream on a PC using XP SP3 with IE6.0. It works, but I wouldn't call it reliable. I'm trying to stream using VLC, with hopes of eventually recording the stream.

I've used Wireshark to pull session ID from the stream to the XP machine.  However after trying several variations of the URL so far am unable to stream to VLC. Does Cisco provide documentation for proper syntax? I know from using the pwc2300 the manual is much more detailed. The URL I've used that appears like it should work is "rtsp:// RTSP/1.0"

Does anyone have experience using VLC to stream from the 4500? Any suggestions?

Any ideas would be greatly appreciated. By spec this looks like a great cam, so far it seems very finicky, and hardly worth

Using it as it is now.



This Discussion

Related Content