WAE not optimizing any traffic after 4.1.7 upgrade

Unanswered Question
Jul 22nd, 2010

I was running 4.1.5c in my WAAS environment.  I have a 612 as CM, several 512 for remote site WAEs and a 574 at a remote site.  Last  night I updated my CM to 4.1.7 and reloaded.  Management to the CM was reestablished and was able to pull info. and manage WAEs.  I then proceeded to upgrade one of my remote sites to 4.1.7.  After successful upgrade and reload, the WAE will not optimize any traffic.  It's been 16+ hours since upgrade.  Since then, I've deregistered WAE and registered back successfully.  I've reload once more but no success.  Accelerator services are running as expected.  License "enterprise" is activated.  WCCP is redirecting packets as normal from the router.  Nothing has changed environmentally during the upgrade.  I literally expected to upgrade this site to 4.1.7 code, restart the WAE and business would be back to normal.


A screenshot portion of connection statistics:


lngwae01#sho statistics connection

Current Active Optimized Flows:                      0
   Current Active Optimized TCP Plus Flows:          0
   Current Active Optimized TCP Only Flows:          0
   Current Active Optimized TCP Preposition Flows:   0
Current Active Auto-Discovery Flows:                 26
Current Reserved Flows:                              10
Current Active Pass-Through Flows:                   49
Historical Flows:                                    27


CMS info:

Device registration information :
Device Id                            = 13307                              
Device registered as                 = WAAS Application Engine            
Current WAAS Central Manager         = 10.9.10.115                        
Registered with WAAS Central Manager = 10.9.10.115                        
Status                               = Online                             
Time of last config-sync             = Thu Jul 22 15:55:06 2010


Accelerator:

lngwae01#sho accelerator

Accelerator     Licensed        Config State    Operational State            
-----------     --------        ------------    -----------------            
cifs            Yes             Enabled         Running   
epm             Yes             Enabled         Running   
http            Yes             Enabled         Running   
mapi            Yes             Enabled         Running   
nfs             Yes             Enabled         Running   
ssl             Yes             Enabled         Running   
video           No              Enabled         Shutdown  
wafs-core       Yes             Disabled        Shutdown                      
wafs-edge       Yes             Disabled        Shutdown


Are there any caveats to running a 4.1.7 WAE mixed with other 4.1.5c sites?  It looks as if WAE isn't building a topology with the other locations or discovering WAE at destination end though Connection Statistics indicate PT in Progress for flows.


Does anyone have any suggestions or has seen this before?  I haven't had much success researching this exact scenario.  Thanks!

David

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dchandler_1 Wed, 08/11/2010 - 15:00

I haven't been able to work on this since I posted question but started back on issue yesterday.  Couldn't find anything related to issue and nobody replied to this thread so apparently it was more of an issue than the experts here have seen.  So after more investigation I noticed the WCCP flow stats all were zero.  Didn't notice that before because I don't have a lot of experience with the WAAS environment so I'm learning some of the information the WAE CLI can provide to help t-shoot.  WCCP redirection was working and packet statistics for WCCP could be observed as being redirected to and from WAE.  I found an incompatibility with WCCP between router and WAE.  Had to update router IOS. After update, traffic optimization began immediately.  HTTP and CIFS tested well.


So with 4.1.7 upgrade, be prepared for the possibility of an IOS upgrade.  I didn't see any reference to this in the release notes for 4.1.7 image.

Actions

This Discussion