UCCX IPIVR 7 Editor in partial service

Unanswered Question
Jul 22nd, 2010

Hi,

Anybody got any pointers on:

1) Why the UCCX engine stays in partial service when the UCCX editor is the only item showing as not runing. Surely the editor is only run when required so shouldn't impact the engine status?

2) When the editor is run up, the engine stills stays in Partial Service as the Editot Bootstrap Manager goes into partial service. I've looked at the MEDT log file with debugging enabled and all I can see is that the engine is waiting for the bootstrap manager to move out of partial sercice.

237: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-4-ON:Enabling WARNING messages
238: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-5-ON:Enabling NOTICE messages
239: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-6-ON:Enabling INFORMATIONAL messages
240: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-ON:Enabling DEBUGGING messages
241: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-OFF:Disabling XDEBUGGING messages
242: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-OFF:Disabling XDEBUGGING2 messages
243: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-OFF:Disabling XDEBUGGING3 messages
244: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-OFF:Disabling XDEBUGGING4 messages
245: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-OFF:Disabling XDEBUGGING5 messages
246: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:Bootstrap Manager: UNKNOWN -> INITIALIZING
247: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-5-ModuleStart:Module has successfully started: Module Name=Bootstrap Manager-4652
248: Jul 22 16:59:05.186 BST %MEDT-GENERIC-5-ModuleStart:Module has successfully started: Module Name=Bootstrap Manager-4652
249: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-6-MGR_INITIALIZING:Bootstrap Manager initializing:
250: Jul 22 16:59:05.186 BST %MEDT-MGR_MGR-7-UNK:Still constructing. Set state to initializing...
251: Jul 22 16:59:05.186 BST %MEDT-MGR_MGR-7-UNK:State is the same => INITIALIZING, no change
252: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:ClusterProfileInfo::Successfully copied profile.ini to profile.ini.bak
253: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:BootstrapManager.initConfig(), bootstrap service hosts=[Ljava.lang.String;@1ca209e
254: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:BootstrapManager.init(): hostBS=false,BS Hosts size=1
255: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:BoostrapManager.init(): BS Host IP=172.16.43.170
256: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-7-UNK:Bootstrap Manager: INITIALIZING -> PARTIAL_SERVICE
257: Jul 22 16:59:05.186 BST %MEDT-BOOTSTRAP_MGR-1-MGR_PARTIAL_SERVICE:Bootstrap Manager in partial service:
258: Jul 22 16:59:05.186 BST %MEDT-MGR_MGR-7-UNK:Still constructing. Set state to initializing...
259: Jul 22 16:59:05.186 BST %MEDT-MGR_MGR-7-UNK:State is the same => INITIALIZING, no change
260: Jul 22 16:59:05.186 BST %MEDT-MGR_MGR-7-UNK:Loading configured Config Manager from properties file => com.cisco.config.impl.RemoteConfigManagerImpl
261: Jul 22 16:59:05.201 BST %MEDT-LOG_MGR-6-CATALOG_LOADED:Log catalog loaded: Catalog=MEDT_CFG_MGR

Thanks

Jed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jedellerby Tue, 08/10/2010 - 08:41

Hopefully I have my answer to this question.

The editor itself has no impact in the status of the engine, which is what I had expected/hoped ... so it a red herring in my case an not relevant. The reason I have partial service in this scenario is because of bug ID CSCtb77537. I have yet to confirm 100% this is the case as I need to upgrtade the CUCM the 7.1.3 SU2 to confirm it fixes the issue.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtb77537

Jed

Actions

This Discussion