Internet connection lost after VPN established

Unanswered Question
Jul 23rd, 2010
User Badges:

It's common problem I think.


I do not  have connection after VPN through PPTP is established.

My VPN  connection was made according to this tutorial:

http://www.cisco.com/en/US/tech/tk827/tk369/technologies_configuration_example09186a00801e51e2.shtml


How to make  it work ??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Federico Coto F... Sat, 07/24/2010 - 17:05
User Badges:
  • Green, 3000 points or more

Hi,


When you connect via PPTP all traffic is going to be sent through the tunnel because it's not like an IPsec client where you can define split tunneling on the server side.


I remember there was an option under the windows client OS where you define gateway precedences and so make certain traffic go over the tunnel (not all). But if you succeed enabling split tunneling, is done on the client side (as opposed to the server side on IPsec).


Federico.

pwolsza_wolfik1 Sun, 07/25/2010 - 01:14
User Badges:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:Standardowy; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Yes, indeed. There is an option "use default gateway in remote site" disable this option helps but after that I'm loosing LAN network behind router.

shaun.cooney Sun, 07/25/2010 - 03:13
User Badges:

In your VPN TCP/IP properties in Windows select the Networking Tab and select properties of TCP/IPv4.
Then select Advanced abd untick the default "Use Default Gateway on Remote Network"

Hope that helps

pwolsza_wolfik1 Tue, 07/27/2010 - 02:27
User Badges:



/* Style Definitions */ table.MsoNormalTable {mso-style-name:Standardowy; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Yes, I know this option.

Unfortunately using it do not allow to connect to computers behind the router, what I could without enabling option in IP configuration on local host.

Edison Ortiz Tue, 07/27/2010 - 04:57
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

As others mentioned, you need to disable the gateway of last resort for the VPN and if you want to add the specific networks sitting behind the router, you need to manually added to the host routing table with the 'route add' command.


This link has a tutorial:

http://www.howtogeek.com/howto/windows/adding-a-tcpip-route-to-the-windows-routing-table/


Regards,


Edison

Edison Ortiz Tue, 07/27/2010 - 15:25
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You can configure some scripting for that.


Please remember to rate helpful posts.

Actions

This Discussion