Having problems with static route.

Answered Question
Jul 23rd, 2010
User Badges:

A picture of my network is attached. The instructions follows the HQ router config.


I am trying to set up two static routes on HQ router for B1 network and B2 network. Due to the IP address schemes I am assuming I would need to do two Summary Routes.


HQ Config:



Current configuration : 868 bytes

!

version 12.3

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname HQ

!

!

!

enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!

!

!

!

!

!

!

!

no ip domain-lookup

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.64.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.65.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

ip address 10.0.0.1 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

ip address 10.0.0.5 255.255.255.252

clock rate 64000

!

interface Vlan1

no ip address

shutdown

!

ip classless

ip route 192.168.0.0 255.255.252.0 10.0.0.6

ip route 172.0.0.0 255.252.0.0 10.0.0.2

!

!

!

!

!

banner motd ^C** Authorized users only.**^C

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

!

end



Here are the instructions that were given to me to do the lab:


Introduction:

This activity focuses on basic device configurations and static routing. The addressing scheme has already been determined. Once you have configured all devices, you will test for end-to-end connectivity and examine your configuration.

Learning Objectives:

  • Cable the devices.
  • Apply a basic configuration to the devices.
  • Configure static and default routing.
  • Test connectivity and examine the configuration.

Task 1: Cable the devices.

Cable the networks according to the topology taking care that interfaces match the labels shown in the activity. HQ is the DCE side of both WAN links.

Task 2: Apply a basic configuration.

Configure the routers with basic configurations including addressing.

  • For the WAN links, assign the first address to HQ and the second address to the other router
  • For the LANs, assign the first address to the router interface and the .10 address to the PCs.
  • Use cisco as the line passwords and class as the secret password.
  • Use 64000 as the clock rate.

Task 3: Configure static and default routing

  • HQ should have exactly two static route.
  • B1 and B2 should have one default route.

Task 4: Test connectivity and examine the configuration.

Step 1 – Test connectivity.

  • You should now have end-to-end connectivity. Use ping to test connectivity across the network
  • Troubleshoot until pings are successful.

Step 2 – Examine the configuration.

Use verification commands to make sure your configurations are complete.



Attachment: 
Correct Answer by Jon Marshall about 6 years 10 months ago

jdbaby0504 wrote:


I can not ping from network to network but I can ping to directly connected interfaces. I am summarizing on HQ router.


I am trying to summarize the networks:

172.24.0.0

172.25.0.0

172.26.0.0

172.27.0.0

I am using command

ip route 172.0.0.0 255.252.0.0 10.0.0.2


I am slo trying to summarize the networks:

192.168.0.0

192.168.1.0

192.168.2.0

192.168.3.0

I am using command

ip route 192.168.0.0 255.255.252.0 10.0.0.6


Okay -


172.0.0.0 255.252.0.0 =


172.0.0.0

172.1.0.0

172.2.0.0

172.3.0.0


so you need to use


172.24.0.0 255.252.0.0


Your 192.168.0.0  255.255.252.0 summary is correct.


So is it anything you can't ping or just the 172.x.x.x networks ?


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Fri, 07/23/2010 - 11:41
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

What is your actual question ? Are you saying after entering the static routes at HQ you cannot ping anything ?


Jon

jdbaby0504 Fri, 07/23/2010 - 11:56
User Badges:

I can not ping from network to network but I can ping to directly connected interfaces. I am summarizing on HQ router.


I am trying to summarize the networks:

172.24.0.0

172.25.0.0

172.26.0.0

172.27.0.0

I am using command

ip route 172.0.0.0 255.252.0.0 10.0.0.2


I am slo trying to summarize the networks:

192.168.0.0

192.168.1.0

192.168.2.0

192.168.3.0

I am using command

ip route 192.168.0.0 255.255.252.0 10.0.0.6

Correct Answer
Jon Marshall Fri, 07/23/2010 - 12:04
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

jdbaby0504 wrote:


I can not ping from network to network but I can ping to directly connected interfaces. I am summarizing on HQ router.


I am trying to summarize the networks:

172.24.0.0

172.25.0.0

172.26.0.0

172.27.0.0

I am using command

ip route 172.0.0.0 255.252.0.0 10.0.0.2


I am slo trying to summarize the networks:

192.168.0.0

192.168.1.0

192.168.2.0

192.168.3.0

I am using command

ip route 192.168.0.0 255.255.252.0 10.0.0.6


Okay -


172.0.0.0 255.252.0.0 =


172.0.0.0

172.1.0.0

172.2.0.0

172.3.0.0


so you need to use


172.24.0.0 255.252.0.0


Your 192.168.0.0  255.255.252.0 summary is correct.


So is it anything you can't ping or just the 172.x.x.x networks ?


Jon

jdbaby0504 Fri, 07/23/2010 - 12:11
User Badges:

Thanks Jon that worked perfectly. Just one question can you direct me to where I can get more info on route summarization?

Jon Marshall Fri, 07/23/2010 - 12:31
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Glad to help and thanks for rating.


Not sure where to go to be honest. I'll have a hunt around. When you summarise you can do it with binary but after a while it becomes easier to work it out in your head ie. in your example -


172.24

172.25

172.26

172.27


so you want to summarise the above 4 networks. We'll do it in the steps i took -


1) You need to summarise 4 networks. The first network is 172.24. Is 24 a multiple of 4 = yes.

2) Because 24 is a multiple of 4 you know that you can start with 172.24. and cover the next 3 network ie. 25,26,27

3) To get the actual subnet mask for 4 networks - 256 - 4 = 252. So the 2nd octet is 252


Lets assume another example to show how it doesn't always work as neatly. You want to summarise in one statement -


172.22

172.23

172.24

172.25


Using the same steps above -


1) 22 is not a multiple of 4. So you know that you cannot summarise this with a 252 subnet mask.

2) What is the next subnet mask up from 252 which covers 4 networks. It is 248 which covers 8 networks ie. 256 - 248 = 8

3) Will an 248 subnet mask work. Well if you go up in 8's it goes networks 0 -7 , 8 - 15 , 16  - 23 , 24 - 31, 32 - 39 etc.

4) Looking at the 4 networks you are summarising even that won't work because the 4 networks do not fit into one of the above ranges provided for by a 248 mask.

5) next subnet mask up is 240. 256 - 240 provides 16 networks. So your ranges are 0 - 15, 16 - 31, 32 - 47 etc..

6) So you can see that now the 4 networks fit in the range  16 - 31.


So 172.16.0.0 255.240.0.0 would cover your networks but it's important to realise you also cover a lot more networks ie. 172.16 - 21 & 172.26 - 31 are also included.


Note that i said it should be summarised in one statement. If you were prepared to use 2 you could do -


172.22.0.0 255.254.0.0

172.24.0.0 255.254.0.0


the reason i used one statement was i wanted to point out that just because you have 4 networks to summarise doesn't necessarily mean you can always just assume a 252 subnet mask.


Thats how i do it in my head. Hopefully that has helped although if it has confused you more i apologize.


Jon

jdbaby0504 Fri, 07/23/2010 - 12:48
User Badges:

Thanks for the info I will definitely put it to use.

Actions

This Discussion