Slow Internet Using 2621XM

Unanswered Question
Jul 24th, 2010
User Badges:

Hi everyone,


I have recently switched my cable internet connection over to a Cisco C2621XM replacing my old Netgear ISP provided router. Before the switch my internet was lightning speed. When I clicked "Home" or entered a URL I would have the site fully loaded in a second or two but now it's taking around 8-10 seconds to do the same thing. Maybe this isn't particually slow but it gets somewhat frustrating as i'm sure you will understand.


My current setup is ---[cable modem]---[2621xm]---[switch]---

To confirm that this wasn't a switch issue I have tried several switches including a Cisco 3500 series and several off the shelf ISRs including a Netgear and a D-Link all with no avail.


The memory and CPU never go above 30%.


My config is below. Any help is greatly appreciated!


Cheers!

Shaun


ip inspect log drop-pkt
ip inspect max-incomplete low 100
ip inspect max-incomplete high 1100
ip inspect one-minute low 100
ip inspect one-minute high 1100
ip inspect udp idle-time 15
ip inspect dns-timeout 2
ip inspect tcp idle-time 600
ip inspect tcp synwait-time 10
ip inspect name CBAC-IN-OUT ftp
ip inspect name CBAC-IN-OUT http
ip inspect name CBAC-IN-OUT rtsp
ip inspect name CBAC-IN-OUT tcp
ip inspect name CBAC-IN-OUT udp
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3


interface FastEthernet0/0
description #### TO INTERNET ####
ip address dhcp
ip access-group FIREWALL in
no ip redirects
no ip proxy-arp
ip nat outside
ip inspect CBAC-IN-OUT out
no ip virtual-reassembly
duplex auto
speed auto
no cdp enable


interface FastEthernet0/1
description #### TO LAN ###
ip address 10.1.1.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside
no ip virtual-reassembly
duplex auto
speed auto


ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip nat inside source list ACL_NAT_ADDRESSES interface FastEthernet0/0 overload


ip access-list standard  ACL_NAT_ADDRESSES

  permit ip 10.0.0.0 0.255.255.255





router#show int f0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0011.bb22.5b20 (bia 0011.bb22.5b20)
  Description: ### TO INTERNET ###
  Internet address is x.x.x.x
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:15, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 55000 bits/sec, 3 packets/sec
  5 minute output rate 3000 bits/sec, 4 packets/sec
     1727555 packets input, 871612830 bytes
     Received 611 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1108027 packets output, 189986330 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 5 deferred
     4 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


router#show int f0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is AmdFE, address is 0011.bb22.5b21 (bia 0011.bb22.5b21)
  Description: ### TO LAN ###
  Internet address is 10.1.1.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:05, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2000 bits/sec, 2 packets/sec
  5 minute output rate 43000 bits/sec, 3 packets/sec
     1101009 packets input, 191160371 bytes
     Received 639 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1699094 packets output, 865312348 bytes, 0 underruns
     0 output errors, 2 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 5 deferred
     1 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Lynch Mon, 07/26/2010 - 11:00
User Badges:
  • Cisco Employee,

Hey Shaun,


Just to clarify, your previous setup was as follows, correct? -


Modem -- Netgear router -- Switch -- Users


Have you tried connecting directly into the 2621XM to test the internet speed and if so, what did you find?  Also, if you remove 'ip inspect' and/or the ACLs from these interfaces, does the problem clear?


Brandon

shaun.cooney Mon, 07/26/2010 - 11:59
User Badges:

Hi Brandon,


Thanksd for your reply. Yes you are correct, that was my previous setup although the Netgear router acted as both a router and a switch for a while until I needed more capacity.


I am currently plugged directly into the Router using an x-over cable. I have (quickly) removed all ACLs and disabled CBAC. It seems that this doesn't affect anything. The speed is still slow.


Any other thoughts?


Thanks,

Shaun

Actions

This Discussion