TenGigabitEthernet vs TwinGig converter

Unanswered Question
Jul 25th, 2010

Hi Guys,

I have a 2 Cat 4510-E each of them has 2 supervisor Engines. They are linked thru 20Gig etherchannel link. Sw1-Te5/1 to Sw2-Te5/1 and Sw1-Te6/1 to Sw2-Te6/1. I convert SW2-Te5/2 into TwinGig and insert 2 SFPs. Then I use the command hw-module module 5 port-group 2 select gigabitethernet to switch from TenGig to Gig. But the port does not come up. When I issue the command Show hw-module module 5 port-group I can see that the port-group 2 is inactive. Would you please give me a clue on how to activate the port?


Your help is greatly appreciated

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
darany111 Sun, 07/25/2010 - 18:12

Thanks Reza. I am sorry I forgot to mention that. It is Supervisor Engine 6E

Reza Sharifi Sun, 07/25/2010 - 19:02

Yes, it is defiantly supported in you sup.  I am actually using the TwinGig converter in a couple 3750s and it works just fine without any additional command.  One thing I have noticed about TwingGig converters and that they are not very secure when inserted into the module.  Can you physically check to make sure the converter is all the way in?


HTH

Reza

Marvin Rhoads Sun, 07/25/2010 - 20:52

Does "show inventory" reveal that the converter module has been recognized by the IOS?


Echoing the earlier reply, reseating may be in order.

darany111 Mon, 07/26/2010 - 05:38

Thank you Mklemovitch. Yes a show inventory display both the converter module and the SFPs 1000BaseSX


NAME: "Linecard(slot 5)", DESCR: "Supervisor 6-E 10GE (X2), 1000BaseX (SFP) with 2 10GE X2 ports"
PID: WS-X45-SUP6-E     , VID: V07  , SN: JAE1352SP49


NAME: "TenGigabitEthernet5/1", DESCR: "10Gbase-LX4"
PID: X2-10GB-LX4       , VID: V04  , SN: HCT13430363


NAME: "Converter 5/2", DESCR: "Converter Module"
PID: CVR-X2-SFP        , VID: V01  , SN: CAT114052ST


NAME: "GigabitEthernet5/5", DESCR: "1000BaseSX"
PID: Unspecified       , VID:      , SN: FNS13460USU


NAME: "GigabitEthernet5/6", DESCR: "1000BaseSX"
PID: Unspecified       , VID:      , SN: FNS13460TAR

I also changed the Fiber cable  and made sure the trunk config between the switches in accurate. But I still do not have a link.


Thank you.

Marvin Rhoads Mon, 07/26/2010 - 06:57

I suspect I know what's going on here. I ran into this on a 4900M.


When you want to use a mix of 10 GE X2 and GE SFPs using Twin-gig converters, you are limited to doing one or the other in a given port group which is serviced by a single stub ASIC internal to the switch. This limitation is referred to in the 4500 configuration guide. See http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/52sg/configuration/guide/sw_int.html#wp1084402 .


That particular documentation cite doesn't specifically address the Supervisor 6-E but I suspect that you can only do 10 GE (one or two X2's) or 1 GE (up to four using Twin-Gig converters and SFPs) in a given Catalyst 4500 Supervisor 6-E module.


I'm unable to confirm this in the documenttion, but the TAC should be able to do so for you.

Marvin Rhoads Tue, 07/27/2010 - 04:33

I hope that fixes the OP's issue. I note that the reference you cited says:


"you can deploy (1) all 4 10-Gigabit Ethernet  ports, (2) 2 blocking ports on an active supervisor engine and 2  blocking ports on the standby supervisor engine, or (3) all 8 Gigabit  Ethernet SFP ports, 4 on the active supervisor and 4 on the standby  supervisor engine."


(emphasis addded)


It does not say that one can deploy a mix of 10 GE and 1 GE SFPs.

Matthew Blanshard Tue, 07/27/2010 - 09:22

On the sup6-e though there's two port groups, one for each 10 gig port, allowing you to configure them as you wish since there's a stub asic for each port So as long as you have shared backplane mode configured to activate all 4 ten gig ports you are good to go. 


-Matt

darany111 Fri, 07/30/2010 - 10:17

I configured Shared backplane on the switch. The result is I have now 1 port-group instead of two. This means that I dont have a separate port-group to configure as Twingig. Then end result is I will not be able to get a Tengig port and a Twingig working at the same time on the same SupE 6-E.


Am I right?

Jayakrishna Mada Fri, 07/30/2010 - 10:44

Yes thats correct.


(1) all 4 10-Gigabit Ethernet ports,or

(2) 2  blocking ports on an active supervisor engine and 2 blocking ports on  the standby supervisor engine, or

(3) all 8 Gigabit Ethernet SFP ports, 4  on the active supervisor and 4 on the standby supervisor engine.


http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/54sg/configuration/guide/sw_int.html#wp1102563


Hope that helps.


JayaKrishna

Actions

This Discussion