Help with 3550 Initial IP config to my Colo Rack

Unanswered Question
Jul 25th, 2010
User Badges:


I have just purchased a 48-port Cisco 3550 with EMI image c3550-i5q3l2-mz.121-22.EA5a.bin installed.


I have 4 class-c's from my colo provider being routed to my cabinet.  They have provided me the following IP routing information:


    WAN: x.y.104.98 255.255.255.252

    Gateway: x.y.104.97

    LAN: a.b.112.0 255.255.252.0


I will connect port 48 to the WAN drop in my cabinet.


I want the other ports to route to various subnets, which will connect to independent servers configured for the subnet. 

  e.g.

          Port 1>   a.b.112.1/26

          Port 2>   a.b.112.64/26

          Port 3>   a.b.112.128/28

          Port 4>   a.b.112.144/28

          Port 5>   a.b.112.160/30

          Port 6>   a.b.113.1/30

          Port 7>   a.b.113.4/30

          etc


How should i configure the 3550 interfaces and/or VLANs? 

How do i configure port 48 for the WAN? 

Do I have to use the IP ROUTE or IP ADDRESS commands?


I have no idea on the best method, or for that matter, a method that will work.


all current ports on the default 3550 read:

  switchport mode dynamic desirable

port 1, for whatever reason, reads:

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast

spanning-tree bpduguard enable

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 07/26/2010 - 01:48
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

strongsecure wrote:



I have just purchased a 48-port Cisco 3550 with EMI image c3550-i5q3l2-mz.121-22.EA5a.bin installed.


I have 4 class-c's from my colo provider being routed to my cabinet.  They have provided me the following IP routing information:


    WAN: x.y.104.98 255.255.255.252

    Gateway: x.y.104.97

    LAN: a.b.112.0 255.255.252.0


I will connect port 48 to the WAN drop in my cabinet.


I want the other ports to route to various subnets, which will connect to independent servers configured for the subnet. 

  e.g.

          Port 1>   a.b.112.1/26

          Port 2>   a.b.112.64/26

          Port 3>   a.b.112.128/28

          Port 4>   a.b.112.144/28

          Port 5>   a.b.112.160/30

          Port 6>   a.b.113.1/30

          Port 7>   a.b.113.4/30

          etc


How should i configure the 3550 interfaces and/or VLANs? 

How do i configure port 48 for the WAN? 

Do I have to use the IP ROUTE or IP ADDRESS commands?


I have no idea on the best method, or for that matter, a method that will work.




Jeff


The WAN port on the 3550 -


int gi0/1

no switchport

ip address x.y.104.198


then for each subnet you want to route on the 3550  you need to -


1) create a vlan in the vlan database eg.


3550(config)# vlan 10 name v10


2) create a L3 SVI for this vlan ie.


3550(config)# int vlan 10

3550(config-if)# ip address a.b.112.1 255.255.255.192

3550(config-if)# no shut


You need to do this for each subnet you want to create


3) then to allocate a server into vlan 10 -


int gi0/2

switchport mode access

switcport access vlan 10

spanning-tree portfast


remove any references to "switchport mode trunk" from the port config as this is an access port not a trunk port. In this example the server would have an IP address from the a.b.112.0/26 subnet and it's default-gateway would be the vlan 10 IP address you assigned in step 2 ie. a.b.112.1


4) turn on ip routing on the 3550 ie.


3550(config)# ip routing


5) add a default route on the 3550 pointing to the default-gateway ie.


3550(config)# ip route 0.0.0.0 0.0.0.0 x.y.104.97


That should do it. Basically you only configure the WAN port with an IP address. The subnets are configured as vlans with L3 vlan interfaces and then you simply configure the ports to be in their relevant subnets.


Jon

Actions

This Discussion